Skip navigation

HT3275: Time Machine: Troubleshooting backup issues

Learn about Time Machine: Troubleshooting backup issues
This discussion is archived

HT3275 Backup failed - "sparsebundle is already in use" - any ideas please?

6893 Views 7 Replies Latest reply: Oct 17, 2012 1:35 PM by LaPastenague RSS
rjsimpson133 Level 1 Level 1 (0 points)
Currently Being Moderated
Oct 16, 2012 2:53 AM

I attached NAS to my iMac and left backup to run overnight as apparently the first one is really really was slow!


This morning there were error messages stating backup has failed - something to do with loss of connection to server.


Tried backup from TimeMachine again and eventually got the above message.

iMac, OS X Mountain Lion (10.8.2)
  • LaPastenague Level 7 Level 7 (32,810 points)

    See C12.. this is the most common issue in Mountain Lion.. there must be a bug with the networking to the TC.


  • LaPastenague Level 7 Level 7 (32,810 points)

    Ok,, very interesting.. you are getting exactly the same error as the TC gets.. which is interesting.. basically the OS on the Mac has lost track of where the disk is..


    There is a long thread about the error -6584.. but it doesn't seem to have a clear resolution.


    I will look up the thread.. this forum has the worst search... ever.


    Did you mount the sparse bundle and verfiy it??


    See A5 in pondini troubleshooting.



    Is the Mountain Lion a clean install?


    Can you ping the NAS by name when the disk is lost?


    Do you enable the server with username and password in finder? I am not sure of the specific instructions for setting up the QNAP with TM.


    I would encourage you to use another backup software.. CCC, SuperDuper, Chonosync are the typically quoted ones. TM gives more trouble than its worth sometimes.


    You can get a check of the sparsebundle by using the option click on the TM icon.


    Anyway this is the thread.


  • Jan C Level 1 Level 1 (40 points)

    Hello Russell


    OS X uses AFP (Apple Filing Protocol, which started life as AppleTalk (a proprietary network solution)) for Time Machine (TM); like the Apple Time Capsule (TC), the QNAP NAS has that protocol installed and, therefore, it appears as a destination when you open the TM preferences. As a rule (although there are, of course, ways of using exceptions!!), no other protocol (including NFS) should be used for TM backups in order for the various elements to work well together. The setup of any NAS that can be used for TM is identical to the setup for TC.


    Did the iMac go to sleep overnight while the first backup was taking place? It might be that there was some corruption on the NAS if that happened. When attempting to start a second backup, did you ensure that the iMac stayed awake all night? The first backup is crucial and must be successfully completed in order for subsequent incremental backups to occur correctly. The reduced assessment of size of backup might have occurred because TM had worked out that the difference had already been backed up (See, and Don't forget, TM is an application that is capable of fully managing backups on internal, external (directly-connected) or networked drives (offering AFP). If the backup disk (sic) is directly connected, the backups are located in folders in a manner similar to the way they appear on the Mac's HDD; that external drive normally remains mounted by the system. On the NAS, however, TM must first mount the network drive (/Volumes/TMBackup) before generating a special type of disk image (sparsebundle) that can then be mounted to the system; only then can TM start backing up to that sparsebundle. There are, therefore, a number of places where things can go wrong, so I suggest that an 'expert' have a quick look at your system and give a more informed response. I'll be round tomorrow!!



    Mac mini (Early 2009), OS X Mountain Lion, 2GHz 8GB
  • LaPastenague Level 7 Level 7 (32,810 points)

    The sleep issues was supposedly fixed on Mountain Lion..


    As often the case with Apple nowadays .. a new idea is introduced without a huge lot of testing.



    Simply set the sleep off in system preference power saving.


More Like This

  • Retrieving data ...

Bookmarked By (1)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.