Skip navigation

Wireless printing stopped working.  Belkin router and Epson Stylus NX420.

1040 Views 4 Replies Latest reply: Nov 7, 2012 10:58 AM by shyamala14 RSS
shyamala14 Calculating status...
Currently Being Moderated
Oct 16, 2012 7:16 AM

I have been printing wirelessy without any problems for about a year and two weeks ago the wireless printing stopped working.  I updated all software for computer and printer.  I installed new cartridges, and I reset the printing system so I can print with a USB cable, but when I uplug the USB the printer won't show up in printer list even though the wireless signal on the printer indicates that it is working.  The printer has never been plugged into the router to print wirelessly like it is with an airport, but it has worked without this connection in the past.  I am not sure where the communication is getting broken.  What else can I do to get communication flowing between router, computer and printer?

iOS 6

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.