Skip navigation

Cinema display won't turn on

39024 Views 72 Replies Latest reply: Mar 4, 2014 5:12 PM by Not So Urban Legend RSS Branched to a new discussion.
  • tdong2234 Calculating status...
    Currently Being Moderated
    Aug 28, 2012 4:07 PM (in response to drPlim)

    Same problem here. Won't even turn on. Definite grounds for a Class Action Lawsuit!

  • ledi Calculating status...
    Currently Being Moderated
    Sep 2, 2012 7:38 PM (in response to MrWolvz)

    Same Problem here.

    Apple Cinema Display + MacBookPro8,2 + Lion

    This morning, the external display just stayed black. USB port is working...

  • Zekky Calculating status...
    Currently Being Moderated
    Sep 10, 2012 11:46 PM (in response to ledi)

    While not helping, i had the same problem today.

    About couple of months back, when i had the same issue, i deleted a plist file (IIRC - com.apple.PowerManagenent.plist), and the issue was resolved. Today, however, deleting the plist file didnt resolve it.  I can see the USB/Sound on the cinema display is working, however, when i plug or remove the video cable, the screens turns blue and then comes back. 

  • Jake Lance Calculating status...
    Currently Being Moderated
    Oct 13, 2012 8:18 PM (in response to MrWolvz)

    This problem just cropped up for me.


    Early 2008 Mac Pro Quad Core

    10 Gb RAM

    Nvidia GeForce 8800 GT 512 mb

    OS X 10.8.1

    Cinema HD Display 30


    After either putting the Mac to sleep, or letting it go to sleep itself, the primary display does not re-awaken and stays black.  The light in the lower right of the monitor sometimes turns on and off.  The secondary display turns on and shows what should be there.


    I followed some advice found in this forum and unplugged the mouse and keyboard usb plugs from the back of the monitor.  The monitor came to life.  I plugged the mouse and keyboard into usb ports connected to a usb hub connected to the front of the Mac Pro desktop enclosure.


    While able to use the primary monitor I followed the suggestion to go to System Preferences, Energy Saver and change Computer sleep to Never. I changed Display sleep to 3 hrs because I did not want to change it to Never.


    This results in the monitor now showing normal, but it randomly blanks out and then returns.  Sometimes for 1 second and sometimes for 5-10 secs.


    I then replaced the apple mouse with a Kensington mouse.  For the time being, this seems to have solved the problem.  It is not a final solution until I can test the computer in different scenarios.


    If this does prove to solve the problem, I would appreciate hearing from an Apple Rep telling us why an apparent faulty Apple mouse causes the monitor to blank out both permanently or randomly.


    It is easy enough to buy a new mouse but it is important to understand why this happened.

  • apples682 Calculating status...
    Currently Being Moderated
    Oct 16, 2012 10:26 AM (in response to MrWolvz)

    Having the exact same problem. My 14 month old 27" Cinema Display started flickering randomly on update to 10.8 then completely stopped working on 10.8.1. If I unplug and replug the monitor multiple times it works. Tried it with another computer with 10.8 and its the same.

     

    Out of frustration I tried switching back to my old vga monitor and noticed that it too has stopped working normally, now it only works if booted into windows, when I try booting into osx it just locks up with a blue screen.

     

    Fun stuff.

  • Jake Lance Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 16, 2012 10:40 AM (in response to apples682)

    I would be curious to know if you tried replacing the mouse.  Of course, that depends if you ever get it to boot again.  In my experience, sometimes a certain symptom is the same but the resolution can be a variety of different things.  Still, if you ever get the opportunity.......

  • apples682 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 16, 2012 10:52 AM (in response to Jake Lance)

    Jake,

     

    I either use the trackpad or the wireless apple mouse. It's a 2011 macbook pro 13".

     

    It's pretty strange, at first I was convinced it was a hardware problem on the monitor side however now I have the feeling that its related to 10.8 somehow as both the cinema display and my vga montiors are suddenly refusing to work on both my computers running osx 10.8.

  • Jake Lance Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 16, 2012 11:01 AM (in response to apples682)

    Aha, being a desktop guy I didn't think about laptop w/monitor connected.  The one thing in common between yours and mine is OSX 10.8.1. 

     

    I was a long time windows user (from 1982) and only converted to Apple in 2007.  Apple has a certain reputation for coming to the rescue of us poor users, or that is my impression.  I wonder why an Apple tech rep has not weighed in on this.  Of course, we don't know just how many users are having monitor-10.8 problems.

     

    You can only get so much help from fellow users, you need tech support from time to time.

  • apples682 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 16, 2012 12:16 PM (in response to Jake Lance)

    I agree, so far apple support has been good to me (while living in the usa). The only problem at the moment is that I am currently in a country without any official apple stores. The closest equivlent here has no idea what it could be and wants to charge me a hefty fee just to look at it.

  • TAHofhhman Calculating status...
    Currently Being Moderated
    Oct 21, 2012 6:08 PM (in response to MrWolvz)

    I recently got a new MacBook Pro and now I can't get my old Cinema Display to turn on either, even though I have the $99 adaptor. I'm really surprised to see that so many other people have the same problem. What is going on?

  • Derek Kuhl Calculating status...
    Currently Being Moderated
    Dec 2, 2012 9:51 AM (in response to TAHofhhman)

    There was a new firmware update today.  December 2, 2012.  We'll see if it fixes the problems.

  • Jeff Cairns Calculating status...
    Currently Being Moderated
    Dec 6, 2012 8:56 PM (in response to Derek Kuhl)

    The new firmware update does not fix the problem for me. I'm going to have to take the monitor in for service (again) before the Applecare I purchased for it runs out.

  • Kevin808 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 9, 2012 6:59 PM (in response to MrWolvz)

    I am having this issue as well - Mac 27" LED Cinema display.

     

    I have read elsewhere that this is a power supply issue (the one inside the monitor)  ...or sometimes a logic board issue.  But several people who have switched out the power supply with a newer part design have had good results.

     

    I really don't believe this has anything to do with the mouse, cord, plug, socket, software etc.  I believe it's an issue with hardware inside the monitor itself.

     

    You can buy a new power supply for $130 online, and you'll need a couple tools to get it open like suction cups to get the glass off and a Spudger to get it open, plus some star (Screw) drivers.  While checking out the step-by-step tear down of the thunderbolt display on iFix-It I found they sell these tools and ordered them from the site.  I'll let everyone know how it goes when I replace the PS.  I hope that's it, I really don't want to have to replace the logic board too. 

  • s_w_i_t_t_e_r_s Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 7, 2013 6:14 AM (in response to Kevin808)

    I've never once had this problem in 4 years of owning my 23" ACD. However, this morning I came into my office and the Macbook Pro was closed and the screen was frozen on the ACD. I opened the MBP and hit a few keys on the keyboard to try to wake it from sleep, but nothing happened. It had crashed. So I held down the power button for a few seconds and restarted. The ACD did not turn on. I restarted and reset the PRAM. Still did not turn on. Disconnected and reconnected the mini-display cable a few times. Still did not turn on. Tried disconnecting the power supply. Still did not turn on.

     

    Has anyone figured out a solution to this, or do I just need to suck it up and buy a new monitor?

  • Kevin808 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 8, 2013 5:55 AM (in response to s_w_i_t_t_e_r_s)

    I don't think so, see my comment above.  I'm still looking for an easy fix...  I haven't swaped out the PS yet, I figured I would try soldering in some new capacitors before I bought the new $120 power supply.  It may sound daunting but it is not that hard.  I'm going to do a video on it and if it works I will post it on youtube.  If not I'll order the new PS.  Some people report that by hooking the ACD up to a UPS (Uninteruptable Power Supply, for power outages) this solves thier problem.

     

    $10 in capcitors or...

    $120 PS or...

    $1000 Monitor.

     

    It's worth a shot.

     

    <Edited By Host>

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.