Skip navigation

HT1338: OS X: Updating OS X and Mac App Store apps

Learn about OS X: Updating OS X and Mac App Store apps

HT1338 upgraded to mountain lion and wifi keeps dropping

54622 Views 235 Replies Latest reply: Jul 25, 2013 1:42 AM by stevefromorpington RSS
  • jackflint Level 1 Level 1 (0 points)

    Today I phoned Apple as I am sick of all this ****.

    I was talked through a huge amount of stuff (much of it I can't remember) but, basically, we wiped every record of any wifi setting off the computer and started from the beginning. Set up a new location in network perfs, deleted all network details, went in to Keychain Access and deleted internet login password file, restarted router, renewed DCHP lease and also input some new DNS servers (8.8.8.8 and 8.8.4.4).

     

    All working good so far. Apparently OS X has trouble carrying over wifi and network settings from previous operating system.

  • kulyk Level 1 Level 1 (0 points)

    funny how apple would give your google's DNS server numbers.....

     

    makes one wonder

  • jackflint Level 1 Level 1 (0 points)

    Huh? Can you explain?

  • kulyk Level 1 Level 1 (0 points)

    u typed u called apple tech support they walked u thru stuff including some new DNS numbers

     

    those DNS numbers belong to google

     

     

    ok ?

  • jackflint Level 1 Level 1 (0 points)

    OK, I understand. I haven't got a clue what a DNS server is and what purpose it serves. As long as my wi-fi stays connected I really am not bothered.

  • wifiguru Level 2 Level 2 (230 points)

    kulyk,

    If you increased the lease time to 1440 and you saw the router doing a DHCP renewal 2 minutes later, then it looks like your router is performing too many DHCP renewals. Could very well be a router bug. Have you checked if there is newer firmware available for this router ?

  • wifiguru Level 2 Level 2 (230 points)

    It means your ISP's default DNS Server has issues translating domain names to IP addresses which is what the computer needs to get info from a website. This is an ISP/router issue.

  • wifiguru Level 2 Level 2 (230 points)

    Which router are you using ? Have you checked if there is a firmware update for your router ? Have you tried using the 5 Ghz band for wireless ? Try finding a cleaner channel if you are using 2.4 Ghz and switch to that channel. Try using 8.8.8.8 for your DNS Server. Delete all the items in your Preferred Network List and then reboot, re-join your network and check if the issue reproduces.

     

    If after all this the issue still reproduces, then call AppleCare and report it to them.

  • jackflint Level 1 Level 1 (0 points)

    Thanks, but that doesn't explain why my MacBook works fine (also running Mountain Lion with no changes to any settings including DNS entries). I'm not sure if the DNS entries I was told to enter actually helped solve the issue. The Apple tech guy said he had told me to change many different settings at once to eliminate all possible causes for the dropouts to save me having to keep calling back. The DNS entries I changed may only have been some sort of safeguard. I suppose I could try deleting them to see if it makes any difference but I am reluctant to fiddle with this machine now because it has worked perfectly since I called tech support.

     

    Also, for other people still having this problem, your machine may be out of warranty but if you tell them you have upgraded to ML you get free software tech support for 90 days. At least that's what happens here in the UK. Even the phone calls are free so you have nothing to lose.

  • tc4mpbell Calculating status...

    Hi everybody,

     

    I quickly clicked through the thread and didn't see any mention of this, so figured I'd let you know what (seemed to) fix it for me.

     

    My Macbook Air was dropping network connection constantly, so the internet was basically unusable.

     

    FIX: I went to System Preferences > Network, and unchecked "Ask to join new networks".

     

    Boom, browsing was back. Watched some Netflix. Joy.

     

    I read this somewhere in a post from like 3 years ago; apparently there was a bug that made it constantly be scanning and asking for new networks, even if it was connected successfully to mine.

     

    Hope this helps somebody.

  • jackflint Level 1 Level 1 (0 points)

    Guess what? Yep, it's starting to do it again . Not every 5 minutes like before, every few hours now. I can't wait for 9am... I am going to go apeshit with Apple techs this morning.

  • barcapat Calculating status...

    Hi Jack, the only solution I've found that works is to change your router settings to WPA2, then clear out Wifi settings on iMac and set new wifi connection to use WPA2 also.

    Since then (Oct 4) I've had no drop outs and I've been using my iMac a lot in that time.

    I tried lots of the other suggested fixes and they usually work for a while and then wifi drops out and back to usual rubbish.

    Here's more details - http://www.patwalsh.co.uk/osx-mountain-lionwifi-issue-finally-a-solution/

  • roxan Level 1 Level 1 (0 points)

    i confirm the report of barcapat. WPA2 and reset of settings are key.

     

    It remains a major problem because you are not meant to ask network administrators to grade their me because you upgrade to mountain Lion! But if you are ready to drop WEP and all your devices that are not WPA2-compatible (including potentially your router) then you have a work around for your Apple upgraded OS.

     

    I still have regular "slow down" for which a reboot is required, but no more drop out.

  • T4K3N Level 1 Level 1 (0 points)

    I can honestly say that this problem just went away for me. I didn't reset or do anything to my computers or router. Guess I just got lucky

  • jackflint Level 1 Level 1 (0 points)

    Thanks. I can confirm that changing my router security to WPA seems to have finally cured this problem. My router is old and is not WPA2 compatible (only WPA). I also have an old PC running Win XP for the kids and that is not WPA2 compatible either. Thankfully, changing the router to WPA has done the trick. I am still furious with Apple for not highlighting this problem, they must surely know about it all.

1 ... 7 8 9 10 11 ... 16 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.