Skip navigation

iOS 6 disables wi-fi on sleep mode - disappointing

91039 Views 249 Replies Latest reply: Nov 17, 2013 8:51 AM by Bill Stephenson RSS Branched to a new discussion.
  • abfield Level 1 Level 1 (0 points)

    He's not wrong. Maybe everyone is getting caught up on the technicality of "drop". However, there are hundreds of posts on forums since the release of iOS 6 about this problem. Whatever you want to call it, it's an issue. Like I mentioned in my earlier post, I have an iPad 2 WiFi-only. When I'm in meetings at work it's basically a useless device. A few seconds after it sleeps it drops the WiFi connection so I no longer receive push emails, IMs, FaceTime calls, etc.

     

    Like I also previously mentioned, it does not do this on my home WiFi which is WAP (work is WPA2 Enterprise). It's doing the same thing on my iPhone 4S with iOS 6. When it's plugged into power this is not a problem. So, they obviously coded it to drop when not connected to power to save battery. This was not happening in iOS 5.

     

    That is what's happening. That is the bottom line. Call it whatever you want. I'm calling it a problem.

  • Lawrence Finch Level 7 Level 7 (24,480 points)

    There are so many posts about previous versions of iOS dropping WiFi when asleep also. In fact, it has been a major complaint for 5 years. If you insist I will gather links to the threads complaining about it, but you can certainly do a search yourself for them.

     

    As a start you can read this 2+year old thread, which has hundreds of posts about WiFi being off when the phone is asleep:https://discussions.apple.com/thread/2450738

     

    I have a 3GS that still has iOS 5.1.1 on it. I just verified that it drops WiFi about 30 seconds after it goes to sleep. I did it using the only reliable way to determing if WiFi is off, by pinging it from another computer on my network.

  • abfield Level 1 Level 1 (0 points)

    This is different. Just do this please... Take a device running iOS 6 and turn on airplane mode and then enable just WiFi. Put it to sleep and leave it for a few minutes (not plugged in). Send yourself an email or anything that would normally be pushed to the device. It doesn't work. I believe your ping test but there is something in iOS 5 that either polls or does something similar to receive pushes when sleeping and only on WiFi.

     

    I'm explaining to you exactly what is happening with the same EXACT iPad 2 and same EXACT iPhone 4S before iOS 6 and after iOS 6. It now works differently. Same device I took to meetings a few months ago now behaves differently. Why? Because something is different. I don't know how else to explain it.

     

    Are you telling me that my iPad 2 WiFi-only is working as designed? If so then it's useless.

     

    edit: And as mentioned in an earlier post, I have no problems on my WPA network at home. So, perhaps it's something with WPA2 (or other encryption).

  • abfield Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 16, 2012 7:51 AM (in response to abfield)

    One more test... My iPad had been sitting in my work bag for about 12 hours. I just pulled back the smart cover and the WiFi logo was there and all my notifications (emails, messages, etc.) were already on the device. Therefore it's been connected somehow. However, when I'm at work on the same WiFi network as when I had iOS 5, this same behavior does not happen.

  • Lawrence Finch Level 7 Level 7 (24,480 points)
    Currently Being Moderated
    Oct 16, 2012 9:04 AM (in response to abfield)

    abfield wrote:

     

    This is different. Just do this please... Take a device running iOS 6 and turn on airplane mode and then enable just WiFi. Put it to sleep and leave it for a few minutes (not plugged in). Send yourself an email or anything that would normally be pushed to the device. It doesn't work. I believe your ping test but there is something in iOS 5 that either polls or does something similar to receive pushes when sleeping and only on WiFi.

    OK, I did this test, first with a 3GS on 5.1.1, then with a 4S on iOS 6. For both I started a ping against the phone's IP address. The 4S was in airplane mode with WiFi on, the 3GS has a deactivated SIM so it does not have cellular service.

     

    On the 3GS I waited until the ping timed out. I then sent an email to my icloud address. The 3GS on 5.1.1 received the email, and the ping showed about 10 seconds of WiFi before it went to sleep again.

     

    I repeated the test on the 4S with iOS 6. I again waited until the ping timed out, then sent an email. The email was received on the 4S with iOS 6, and the ping showed that WiFi awakened briefly for about 10 seconds.

     

    I repeated the test again on the 4S with iOS 6, this time with airplane mode off, cellular data on AND WiFi on. The email was received on the 4S with iOS 6, and the ping showed that WiFi came on for about 17 seconds.

     

    I also considered the possibility that a phone being pinged might behave differently from one having no stimulation at all. So I repeated the test on the 4S with airplane mode on and the 3GS with no cell plan and WiFi on both, but without ping running. The results were the same. The message was delivered to both iOS 5.1.1 and iOS 6.

     

    For all of the cases with cellular data off there was a delay in delivery of up to a couple of minutes, so what is likely happening is the phone periodically polls for content when cellular data is off. There was no delay with cellular data on.

     

    Finally, thinking there might be something different about iCloud I repeated the tests again, this time using a MS Exchange email account. With cellular data off and WiFi on for both iOS 5.1.1 and iOS 6 mail was delivered to the Exchange account.

     

    The bottom line is iOS 6 appears to behave exactly the same way iOS 5.1.1 did on my 2 phones. I can't test 5.1.1 with cellular data because it doesn't have a data plan and I don't have a SIM adapter to put the SIM from the 4S in the 3GS.

  • abfield Level 1 Level 1 (0 points)

    Thank you for taking the time to do the tests. What security do you use on your WiFi network? If it's something other than WPA2, that could explain things. My devices work exactly as you state when I'm at home (WPA) but not when I'm in the office (WPA2 Enterprise).

  • Lawrence Finch Level 7 Level 7 (24,480 points)
    Currently Being Moderated
    Oct 16, 2012 9:27 AM (in response to abfield)

    I use WEP at home. I know I should be using something stronger, but I've procrastinated because I have 15 devices I would have to reconfigure.

  • ediab Calculating status...
    Currently Being Moderated
    Oct 16, 2012 9:31 AM (in response to yanipopo)

    yesterday i have the same problem but today i did the following:

    - enter wifi and tap "forget this network"

    - reboot the router

    - re-connect to the network again

    it works

  • OzzzzY Calculating status...
    Currently Being Moderated
    Oct 16, 2012 11:39 AM (in response to yanipopo)

    Hi Everyone,

     

    I completely agree that it is a shame. My iPhone was perfect till 6.0 update. At home I have very bad coverage, and before the update everything is fine. Now apps like Skype behaves silly couse I think they get stuck somewhere with the constant change of the 3G/wifi.

    I agree that it should be up to the user how the phone behaves when sleeping.

     

    Couse my solution to the problem is just the opposite what apple tries to do.

    I just disable the auto-lock and let the screen working brightly for many hours.

    I guess this does not help to the battery or screen life.

     

    As long as there is no solution, this looks the best way to me.

    And if the phone stops working this way Apple will have to pay it. So up to them.

  • Sk8Dreams Level 3 Level 3 (840 points)

    Lawrence FInch - I switched from WEP to WPA and didn't have to reconfig anything.  I kept the same hex passcode, and everything connected up just fine.  Devices I had at the time are 1 iPhone 4, 1 Roku, 1 Lenovo PC, 1 Lenovo laptop, and 1 netbook.  Just be sure the passcode doesn't get switched to upper case, because WPA looks at that, while WEP does not (being hex to begin with).

  • Lawrence Finch Level 7 Level 7 (24,480 points)
    Currently Being Moderated
    Oct 16, 2012 3:10 PM (in response to Sk8Dreams)

    Thanks for the tip! I'll try it.

  • danfromaurora Calculating status...
    Currently Being Moderated
    Oct 23, 2012 7:04 PM (in response to yanipopo)

    I too am experiencing issues with my new iPhone 5 going to sleep and not waking up for iMessages or showing offline for Skype.  The difference is I also own a 4S with iOS 6 and it behaves the same as it did on iOS 5.  I did not notice this until I traveled outside the US.

     

    I have reviewed several threads and as I am perform a new install on the 5 right now I decided to conduct some tests by sending myself some iMessages from my my MBP and here is what I have observed:

     

    Test #1: Airplane mode On, WiFi On, send iMessage to myself via MBP after iPhones have locked their screens for at least 20 seconds = both phones receive iMessage almost simultaneously.

     

    Test #2: Airplane mode Off, Cellular Data Off, WiFi on, send iMessage to myself via MBP after iPhones have locked their screens for at least 20 seconds = both phones receive iMessage almost simultaneously.

     

    Test #3: Airplane mode Off, Cellular Data On, Data Roaming Off, WiFi on, - In this case the 4S has a local sim and the 5 is roaming. Send iMessage to myself via MBP after iPhones have locked their screens for at least 20 seconds = 4S receives iMessage immediately and nothing from 5 until I wake it up.

     

    Based on this I appears to me that in Test #3, once Cellular Data is turned on that WiFi goes to sleep shortly after the screen lock. The 4S is receiving iMessage over cellular but since the 5 has roaming turned off it basically has no network connectivity. This seems like a bug to me as the 5 should behave as it does in Test #2 but since cellular data is on I do not think it takes roaming switch into consideration.

     

    Test #4: Same as Test #3 but iPhone 5 is plugged into power. Both phones receive iMessage almost simultaneously.  Appears that once the 5 is plugged into power the WiFi no longer sleeps.

     

    So at this point to have the 5 work while unwilling to roam on another carrier's data network, I need to keep airplane mode on or be connected to power.

  • p47x Calculating status...
    Currently Being Moderated
    Oct 24, 2012 4:48 AM (in response to yanipopo)

    Having the same problem with my iphone 4s after upgrading to IOS 6.

     

    I have to constantly unlock my phone to check if someone sent me mails or messages on whatsapp or skype.

     

    This is extremely frustrating. I hope they will come up with a solution to fix this.

  • simcam68 Calculating status...
    Currently Being Moderated
    Oct 24, 2012 9:29 PM (in response to p47x)

    I am right there with you, I have the same exact problem at work. I typically connect to companies guest networks when I am onsite there. With 5.1.1 I would receive emails and imessages without unlocking the phone. Now everytime it goes to sleep it disconnnects and I get bounced to the "acceptable usage" page of the network I am connected to when I go to check manually. This is now the rule when I am at customers locations, before it was the exception. FAIL.

     

    I hope that apple fixes this "improvement" soon. I feel like I'm back using my 3g again with ios3. At least give me an option to save battery with wifi or not. It's not a problem at home as it reconnects there very quickly, but it still does not push emails or imessages while asleep.

     

    Most times I don't have a cell signal because of the buildings I'm in, so I am cut off when the wifi turns off.

  • bdiamond18 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 31, 2012 6:06 AM (in response to simcam68)

    I apologize if I haven't read through all 7 pages of this thread, but I thought I would add my two cents on this behaviour, as I have a unique scenario that really pinpoints exactly what is happening on my phone.

     

    I have an iPhone 5, I was on Android previously.

     

    In my office, we are working on deploying Microsoft Lync.  Currently the client will only work on mobile devices outside of the office (IE, on Cell network, or wifi outside of the building).  Mobile devices will not be able to connect to Lync when on office Wifi.

     

    When my phone is asleep, I get a notification of a new message in Lync, and when I go to check it, I get told I can't connect to the Lync server.  I also see my signal quickly change from LTE to the wifi icon when I wake the phone up.

     

    The reason that this behaviour is bothersome, is I am wondering what this is doing for my data consumption while the phone is sleeping.  Should be consuming data on wifi, but instead is taking data from my Cell plan.

1 ... 5 6 7 8 9 ... 17 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (6)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.