2 Replies Latest reply: Oct 16, 2012 6:26 PM by roam
p8tranator Level 1 Level 1 (0 points)

I recieced a message that Firefox 16 is the last version of Firefox that works with Mac OS X 10.5. To keep my personal information safe, we recommend you switch to a newer computer capable of running Mac OS X Mountaian Lion (10.8) if possible. Apple stopped supporting Mac OS X 10.5 in 2009 and many software makers have either dropped support for it or soon will. Your best bet is to get a computer capable of running the latest version of Mac OS X - Mac OS X Mountain Lion (10.8). This is the most secure option and will allow you to run the latest and greatest Firefox.

Would I be in the same situation if I used Safari? Do I need to upgrade? Is my mac not secure any longer?


Mac OS X (10.5)