Skip navigation

Thumbnails building on launch, impermanent and missing several years

279 Views 9 Replies Latest reply: Oct 22, 2012 11:35 AM by Patrick Snook RSS
Patrick Snook Level 1 Level 1 (10 points)
Currently Being Moderated
Oct 17, 2012 4:21 AM

When I open it, Aperture always wants to generate thumnails (70,000+, for a library of 190,000 referenced files).

 

I'm working with a fresh install of 3.4, a new plist.

 

If I let the thumbnails build until done, it apparently makes no difference the next time (after quitting and relaunching Aperture).  The same thing happens.

 

Looking at the package contents, I see that although I have pictures in my referenced library going back to 2005, the Thumbnails folder shows folders beginning at 2008.  So several years of thumnails are evidently missing.  (That's probably around the time I switched from iPhoto to Aperture as my photo organizer and editor.  That might be a red herring, or is there something qualitatively different about those former-iPhoto Masters?)

 

So how do I make a permanent set of thumnails for those missing years, so that I don't have to either wait a long time for the program-slowing activity to complete, or manually cancel the 70,000+ temporary rebuild every time I launch Aperture?

 

Thanks for any advice.

 

Patrick

  • léonie Level 8 Level 8 (46,700 points)

    So how do I make a permanent set of thumnails for those missing years,

    Patrick,

    you can select the images (for example create a smart album with an added "Date" rule: Capture year is before 2008.  Then use the command "Photos > Generate Thumbnails".

     

    But look at the Thumbnails folder for 2008, which images it contains. The folders inside the Aperture Library are not organized by "Capture Date", they are organized by import session. Your images imported in 2008 may very well have a capture date of 2005. All my iPhoto imports from 2003 show up in my Aperture library in folders from 2010.

     

    What are the years that you see in your "Masetrs" and "Previews" folder? There the same rules apply.

  • léonie Level 8 Level 8 (46,700 points)

    Patrick,

    I'm still trying to figure out what I changed (if anything) that might have caused the spinning beach ball.  I can think of only one thing, and it has to do with previews--but I had better put that aside for now,

    That is a frequent cause - a single corrupted image or incompatible video can cause Aperture to hang, it will try over and over again to generate a preview and not succeed. Then the only help is to lauch Aperture with the Shift key held down, to defer the generation of previews.

     

    Do you have imports from iPhotoin your library - smart iPhoto albums?

  • léonie Level 8 Level 8 (46,700 points)

    And since I don't currently want Previews, would you predict that it will be OK to drag that folder to the trash?

    It would be safer to let Aperture delete the previews.

    • Disable all options to automatically generate previews in the Preferences > Previews tab.
    • Select all images at once, e.g. from the "Photos" view and select from the main menu bar "Photos > Delete Previews".

     

    Is there a way to track down corrupted files (a Preview, or a Master, or whatever)?

    I supect corrupted original files from your most recent import (video, original image), and to find them will be a lot of work.

    And sometimes an import from iPhoto can cause this (smart iPhoto albums).

     

    Your corrupted image will be the first, that does not have a preview, since Aperture probably hangs, when it tries to generate the preview. So if you want to find the culprit, delay the deletion of previews.

    One approach to find the corrupted image/video is to select the last imported project; then to force the creation of previews for some of the images, in small batches (Photos > Update Preview). If that succeeds, the images are o.k., if not, then the corrupted image is in the batch of images you just tried.

     

    When you have isolated the image, remove it from the library.

  • léonie Level 8 Level 8 (46,700 points)

    But export-import might be a useful extra step to add to the list of troubleshooting steps.

    Clever!   After exporting, did you delete the files from the library?

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.