Skip navigation

iPhone uses wrong exchange account for outbound email

11775 Views 25 Replies Latest reply: Jun 12, 2013 11:52 AM by Arderr RSS
  • RaslDasl2 Calculating status...

    I fixed my issue by changing the address on my Microsoft account to another email address.

  • 1-800-MACINTOSH Calculating status...

    For Lisa.  Try this.  Delete the Hotmail account then add it again.  This time do NOT choose "Hotmail" as the type of account.  Choose "other" as the type.  Then just fill in the rest.  I had the exact same problem and this was the only way to fix it.

  • StephenWong Calculating status...

    I have the exact same problem. Did Apple do anything to fix this? this is a silly problem

  • AlanSaysYo Calculating status...

    This was my problem also - thanks for pointing this out.

     

    I had the same issue as described in the original post. Exchange A account was sending from the email address for Exchange B account and I couldn't figure out why. Turns out that both accounts had the same email address listed under Settings -> Mail, Contacts, and Calendars -> [Account Name] -> Account. I have no idea how this happened, or how the accounts could have been set up this way in the first place, but they both had the email address for Exchange B. Once I corrected this, I was able to send from Exchange A properly.

  • doogle Calculating status...

    This was the answer for me.  Somehow my Exchange account's (Account B) e-mail address had been added to the list of addresses in my POP account (Account A) - in Settings -> Mail, Contacts, and Calendars -> [Account Name] -> Account.  Removing that address from Account A allowed it to send correctly from Account B.  That was not how it was originally set up and working.  Not sure how long it's been going on but may date to a device swap about 3 weeks ago (back up old phone in iTunes, restore to new phone).

  • rsm10 Calculating status...

    I am having the same problem, and none of the suggested solutions have helped.  I have a hotmail account and a school account which I have set up using exchange.  The only settings that are available to change are the email and password, which both have the correct value for.

     

    Any email I send from my phone, regardless if it is from my school account or hotmail gets sent via hotmail, and the message is saved to the hotmail sent folder. When I removed the hotmail account, then tried to send from my school account, it worked correctly.

     

    Can someone from apple please address this problem?  It is really annoying. I do not wish to have to use a normal POP account as these suck (do not sync with your actual account).

     

    Help anyone?

     

    Cheers,

     

    Robin

     

    PS

     

    Using iPhone 4, iOS 5.1.1

  • MagMoment Calculating status...

    I am having the same issue with a godaddy POP account and a gmail account. My accounts came into my phone when I upgraded my iphone 4. We used the cloud to pull in all my data/settings. The "default" account is correct.

     

    BUT I never has this issue with iPhone 4 as stated in these postings. I am running businesses here and need this to work, so I look professional. I called AT&T, and they said to set the default account, which does not fix this issue. Thanks!

  • MagMoment Level 1 Level 1 (0 points)

    I was able to fix my account today. I suggest doing these steps in this order:

     

    1. reenter the password on your account that is NOT working correctly. Try sending mail from it.

    2. click the following within Settings App on iPhone:

    Mail, Contacts, Calendars

    Click on account that is NOT working

    At the very bottom click on

    SMTP of the Outgoing Mail Server >

    (even though it looks right)

     

    Turn off the account you don't want here. You will notice that your mail won't send at all now because there is still something wrong with the settings in your primary account.

     

    Note it says (and does do this!)  "If mail is unsuccessful using the primary server, it will try the others. This also means it will change your FROM address to the the one you use with that server, which is why this is frustrating. And, yes, deleting and reinstalling your accounts will work, but this is much faster.

     

    You're welcome. Enjoy the day!

  • Hailey50 Calculating status...

    Thank you MagMoment!

     

    I had the same problem on my iPhone 5. Every time I would send an email it would always send it from my gmail account regardless of the account I had chosen for it to send from. Sometimes it would even send the email twice! After reading your post, I fixed it by shutting off the outgoing server for my gmail account. In fact, I shut off all outgoing mail servers except the one I want my emails to be sent from. This fixed the problem. I receive mail for all my email accounts but my outgoing mail only goes from the one mail account that I have the outgoing server turned on for. If I want to specifically send from a different outgoing account, I go in and shut off the one outgoing server I have on and turn on the one I want the email to send from.

     

    Just FYI, as everyone has pointed out, setting up a default accout does not solve the problem and for me, I was not willing to delete my gmail account off my phone to solve the problem nor did shutting that account off work. The only thing that worked was shutting off the outgoing server for gmail!

  • Premican Calculating status...

    I have been having the same problem, I have several accounts set up, the from or sent from email differs each time and not necessarily from the same each time. I have looked at my settings and found that one account was not able to send out through its own smtp server and thus using the acoounts smtp server, I have now selected them off but cannot send any mail as I get a message "A copy has been placed in your outbox. No password provided" "Please go to your account settings and enter a password".

     

    I have checked and reentered the password and still same message, I have the same settings on my macbook mail program and it works fine. I have just spent an hour wth the tech guy from my internet provider Eastlink (dccnet in Delta BC) in Canada.

     

    This problem has been going on for about two months and I have not made any changes to mail program or settings.

  • Arderr Calculating status...

    I had this exact same issue and just resolved it reading through these posts but without deleting accounts etc.

     

    Again, in Settings, "Mail, Contacts, Calendars", select one of your accounts.

     

    Go to Account Information on accounts you can't see your Outgoing Mail Server immediately, when there click on the field with your Outgoing Mail Server.

     

    Listed will be the Primary Server for this account and beneath it Other SMTP Servers.

     

    You can turn the Other servers off.  The first one I turned off defaulted the rest to Off as well.  You could then turn On or Off other servers if you wanted (if your domain or service has multiple mail servers available for failover etc).

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.