Skip navigation

Ipod Nano 7th Generation - Not Charging / Error Msg From Comp 'Attached Device Malfunctioned'

10926 Views 10 Replies Latest reply: Jan 30, 2013 3:54 AM by juancho507 RSS
SavvYgirL33 Level 1 Level 1 (0 points)
Currently Being Moderated
Oct 17, 2012 6:17 AM

My IPod Nano 7th gen arrived last night.  I was able to turn it on and select language 'english'  When I connected it to my computer it did not recognize my iPod, so it also did not show up in iTunes,  Error message: "One of the USB devices attached to this computer has malfunctioned.  and Windows does not recognize it." 

My Nano turned off and went blank.   I have tried to reset it.  Nothing works, just blank.

No charge icon, I have tried all USB ports on my comp, but nothing works- (but my USB ports work fine)  I have read that if my iPod has not been charged fully, the computer my not recognize it.

I am now using an adapter and trying to charge it thru the wall power socket.  It has been connected for half an hour.  Still cannot turn iPod on.


I have Windows 7 running on comp.  Itunes is current version 10.7.  I have rebooted my comp several times and re-installed iTunes.

I have an iPhone and an iPod shuffle that are both synced with iTunes on this comp, they work fine.


Is my iPod broken?  Do I send it back?  Anyone else having the same problems?  Please Help !!

iPod nano, 7th Generation


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.