Skip navigation

View PDF files with Safari

60001 Views 35 Replies Latest reply: Sep 4, 2013 5:46 PM by BeccaC213 RSS
  • Barbara Passman3 Level 2 Level 2 (180 points)
    Currently Being Moderated
    Apr 24, 2012 9:11 PM (in response to Rob Gendreau)

    Where do you see the little floppy icon

    What pop up? where?

     

    I have the same problem.Got the same message, can't save file as ...

    would prefer to open in Adobe viewer'

  • Barbara Passman3 Level 2 Level 2 (180 points)
    Currently Being Moderated
    Apr 24, 2012 9:25 PM (in response to Barbara Passman3)

    Never mind, I found what you meant

    Its that semi translucent grayish bar that appears, with image of floppy disk ( save copy as), print icon etc.

     

    thank you!

  • warley Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 25, 2012 4:23 AM (in response to pyrrhonota)

    many thanks--that was exactly the problem!

  • norm colorado Calculating status...
    Currently Being Moderated
    Apr 28, 2012 12:47 PM (in response to Carolyn Samit)

    thanks a lot for your suggestion carolyn.  it worked perfectly!  you have saved me several hours of hassle.  god bless!

  • chris_7777 Calculating status...
    Currently Being Moderated
    May 6, 2012 10:47 PM (in response to Harpo Marx)

    Ha!  And I was getting irate at apple for going backwards.  Good work, appreciate you taking the time to put this in the community.  I installed Acrobat Reader because of a form issue and it adoberised the hover menu and refused to allow me to copy/paste.  Very Very unhappy adobe, that's not playing nicely and is actually a little devious to modify my browser behaviour because of the installation of a different app.  Deleting the files solved my problem, everything back to normal! love it.

  • oreomiller Calculating status...
    Currently Being Moderated
    May 21, 2012 3:07 PM (in response to Carolyn Samit)

    Thanks Carolyn.... :-)

     

            I was wondering why the pdf's weren't opening in Safari.  (just getting blank screen).  I trashed the Adobe 10.1.3 update and then uploading it again without the Browser plug-in. I also followed your advice about going to Libary and deleting the Adobe item.  I found 2 similar Adobe items in library (I deleted both : AdobePDFViewer.plugin and AdobePDFVIewerAPAPI.plugin)....some other Apple users might find them under these names depending on how old their computer is.  I restarted Safari and the pdf worked.

     

    Thanks again for your help.

  • ryr Calculating status...
    Currently Being Moderated
    May 28, 2012 3:35 PM (in response to Harpo Marx)

    Thank Carolyn,

     

    I deleted AdobePDFViewer.plugin and AdobePDFViewerNPAPI.plugin (actually moved them to the Desktop initially, to be safe) from HD>Library>Internet Plug-Ins. Then deleted Adobe Reader and re-installed it. And it worked!

  • Luis Sequeira1 Level 5 Level 5 (4,815 points)
    Currently Being Moderated
    May 29, 2012 6:57 AM (in response to ryr)

    There is no need that I can see to use or even install Adobe Reader at all.

    Safari can display pdf files on its own and the current version of Preview is more than capable to do basic manipulation of pdf.

    If you require the full Acrobat, that is another matter, but for what the Reader does there are better tools already on your mac. Adobe installers cause a lot of hurt, because they do things behind your back, as has been apparent in this thread. I have not had Reader on my macs for several years, and I can annotate, reorder and delete pages, combine pdfs into one, and more - just using Preview.

  • Nor251 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 4, 2012 3:59 AM (in response to Harpo Marx)

    Re-installing Adobe Reader solved the problem for me.

  • georgesfromkoyao Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 26, 2012 11:21 PM (in response to Harpo Marx)

    pdf files on safari don't work... why not ? I don't know, it should work, we should not spend hours finding out the trick to make it work, we want it to work, we are fed up with things that do not work...

    I have the feeling to be back in time when it was a war between apple and microsoft, when there was no possible file exchange from one system to the other...

    progress... yes, back to the past.

  • Luis Sequeira1 Level 5 Level 5 (4,815 points)
    Currently Being Moderated
    Jul 28, 2012 9:33 AM (in response to georgesfromkoyao)

    Safari can open pdf without any plugins since at least Leopard. Preview can do everything that Adobe Reader can, and a lot more.

     

    There must be some conflict in your mac, probably an older plugin that does not play nice with 10.8.

     

    There is no need to have plugins for pdf in OS X, and there hasn't been for years. There is also no need for Adobe Reader.

     

    Look at your internet plugins, move them to the desktop, logout and login in again. To get to the Library folder, hold down the option key and click the "Go" menu in the Finder. Choose Library; then open the "

    "Internet Plug-Ins" folder.

  • Bruce Kieffer Level 1 Level 1 (145 points)
    Currently Being Moderated
    Aug 1, 2012 8:58 AM (in response to Luis Sequeira1)

    Seem that Adobe is up to their old tricks again. I had to rebuild my entire system when I upgraded to Mountain Lion. I reinstalled Adobe CS 5.5, did all the updates, opened Safari, went to a PDF page, and it opens with Acrobat Reader. I open Acrobat Pro, go to preferences, Internet, and the darn check box is grayed out. I had to manually remeove AdobePDFViewer.plugin and AdobePDFVIewerAPAPI.plugin to get Preview PDF working in Safari. I really dislike Adobe. They have no right doing this.

  • jacksond Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 16, 2012 10:51 PM (in response to Bruce Kieffer)

    Not sure how relevant this is to your discussion but I offer it anyway. I could not open nor print out a tax form after saving to the Desktop with Adobe Reader. I opened ther file with Preview and everything worked properly. Thank heavens for Preview. If they ever get rid of it, I'dump my Macs!

  • MM087 Calculating status...
    Currently Being Moderated
    Oct 17, 2012 4:24 PM (in response to jacksond)

    Hi, Im having the same issue with my MacBook Pro. I was able to preview a PDF File within Safari and I could hover the mouse over the bottom of the screen and then click to download, print etc.

     

    Some update has taken place on my computer and I am now unable to either download a PDF File from certain sites like my University Portal nor Preview files within the Safari Brower.

     

    I do have the files mentioned on here if I go to: Library - Internet Plug-ins:

    - AdobePDFViewer.plugin

    - AdobePDFViewer.NPAPI.plugin

     

    Also in: Applications - Utilities - Adobe Reader*

     

    Now the Problem I have is I cant move to the desktop and delete from the desktop as I end up with a duplicate so to speak.

     

    When I try and delete them from the folders directly I get the following error message:

    "The operation can't be completed because some items had to be skipped. For each item, choose File > get Info, make sure "Locked" is deselected, and then check the Sharing & Permissions section. When you are sure the items are unlocked and not designated as Read Only or No Access, try again."

     

    *The 2nd issue is the Adobe Reader is faded out and has the circle going through it and is faded out ?

     

    I have re-installed the operating system, tried to deleted the items in safe mode to no avail !

     

    Please Help ...

  • Luis Sequeira1 Level 5 Level 5 (4,815 points)
    Currently Being Moderated
    Oct 18, 2012 12:51 AM (in response to MM087)

    You may need to resort to the Terminal. Be careful, as with the method I am about to describe you can just about delete *anything* in your drive; so follow these instructions exactly, or have someone more knowledgeable help you with it.

     

    1) Open Terminal (it is in /Applications/Utilities).

     

    2) Type (or paste) exactly the following (without the quotes but with the trailing SPACE) but do NOT press Enter or Return:

     

    "sudo rm -rf "

     

    3) Now drag the offending file or files from the Finder into Terminal (these will write down their full path next to the command you've typed.

     

    4) Hit the Return key.

     

    5) Enter your password, as requested.

     

    The files have now vanished.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (6)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.