Skip navigation

Users can't login because of an error occurred.

3677 Views 5 Replies Latest reply: Nov 30, 2012 11:10 AM by quesengar RSS
Cron Master Level 1 Level 1 (85 points)
Currently Being Moderated
Oct 18, 2011 1:32 PM

Xserve with 2.26 GHz Quad-Core Intel Xeon with 10.6.8

 

Lately I've been seeing this error message a lot:

 

You are unable to log in to the user account "XXXXX" at this time

 

Logging in to the account failed because an error occurred.

 

 

Everytime when the above error occurred, I would see the below error in the system.log:

 

Oct 18 15:03:00 office /usr/sbin/AppleFileServer[191]: CloseFork: fOpenForks[1] is Null!

 

Hope someone out there can shed some light.

Xserve, Mac OS X (10.6.8)
  • sscholle Calculating status...
    Currently Being Moderated
    Nov 3, 2011 12:35 AM (in response to Cron Master)

    This usually happens when the clients cant resolve your servers hostname.
    Therefore their DNS config must somewere be able to resolve the servers hostname.
    I got that error all the time before I fixed my DNS config, so in my DHCP server config the Primary DNS is pointing at my server (Open Directory/xserve). This might fix it, try that.

  • ClassicII Level 3 Level 3 (830 points)
    Currently Being Moderated
    Nov 14, 2011 9:33 AM (in response to Cron Master)

    You can also do a quick thing on the users side. Select the user that you have picked to log and you are getting this error. Open Workgroup Manager and select the user then click the advanced tab. Switch "user pasword type" to crypt password and then type in any password. Click save, then select another user and then go back to the user where you switched the password. Now switch it back to Open Directory.


    This has worked for us with users getting that same error.

  • Dreyfuzz Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 18, 2012 10:52 AM (in response to ClassicII)

    This didn't work for me.

  • quesengar Calculating status...
    Currently Being Moderated
    Nov 30, 2012 11:10 AM (in response to Cron Master)

    I was having the same problem and what I ended up doing was adding my server ip to hosts file with the correct lookup value.  Solved the problem immediately. 

     

    hosts file is located in /etc/hosts

     

    open terminal

    elevete permissions to root

    i.e. sudo vi /etc/hosts

    enter password

    add your server/name to file by

    hitting i

    then add a new line at the bottom of the file

    enter your ip address and a few spaces and then enter your server name, mine was

    192.168.1.102     minimac.server.private

    hit escape key

    enter :wq

     

    Login  with the user you were having problems with...

     

    voila!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.