Skip navigation

enable java mountain lion

41604 Views 29 Replies Latest reply: Apr 17, 2013 4:47 AM by francisgomes RSS
1 2 Previous Next
fmiranda Calculating status...
Currently Being Moderated
Oct 18, 2012 4:27 AM

Hello,

 

 

I'm using the latest Mac OS x Mountain Lion 10.8.2. To access my online banking it is required to enable java.

When I got to the bank web site I get a "missing plugin" message.

 

I opened my terminal and typed java -version and I got this result:

java version "1.6.0_37"

Java(TM) SE Runtime Environment (build 1.6.0_37-b06-434-11M3909)

Java HotSpot(TM) 64-Bit Server VM (build 20.12-b01-434, mixed mode)

 

So I do have java enabled, why I get this message of missing plugin when using - Safari, or Firefox or Chrome ?

Could someone please help me find out what is going on?

 

Thank you,

MacBook Air, OS X Mountain Lion (10.8.2), 256GB 8GB RAM
  • sig Level 8 Level 8 (35,770 points)
    Currently Being Moderated
    Oct 18, 2012 4:31 AM (in response to fmiranda)

    Have you installed the new Java update?

  • Graig Kivell Calculating status...
    Currently Being Moderated
    Oct 18, 2012 7:57 AM (in response to fmiranda)

    I don't know if its correct or not but I get the same result on my iMac.

  • Graig Kivell Level 1 Level 1 (10 points)
    Currently Being Moderated
    Oct 18, 2012 5:53 PM (in response to fmiranda)

    I have read that you should install the JDK rather than the JRE to see this corrected.

  • Graig Kivell Level 1 Level 1 (10 points)
    Currently Being Moderated
    Oct 18, 2012 7:17 PM (in response to fmiranda)

    The JDK also installs the JRE at the same time. I'm not sure about uninstalling the JRE first, it might be a good idea but maybe the JDK install will simply replace it. The latest versions are 7 update 9. I did install the JRE  terminal shows 1.6.0_37 like yours does. Someone on another forum said to install the JDK TO CORRECT THIS. I restored from a backup so to try again but have not had the nerve to go ahead with it yet. What a mess Apple has caused us. Why can.'t they instruct us what to instead of everybody try to guess.

  • Graig Kivell Level 1 Level 1 (10 points)
    Currently Being Moderated
    Oct 18, 2012 7:57 PM (in response to Graig Kivell)

    Read this for more information....

     

    http://www.macupdate.com/app/mac/39490/apple-java

  • Lanny Level 5 Level 5 (4,175 points)
    Currently Being Moderated
    Oct 18, 2012 8:18 PM (in response to fmiranda)
  • Alan Cozzens Calculating status...
    Currently Being Moderated
    Oct 22, 2012 12:28 PM (in response to fmiranda)

    I recently purchased a new Macbook Pro and upgraded my OS to Mountain Lion.  I now find the Safari is glitched and does not work properly while all of my other browsers seem  fine.  Yesterday, I updated my Java and am now unable to play bridge at my favorite site, Yahoo Bridge. The minute I ateempt to join a table the lounge crashes no matter what browser I try using.  I hate not being able to use my favorite browser  but after this recent Java updte, I apparently have a $2400 DOOR STOP  sitting on my coffee table because I am no longer able to enjoy my favorite past time on my new laptop.  Is there a fix in the works for the Safari problem  and is there a work around for the Java  problem created by the latest update.  I have been using Macs for over 25 years and am now totally ****** at this situation.   HELP !

  • Spencer Swift Calculating status...
    Currently Being Moderated
    Oct 25, 2012 3:29 PM (in response to fmiranda)

    Is that suppose to be correct ?

     

    I just tried to clear up this same issue of Apple Java 6 / Oracle Java 7 myself.  As near as I can tell, the answer is "Yes".

     

    Basically, Safari, Firefox and probably other browsers, get the Java environment set up through the Java Plug-in in the /Library/Internet Plugins/ folder.  That effectively points to the Oracle Java 7 installation which is buried away.

     

    But in your shell on the command line, things are governed by standard Unix environment - basically $PATH.  You obviously still have Apple Java 1.6 environment installed which places a java binary in /usr/bin/.  That is almost always first, or early, in a Unix path.  The Oracle Java location is most likely not even in your PATH unless you put it there.  As a test, I did put the Oracle location first in my PATH and then got this:

     

    cf-vpn-hw-swift-1(27)$ java -version

    java version "1.7.0_09"

     

    So now, my question is how best to get my Unix and browser environemnt in sync in the most "Apple"-like way.

  • Alan Cozzens Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 25, 2012 4:32 PM (in response to Spencer Swift)

    Thanks for the response Spencer,

    I am glad I am not totally nuts and this problem does exist, but I am not a  "go under the hood" savy guy. Is there a quick fix even an old duffer (65 and holding) can use or must I wait for Apple to do an upgade of some type?  I really hate not being able to use my new MacBook Pro  to play Bridge at Yahoo.  Is there a way to remove the old version of Java so that only the new one is there  or will that not by itself solve the basic problem?

  • Spencer Swift Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 26, 2012 7:49 AM (in response to Alan Cozzens)

    Hi Alan,

     

    I think you are out of luck for Apple to release any fix.  It seems the have passed on Java support to Oracle.  So you likely would be waiting for Oracle to fix Java 7 or for Yahoo to patch their Java program used in Yahoo Bridge.

     

    Here are instructions from Oracle on how to uninstall their Java 7 and instructions from Apple on how to reinstall their Java 6.  I have not tested this nor can I say it will restore Yahoo Bridge.  But it seems like it might and is easy to revert back if necessary.

     

    The Apple instructions go under the hood a bit, but I think they are clear enough for a non-savy person.

     

    Unistall Oracle Java:

    http://www.java.com/en/download/help/mac_uninstall_java.xml

     

    Reenable Apple Java:

    http://support.apple.com/kb/HT5559?viewlocale=en_US&locale=en_US

     

    Hope that helps!

  • Alan Cozzens Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 26, 2012 1:54 PM (in response to Spencer Swift)

    Thanks again Spenser,

    Believe it or not I actually had found both of those sources previously during my research and tried to use them. Unfortunately, when I Migrated my data from my old MacBook Pro to the new one, the terminal lists my old computer's admin which I can not login as on the the new machine.  When I am logged in as Admin on the new mac, which has the same password as the old one,  it will not accept either password when I am prompted after hitting return to supply my password. Therefore, it would appear I am at the mercy of Yahoo and Oracle to fix the problem at either or both of their sites.  I even attempted to dowmload and do a Clean Install of Mountain Lion on the new machine hoping it would overwrite all the old stuff an leave me a pristine OS to begin all over with. Evidently the download can't or didn't overwrite anything because all of the old transfered files and data still pops up when I restart the machine.  I never got a new setup Assistant prompt as I had expeted after completing the download  ( 12 hours out here in the boonies of northern NM) .

    I sincerely appreciate your efforts to help me but suspect I am stuck for now.

    Alan

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.