Skip navigation

Upgraded to iOS6 now I can't use wifi on iPhone 4S

47553 Views 82 Replies Latest reply: Oct 25, 2013 5:24 PM by gambyseetwo RSS
  • enter10m3 Calculating status...

    Had the same issue,

     

    "Reset All Settings"

     

    worked for me, but after reading this thread it seems like after 5:00pm everyone's wifi seemed to start working?

     

    -iphone 4 32gb Att

  • harrier99 Calculating status...

    Apple fixed this at about 4:35 pm PST (7:35 pm EST).  I did nothing and noticed that someone had posted this in another thread.  I tried connecting again after that and it worked fine. 

  • godardmac Calculating status...

    With my 4s (only three months old), it still does not work.  I do not have the ability to turn on wifi.  The "on" icon is gray and does not respond when I touch it. 

  • Chrissyd23 Calculating status...

    I clicked forget this network, then searched for connection again, put password in and it worked fine ever since

  • cwayman Calculating status...
    Currently Being Moderated
    Sep 20, 2012 9:28 AM (in response to godardmac)

    I can't even turn it on. Just see it greyed out. Time to go over to Samsung methinks!

  • renefagenais Calculating status...

    this worked for me tanks a million :-)  hope they test a bit more next os

  • Gibson92 Calculating status...
    Currently Being Moderated
    Sep 21, 2012 10:12 PM (in response to godardmac)

    Has your wifi started working again?

  • cherryjaoka Calculating status...

    my 4s has internet signal but cannot use it, I have tried as follows:

     

    - login to apple id page

    - reset network setting also forgot the network

    - off/on wifi & cellular data

    - set "on" Ask to join Networks

    - set "auto" for HTTP Proxy

    - reset my router

    - reboot my phone

    - restore my phone

     

    and still no luck

  • MacNueb Calculating status...

    Have same issues as cherry up there ^

     

    But I noticed that I can use Wi-fi only if its not secured... the security protocol is not allowing the 4S on ios6 make the connection... cant tbe the router and settings cos my android and laptops all can connect with no issues.. im a bit frustrated since Im under the impression that Apple products has to be superior to all PC products

  • cherryjaoka Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 23, 2012 8:45 AM (in response to MacNueb)

    Yes Macnueb I think it is the router setting issue because my daughter's laptop and mine all can connect except my 4s. Then I went to my sis place this evening and I can use wifi at her place!!??. So now I don't know if I should buy a new router or not LOL  dam Apple!!

  • MacNueb Level 1 Level 1 (0 points)

    Cherry.. i solved my WiFi Issue...  Here's the breakdown.  My iPhone 4S is with ATT and it had iOS5.1.1 i updated to 6.0 and my WiFi would not connect to secured networks..  I found out that 4S on ios 6 does not like WPA/2 so i moved my authentication to WEP format. Give it a shot. That worked fine and my WiFi issues are now resolved. Maybe someone might be helped by this info.  Good luck peeps.  I just hope that Apple could work on a patch for this issue since most of the secured networks I log on to is running WPA/2 settings.

  • RedMelb Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 19, 2012 3:14 AM (in response to cwayman)

    Apple Genius showed me how to fix this today!!!!! And it worked!

     

    1. Back up iPhone as always (just in case)

    2. Goto settings

    3. Select Reset

    4. Select Reset All Setting

     

    NOTE: Your data all remains in tact, but you will need to reconfigure you iPhone (eg wallpaper, ringtone selection, mail signature etc as they will return to the defaults).

     

    My iPhone 4S now has wifi and Bluetooth back!

  • Whitney1987 Calculating status...

    Okay try this guys... I did all of the above, some people's wifi are working some are not. I did the whole reset router and "forget this network" and blah blah... we all know how to do that. THIS WORKED for me: Go to your router ISP page, your going to be changing your security to WPA2 TKIP. If it was WEP or WPA2 AES change it to WPA2 TKIP... it will ask you to type in a form of password, type one in. BAMM! My wifi worked immediatedly on my 4S. Hopefully this helps others. Thanx

  • MrsBClarke Calculating status...

    I tried all the workarounds which didn't work, I then changed the settings on my router as per the above and i can now connect to my wifi but its still not working properly. It connects now but I have to connect manually every time I try to use my wifi. I connect, use my wifi, put my phone down, go to use it again 5 minutes later and the connections gone! Any ideas why this is happening? Thanks!

  • Whitney1987 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 26, 2012 11:02 AM (in response to MrsBClarke)

    Yeah, there's a major issue with Apple 6.0 & 6.1 updates. You can read here and online a lot of people can't use their wifi after updating. Two things seem to work... You can reset your phone Internet settings; via 1. Settings 2. General 3. Reset 4. Reset Network Settings. You will have to add your router/ISP again. Some say this works. Or you can go online under your routers ISP page and change your security from WEP to WPA2 TKIP. Not on your computer, but online you will have to do this. It will ask you to make a password and then exit. This does work. There is a security issue with the 6.0 and 6.1 update that doesn't allow wifi to work. If you do get a signal and it cuts off that's okay bc it means its working.

     

    Read this article for help.

    Http://www.zdnet.com/apples-ios-6-wi-fi-problems-linger-on-7000004799/

Actions

More Like This

  • Retrieving data ...

Bookmarked By (5)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.