4 Replies Latest reply: Oct 19, 2012 6:28 AM by Drew777
Drew777 Level 1 Level 1 (0 points)

When I step record midi, I get shortened staccato notes.

 

I select whole notes or half, no difference. They all come out very small and short.

 

I then have to select all and force legato.

 

Any help would be greatly appreciated.

 

Drew


iMac, Mac OS X (10.6.8)
  • 1. Re: When I step record midi, I get shortened staccato notes
    CCTM Level 6 Level 6 (9,025 points)

    Hi

     

    Are you Step Input recording using the MIDI IN red button?

     

    Are you doing this in the Piano Roll or the Score (the behaviour is different)?

     

     

    CCT

  • 2. Re: When I step record midi, I get shortened staccato notes
    Drew777 Level 1 Level 1 (0 points)

    Hi CCT;

     

    Thanks for the quick reply.

     

    I've been doing it in the Piano roll (sadly, I didn't think to do it in the score)

    but both seem to have the same result.

     

    When I step record I

    1. Create Instrument Track

    2. Either click on Piano roll (bottom by mixer, sample editor, etc) or COMMAND+6

    3. I press pause (lights up pause and play) then record (so the track has play, pause, and record lit)

    4. Now I input using my midi keyboard

    5. when I press stop the notes that looked longer are now very short and staccato

     

    BUT

     

    When I start playing on the keyboard it still writes to midi and the notes are the length they should be (even though the record button is off)

     

    I'm not sure why the record button being on, I record, then off, and can still record midi input.

    If I try to just input data before pressing record it acts as I expect (no input)

     

    Sorry if this reply is long. Just trying to get to the bottom of what I'm doing wrong.

    As usual, I assume there's a setting I've not checked somewhere.

     

    Drew

  • 3. Re: When I step record midi, I get shortened staccato notes
    CCTM Level 6 Level 6 (9,025 points)

    Hi

    Drew777 wrote:

     

     

    I've been doing it in the Piano roll (sadly, I didn't think to do it in the score)

    but both seem to have the same result.

     

    When I step record I

    1. Create Instrument Track

    2. Either click on Piano roll (bottom by mixer, sample editor, etc) or COMMAND+6

    3. I press pause (lights up pause and play) then record (so the track has play, pause, and record lit)

    4. Now I input using my midi keyboard

    5. when I press stop the notes that looked longer are now very short and staccato

     

    Noooooo

     

    With the Transport in "Pause Record", Logic will enter note events with effectively 'zero' length.

     

    Instead try this:

     

    Make an empty region in the Arrange (Pencil tool or Control click).

     

    With this region selected, place the Playhead where you want to enter the notes, and open the Piano Roll.

     

    In the Piano Roll window, click the MIDI IN button (turns red)

    MIDI IN.jpg

     

    Enter the notes using your MIDI Keyboard. The Playhead will advance when you let go of the note.

     

    The length of the note entered is dictated by the Division value:

     

    Division.jpg

     

    Alternatively, use Options:Step INput Keyboard.

     

    This will allow you to choose note length and dynamic (velocity): a click on the mini keys at the bottom will enter the notes.

     

    Combining the Step Input Keyboard with the MIDI IN red button allows you to select the note length from the Step Input Keyboard with the pitch and velocity from your MIDI keyboard.

     

     

    These  methods work similarly with the Score editor.

     

    HTH

     

    CCT

  • 4. Re: When I step record midi, I get shortened staccato notes
    Drew777 Level 1 Level 1 (0 points)

    Perfect!!!

     

    And now I understand why when I stopped recording in the first place it would still record but not staccato.

     

    I'll use both your ideas (input data with my controller AND use the step input keyboard to change note length)

     

    Thank you,

     

    Drew