Skip navigation

How to stop the wifi pop-up window?

20178 Views 33 Replies Latest reply: Mar 24, 2014 10:10 AM by Manuel Flores-Arce RSS
  • Michael Ruiz2 Level 1 Level 1 (25 points)
    Currently Being Moderated
    Nov 21, 2011 8:46 AM (in response to softwater)

    Hey, I'm replying to this directly under the post here since now we know. The solution (tested in OS X 10.7.1):

    1) Open System/Library/CoreServices/

    2) Zip Captive Network Assistant.app

    3) Move the resulting Zip file to someplace convienient. (such as your documents folder or make a folder such as ~/System Components/ just in case a later update break it)

    3) Delete the Captive Network Assistant.app

     

    Now the dialog box will no longer pop up because the CNA will not be able ot be run. If someone knows a way to simply disable the triggering of this app on an account by account basis or a global basis, then post it here. Thanks.

  • _KcM_ Calculating status...
    Currently Being Moderated
    Nov 24, 2011 10:30 AM (in response to softwater)

    Hey,

     

    I'm having the opposite problem. How can I force the captive network assistant if it doesn't appear when required? Safari just gives me the new stylized "you are not connected to the Internet" page, and the wifi icon in the taskbar just tells me Alert: No Internet Connection.

     

    Bah! Abou 1/4 of the time the login window appears, but the rest o the time I'm left to working on my phone (like now).

    Trying to log in to a Aruba-networks portal, if that helps 

  • Shahin Level 2 Level 2 (215 points)
    Currently Being Moderated
    Aug 11, 2012 2:34 PM (in response to _KcM_)

    I am dealing with this issue at our school. We have several secured wireless networks and one unsecured for use by studends and BYD scenarios. I noticed this pop up issue as well and could not figure out what it was, so thanks for this discussion.

     

    And BTW, the issue is fixed in Mt. Lion.

  • caleb155 Calculating status...
    Currently Being Moderated
    Oct 4, 2012 12:06 PM (in response to Shahin)

    I do not believe that they have fixed this in Mountain Lion. I am currently using Mt. Lion and I still get the Captive Network Assistant. The directory that they mention above: /System/CoreServices does not exist in Mountain Lion that I can find.

    Any assistance with this matter would be greatly appreciated.

  • Michael Ruiz2 Level 1 Level 1 (25 points)
    Currently Being Moderated
    Oct 4, 2012 12:39 PM (in response to caleb155)

    I just looked, and in 10.8.2 it is (still) in:

    /System/Library/CoreServices/

    From your post, it looks like you looked in the wrong place by excluding …Library/ from the path.

     

    Message was edited by: Michael Ruiz2 (clarified)

  • Rah Zee Calculating status...
    Currently Being Moderated
    Oct 16, 2012 12:16 PM (in response to softwater)

    I'm trying to get rid of that window too...Very annoying

  • Rah Zee Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 16, 2012 12:25 PM (in response to softwater)

    Yup, the X did the trick. Cheers.

  • zdewitt Calculating status...
    Currently Being Moderated
    Oct 18, 2012 4:07 PM (in response to softwater)

    Thanks for the tip....Just to add my 2 cents my main issue with the CNA is that it ***does not keep any cookies and remember login data***

     

    The wireless network at my school will remember your login credentals for 7 days, but only if I login from my browser. It got really annoying having to retype my password every time I opened my computer when I didn't have to in 10.6

  • anku360 Calculating status...
    Currently Being Moderated
    Oct 19, 2012 12:54 AM (in response to Michael Ruiz2)

    Hi,

     

    I am facing the same issue on my iphone. Whenever I switch on my iphone's wifi and it joins my home network (which requires a sign in via a browser), it automatically opens a login browser and goes to www.apple.com and there is no way to change the address. Then, when I close this browser, it automatically disconnects me from the wifi and if I reconnect, it puts me back onto the same browser. Basically, I have to use another device to login to WiFi and only after that, does the iphone connect up.

     

    Any solutions??

  • zdewitt Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 19, 2012 9:13 AM (in response to anku360)

    Go into Settings > Wifi then tap on the blue arrow next to your home network on the list. I don't have it in front of me right now but there should be a switch in the network details called "Auto Login" which you can turn off. Then just normally login with Safari.

  • ThiGre Calculating status...
    Currently Being Moderated
    Sep 6, 2013 5:29 AM (in response to softwater)

    The CAN window is still showing up annoyingly in Mavericks (DP7, connexion established on a VPN cisco WiFi based network, without the help of CAN, but still poping up from time to time), and the "XCAN" trick described above is still valid !

    Thanks

  • j_goldberg Calculating status...
    Currently Being Moderated
    Feb 14, 2014 4:01 PM (in response to softwater)

    I think you can just uncheck "Ask to join new networks" under wifi in Network preferences.

  • Manuel Flores-Arce Calculating status...
    Currently Being Moderated
    Mar 19, 2014 5:32 PM (in response to softwater)

    I have the same problem. It started when my institution changed to a different service provided. There is a public spot nearby and I used it while disconnected. When the new connection was up, the Safari pop-up showing Apple's "um it looks like the page you're looking for..." started coming up regularly in 5 min intervals. I am connected to the Internet and not looking for any page! I tried everything from resetting Airport Extreme, replacing it with Airport Express, resetting Safari... Short of erasing everything in my computer nothing worked, except connecting to Internet via Ethernet. If I use WiFi the pop-up window starts as soon as an Internet connection is established. This also happens if I bring my laptop and connect via WiFi in my office. I'm now going to experiment with some of the suggestions above, but still I wanted to post this in case someone might have an answer for me.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.