Skip navigation

iCal does not sync with iPhone via iTunes

57358 Views 70 Replies Latest reply: Mar 4, 2014 11:11 PM by Why_do_I_need_a_user_name RSS
  • justmakeitwork! Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 27, 2012 3:49 PM (in response to Z001)

    Help. I tried to find the cache files as posted. Went to finder>go>library but no files with calendar or iCal to be found. I did searches...nothing. The cache files had nothing to do with the calendar. The apple.com things - nothing related to calendar. I'm fairly computer literate so this is really bugging me.

     

    I have three iPhones sync'ng to same iTunes account with crazy calendars - this is causing a schedule crisis.

  • justmakeitwork! Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 27, 2012 5:40 PM (in response to justmakeitwork!)

    I found this and it fixed the problem - it is resetting the sync

     

    http://support.apple.com/kb/TS1627

  • toblerone777 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 13, 2012 10:27 PM (in response to Z001)

    Thank you Z001!!!  The suggestion of deleting the calendar cache files worked great!  Whew!!

  • saabs4life Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 14, 2012 5:14 PM (in response to RMH)

    This worked for me too! My calendar was syncing very strangley. My wife & I both have iPhones and have some calendars that are shared between both phones and some that are only on one iPhone. Before deleting these files any events created on an iPhone would not show on the iMac, even though they would transfer THROUGH the iMac to the other iPhone!! Go figure!! And any events created on the iMac would show up with an alert for 15 hours before, regardless of what the iMac Calendar said for an alert setting. You could not change this on the iPhone because if you changed the alert on the iPhone and then synced with the iMac it would be changed back to 15 hours before for the alert. I was getting very frustrated with Apple over this and had not gotten any help from calling them.

     

    Thanks!!

  • saabs4life Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 14, 2012 5:17 PM (in response to saabs4life)

    Like other commenters we do not want to use iCloud. When I first upgraded to Mountain Lion (the first day it was out) and started having this issue we tried switching everything over to iCloud but that just made it worse and duplicated EVERY event that was on a shared calendar since iCloud was picking up that it was on multiple devices, even though it was the same event. I much prefer syncing over wi-fi with iTunes. I don't like all this cloud push...and I work in IT...

  • KatieHale Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 25, 2012 6:12 AM (in response to Z001)

    Hello All,

     

    I have tried all the above suggestions (and gone to the genius bar) and tried re-setting the sync, and I cannot make this work. My specific problem is that somtime recently, I stopped being able to sync new events that were entered via my iphone into iCal to my MacBook (OS Mountain Lion). I can sync all events from the MacBook to the iphone but not vice versa. Everything else works (creating new contacts on the iphone will then sync to the MacBook). Interestingly, it works just fine when I sync to a test use account on the same computer. It's specifically my user account that has problems syncing new events from iCal on my iphone to iCal on my MacBook. Like other users here, I really do not want to use the Cloud as it has caused me huge headaches in the past. Any other suggestions would be greatly appreciated!!! Thank you.

  • KatieHale Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 25, 2012 6:52 AM (in response to KatieHale)

    I fixed it! I noticed that there were also email cache files in the calendar folder. I then deleted those as well as everything else listed above plus "re-set" the sync again through Terminal, and it finally worked.

  • Blue Wammer Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 16, 2012 5:43 AM (in response to diftong)

    Deleting the plists solved the problem for me.  Many thanks!

  • KatieHale Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 18, 2012 9:04 AM (in response to Z001)

    It is happening to me again! Please help. I do not know why this happens every so often. Has this recurred for anyone who originally fixed the problem? I've tried re-setting sync services and deleting everything that's been mentioned in the forum (which worked for me last time), but now it's not working. Any new events I put in iCal on iphone do not sync to my computer, but the reverse works. This is the first time I'm seriously considering not getting another iphone/Mac although I don't know what else I'd get as I hate PCs (and I especially don't like GoogleCalendar). Any help would be greatly appreciated. Thank you!

  • Babyhair Calculating status...
    Currently Being Moderated
    Oct 19, 2012 11:00 PM (in response to Z001)

    Duplicate ****.  Have tried deleting the caches as described and resetting the syncservices folder.  From the moment I sync my MBPro '09 to my Touch 3G no less than 6 sets of duplicates appear in Calendar on my MB.  And i've restored and rebooted.  Sync also no longer works on my iphone 4S, even though I've unchecked the Calendar option in iCloud. I delete duplicates on each ios device then sync and they reappear.  What a mess.  Just like KatieHale, I hate PCs but I've never experienced difficulties like this and honestly would think hard before another ios as the whole reason of paying extra was because it was slick.

  • elmo3112 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 20, 2012 10:01 PM (in response to Z001)

    Lol, I found my problem (and yes its a bit silly)! I changed all my passwords the other day including my apple ID account password via my mac. This is what prevented me from syncing. Stupid thing is that the phone DIDN'T prompt me that the iCloud password was incorrect so I had to go and change it myself.

     

    On your iPhone go:

    Settings>Mail,Contacts,Calendars>iCloud>Account and NOW your phone will say... 'Oh, by the way, your password has been incorrect for the last few weeks and nothing has been syncing in your calendar, I only now just decided to tell you!'

    Now you can input your correct password and syncing should take place when you open you calendar. Don't know why the incorrect password message message doesn't come up earlier... Apple.

  • diftong Level 1 Level 1 (30 points)
    Currently Being Moderated
    Oct 21, 2012 10:33 AM (in response to Babyhair)

    Dear Babyhair, Dear Katie,

     

    I can not help you because I did not have your specific problem. If you read this thread, you will see that others did not have your problem neither, that it might be too far away from what the original question was. I would encourage you to open a special thread with your special question. I hope there are others, that have the same problem too, and they might have found a solution to the problem.

     

    BTW: It is hard, but Macs are PCs too. You can have those problems with Windows, MacOS, Linux, Android, whatever.

  • McLainUK Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 30, 2012 10:20 AM (in response to Z001)

    I was having problems with my Mac synching with icloud - my phone / pad all would update icloud - but not the mac. If I turned off Calendars in iCloud and turned them back on - all the new items would appear on my calendar and Reminders - but then would fail shortly thereafter.

     

    I took removing caches a step further and deleted all the files (moved them to a new folder) in Library Calendars.

     

    Then all my local calendar items were gone and when they sycnhed with icloud they updated fine and now work very fast!

  • yatesj Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 2, 2012 9:56 AM (in response to RMH)

    where do you find these files?  Through Finder?

  • diftong Level 1 Level 1 (30 points)
    Currently Being Moderated
    Dec 2, 2012 10:47 AM (in response to yatesj)

    The following is a summary of other posts: It helped some of us. Try it out!

     

    1. Make a backup ( a) Time Machine, b) Export > Archive iCal) Close iCal

     

    2. In Finder hold down alt-Key while choosing "Go to..." menu

     

    3. Select Library

     

    4. In the folder Calendar delete the files

    Calendar Sync Changes

    Calendar Cache

    Email Cache.plist

     

     

    5. In the folder Preferences delete the files

    com.apple.CalendarAgent.plist

    com.apple.iCal.helper.plist

    com.apple.iCal.plist

    com.apple.iCalExternalSync.plist

    com.apple.syncserver.plist

    (not sure which one is the bad guy, but it did not hurt to erase all of them)

     

    6. Start iCal, it will update itself.

     

     

    HTH, Patric

Actions

More Like This

  • Retrieving data ...

Bookmarked By (5)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.