Skip navigation

Safari won't load certain websites

68025 Views 34 Replies Latest reply: Feb 11, 2014 7:22 PM by MadMacs0 RSS
1 2 3 Previous Next
DallasTwinMom Level 1 Level 1 (0 points)
Currently Being Moderated
Jul 9, 2012 3:14 PM

When I use Safari 5.0.6 on my MacBook running Mac OS X 10.5.8, various websites will not load.  Some will load fine, like the home page of New York Times.  However, if I select an article, it won't load.  If I try to load google search, it may take several minutes to come up. page will NOT load forever and ever.  When I state that it 'doesn't load' I mean that you'll see the address in the address bar and halfway thru that will be a blue progress bar.  It just sits there like that and doesn't ever finish loading.  If I try the same pages on Firefox, I have no problems at all.  I have run the ClamXAV to make sure it's not a virus and it found nothing.  I'm not sure what's going on.  I have tried resetting Safari and clearing the cache and whatnot, but it made no difference.  I tried allowing pop-ups.  No change.  This has been going on awhile and it's just irritating.  Any suggestions?

MacBook Pro, Mac OS X (10.5.8)
  • Neville Hillyer Level 4 Level 4 (1,845 points)
    Currently Being Moderated
    Jul 9, 2012 3:19 PM (in response to DallasTwinMom)

    First establish if the problem exist in other accounts - if necessary create a new account to test it.


    You need to post two or three urls of problem pages.

  • Carolyn Samit Level 10 Level 10 (84,200 points)
    Currently Being Moderated
    Jul 9, 2012 4:40 PM (in response to DallasTwinMom)

    MIght be a plugin ...


    From your Safari menu bar top of your screen click Safari > Preferences then select the Security tab.


    Deselect:  Enable plug ins. Quit then relaunch Safari to test.


    If that made a difference then you need to troubleshoot third party add ons > Safari: Unsupported third-party add-ons may cause Safari to unexpectedly quit or have performance issues


    And try deleting the cache associated with Safari. (Not the same as deleting the cache from the Safari menu bar.


    Open the Finder. From the Finder menu bar click Go > Go to Folder


    Type this exactly as you see it here:




    Clck Go


    Move the Cache.db  (or ApplicationCaches.db) file from the folder to the Trash.


    Quit then relaunch Safari to test.


    And several of the sites you mentioned require the Flash plugin. Try uninstalling the currently installed Flash plugin, then reinstall new >  Troubleshoot Flash Player | Mac OS


    Make sure there's enough free space on the starutp disk. 


    Right or control click the MacintoshHD icon in your Desktop. Click Get Info.


    In the Get Info window you will see Capacity and Available. Make sure there's a minimum of 15% free disk space.


    And remove any items in System Preferences > Security > Login Items


    Same for  HD > Users > (your account) > Library > Startupitems





  • MadMacs0 Level 4 Level 4 (3,330 points)
    Currently Being Moderated
    Jul 9, 2012 7:44 PM (in response to DallasTwinMom)

    DallasTwinMom wrote:


    Kinda strange.  I created a new account and the Safari icon is a '?'.  Also, the Application doesn't appear under Apps. 

    Sounds as if you may have moved Safari at some point in time. Go back to your own account Option-click on Safari in your Dock and choose "Show in Finder" to figure out where it went. If it's not directly in the root Applications directory (folder) then move it there. If it's in your home Applications directory it's in the wrong place.

  • Neville Hillyer Level 4 Level 4 (1,845 points)
    Currently Being Moderated
    Jul 10, 2012 2:08 AM (in response to DallasTwinMom)

    Apple search facilities are not wonderful. Download this very efficient search application and use it in future for searches on your Mac:


    Always put all applications in the main Applications folder at the root. The only exceptions to this are utilities in the Utilities folder - a sub-folder of Applications. Do not have any other applications folders - they cause too much confusion and many applications do not work properly in them.


    Drag non-working items out of the Dock. To recreate Dock items drag a CLOSED application from the Applications folder to the Dock.

  • MadMacs0 Level 4 Level 4 (3,330 points)
    Currently Being Moderated
    Jul 28, 2012 11:29 PM (in response to DallasTwinMom)

    DallasTwinMom wrote:


    the solution to my original problem, which is that many common webpages would not open on in Safari (and later began to hang in Firefox, too), was to disable IPv6.


    WHY was this a problem?

    Even though the world was supposed to turn IPv6 on June 6th, only about 1% of ISP's were ready. As a result, some are able to use it while others are not. Very soon now, seveal parts of the world will run out of IPv4 addresses and be forced to issue new sites only an IPv6 number. That's when the real problems will come as some of us who's ISP has not adequately implemented IPv6 will cause some web sites to be unreachable. So the race is on.


    There are some tunneling work-arounds that aren't super reliable right now, but anticipate issues for a few months until everybody gets caught up.

  • Neville Hillyer Level 4 Level 4 (1,845 points)
    Currently Being Moderated
    Jul 29, 2012 3:55 AM (in response to DallasTwinMom)

    I don't know the answer to your question but the following is food for thought:


  • Anders Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 21, 2012 11:56 AM (in response to DallasTwinMom)

    I had the same issue, turned out it was a setting on my time machine, an Ivp6 setting.


    Have a look at your router setting.



  • Kmcollier1 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 16, 2013 12:20 PM (in response to DallasTwinMom)

    Hope you fixed it by now.  I just experienced the exact same problem.  It was unique to my macbook pro, running OSX 10.6...  I could not open facebook, yahoo, google etc via Safari.  I troubleshot by testing other devices.  Lastly I synced my Macbook Pro to my Ipad and ran it off of Verizon's LTE 4G.  Everything else was working fine except my macbook pro on my home wifi via safari.


    I FIXED the problem by downloading the Firefox Browser.  I'm no computer expert, but it seems like firefox is far superior in at least interfacing with my macbook pro.  Hope this helps.

  • Neville Hillyer Level 4 Level 4 (1,845 points)
    Currently Being Moderated
    Feb 18, 2013 12:13 PM (in response to Kmcollier1)

    I find that such problems are often cured by a change of browser  or a complete reinstall of the same browser. I suspect that caches get corrupted or bloated. Sometimes Safari's Reset facility cures issues. Very often my Macs work better after resetting the DNS cache - Google if necessary. I get reasonable stable performance by using both Safari Reset and clearing my DNS cache once a day - I have automated both so that they are activated during my daily boot.

  • Craig Fer Level 1 Level 1 (25 points)
    Currently Being Moderated
    Apr 1, 2013 8:38 AM (in response to DallasTwinMom)

    I had the same problem and this worked!!  Searched for days before finding this answer.  Thank you so much for posting the fix.

1 2 3 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (1)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.