Skip navigation

"Damaged and can't be opened" file error

12155 Views 14 Replies Latest reply: Oct 27, 2012 2:27 PM by Tasman Traveller RSS
Tasman Traveller Calculating status...
Currently Being Moderated
Oct 21, 2012 4:15 PM

Hi all

When I try opening a number of games on my iMac, I am getting the error message (for example COD) "Call of Duty 4 - Modern Warfare" is damaged and can't be opened.  Delete "Call of Duty 4 - Modern Warfare and download it again from the App Store"

COD4 error.jpg

The last tme I used these apps/games (specifically Call Of Duty 4, Doom 3 and Battlefield 2012) was months ago... apart from COD4 which I definitely fired up and was working 6 weeks ago.  (Don't play games much!)


I have searched for the answer, and most similar problems are associated with Gatekeeper - i.e. setting to allow install from amy location.  But two of these apps are from the AppStore (I bought Battlefield elsewhere).


I have tried;-

* Deleting/Download the app again from AppStore

* Setting Gatekeeper to "Allow Applications Downloaded from anywhere" (Always had this setting)

* Running Disk Utility "Repair Disk Permissions"

* Using AppCleaner to delete all settings as well as the App (**** going to lose my place in the game!)

- Also deleting the trash.  Then re-downloading/Installing.


It's really weird that none of my other Apps apart from these 3 games get the error.

I Installed COD4 on my Macbook Air which is the same OSX/Update level (latest) and it WORKS.  So something is specifically wrong with my iMac


I'm wondering if there are any OSX security/java/whatever updates which could have affected this  But once again it all works on my Macbook Air.

Are there any files/settings that Appcleaner misses that I could reset/delete and try again?





24-inch, Early 2008

Processor  3.06 GHz Intel Core 2 Duo

Memory  6 GB 800 MHz DDR2 SDRAM

Graphics  NVIDIA GeForce 8800 GS 512 MB

Software  OS X 10.8.2 (12C60)

iMac, OS X Mountain Lion (10.8.2), 24-inch, Early 2008, 6GB RAM
  • Linc Davis Level 10 Level 10 (108,110 points)
    Currently Being Moderated
    Oct 21, 2012 6:27 PM (in response to Tasman Traveller)

    "AppCleaner," like almost all "utilities" for the Mac, is useless, or worse than useless. Get rid of it.


    When you re-downloaded these apps, did you delete them first? If not, try that.

  • Linc Davis Level 10 Level 10 (108,110 points)
    Currently Being Moderated
    Oct 21, 2012 7:51 PM (in response to Tasman Traveller)

    Launch the Terminal application in any of the following ways:


    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)


    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.


    ☞ Open LaunchPad. Click Utilities, then Terminal in the icon grid.


    Triple-click the line below to select it, then drag or copy into the Terminal window — do not type — and press the  space bar:


    codesign -vv


    Now switch to the Finder and drag one of the problem apps into the Terminal window. More text will be added to what you entered.


    Click in the Terminal window to activate it, then press return.


    Post any lines of output that appear below what you entered — the text, please, not a screenshot.

  • Linc Davis Level 10 Level 10 (108,110 points)
    Currently Being Moderated
    Oct 21, 2012 9:03 PM (in response to Tasman Traveller)

    Please enter this command in the same way as before:


    ls -Oel !$/Contents/MacOS

  • Linc Davis Level 10 Level 10 (108,110 points)
    Currently Being Moderated
    Oct 21, 2012 9:49 PM (in response to Tasman Traveller)

    Please read this whole message before doing anything.


    This procedure is a test, not a solution. Don’t be disappointed when you find that nothing has changed after you complete it.


    Step 1


    The purpose of this step is to determine whether the problem is localized to your user account.


    Enable guest logins* and log in as Guest. For instructions, launch the System Preferences application, select Help from the menu bar, and enter “Set up guest users” (without the quotes) in the search box. Don't use the Safari-only “Guest User” login created by “Find My Mac.”


    While logged in as Guest, you won’t have access to any of your personal files or settings. Applications will behave as if you were running them for the first time. Don’t be alarmed by this; it’s normal. If you need any passwords or other personal data in order to complete the test, memorize, print, or write them down before you begin.


    Test while logged in as Guest. Same problem?


    After testing, log out of the guest account and, in your own account, disable it if you wish. Any files you created in the guest account will be deleted automatically when you log out of it.


    *Note: If you’ve activated “Find My Mac” or FileVault, then you can’t enable the Guest account. The “Guest User” login created by “Find My Mac” is not the same. Create a new account in which to test, and delete it, including its home folder, after testing.


    Step 2


    The purpose of this step is to determine whether the problem is caused by third-party system modifications that load automatically at startup or login.


    Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards. Boot in safe mode* and log in to the account with the problem. The instructions provided by Apple are as follows:


    1. Shut down your computer, wait 30 seconds, and then hold down the shift key while pressing the power button.
    2. When you see the gray Apple logo, release the shift key.
    3. If you are prompted to log in, type your password, and then hold down the shift key again as you click Log in.


    Safe mode is much slower to boot and run than normal, and some things won’t work at all, including wireless networking on certain Macs.


    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.


    *Note: If FileVault is enabled, or if a firmware password is set, or if the boot volume is a software RAID, you can’t boot in safe mode.


    Test while in safe mode. Same problem?


    After testing, reboot as usual (i.e., not in safe mode) and verify that you still have the problem. Post the results of steps 1 and 2.

  • Linc Davis Level 10 Level 10 (108,110 points)
    Currently Being Moderated
    Oct 22, 2012 10:45 AM (in response to Tasman Traveller)

    When you deleted the problem apps, did you use the method recommended by Apple?


    How to remove Mac App Store apps that appear in Launchpad


    I've seen various reports of this issue. It seems to have different causes. In some cases, it's caused by a bug in the App Store:


    Corrupt App Store binaries crashing on launch


    Sometimes the app itself is incompatible with the current version of OS X:


    Repeated message "Kaspersky Virus Scanner" is damaged


    Sometimes the user files created by the application are corrupt or out of date, but that's not the case here. Sometimes the system keychain has been tampered with, or the system has otherwise been corrupted:


    Mac App Store - App Damaged and Can't...: Apple Support Communities

    I deleted my Mac App Store certificates...: Apple Support Communities


    I suggest you use the Apple-approved method of deleting the apps, which removes the hidden receipt associated with the app as well as the app itself. If that doesn't work, contact the respective developers.

  • Linc Davis Level 10 Level 10 (108,110 points)
    Currently Being Moderated
    Oct 23, 2012 2:43 PM (in response to Tasman Traveller)

    Did you try to contact any of the app developers?


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.