11 Replies Latest reply: Jun 11, 2013 11:23 PM by Hudson13hawk
nmarkellos Level 1 Level 1 (0 points)

Does anyone know if there is a workaround for the java applet not working. Ever since the update on October 16th, I have not been able to run any java programs online. Everytime I go to run a Java program I get this message: "To open this Web Start application, you need to download the Java Runtime Enviroment" and it prompts me to download Java 7 from oracle's website. That notwithstanding, once I download Java 7 it opens but the little coffee cup times out and I can't launch the program.


Any one know a solution for this? Will Apple be reinstalling Java? Help!!!

OS X Mountain Lion (10.8.2)
  • 1. Re: Java Not Working
    CT Level 6 Level 6 (15,535 points)
  • 2. Re: Java Not Working
    nmarkellos Level 1 Level 1 (0 points)

    Thanks ... I tried it and although the error message is gone, I still cannot launch the one program I need. My PowerTeacher Gradebook. I am going keep trying, and hopefully something will work soon. I appreciate your help

  • 3. Re: Java Not Working
    DavidinTexas Level 1 Level 1 (0 points)



    I had a problem with Scottrade's Scottrader Streaming Quotes Java app after the October 16 update. Som parts of the app's drop down menus had stopped working. I went to the support link you provided and foloowed the instuctions for disabling Java 7 and reenabling Java Web Start. It appears to have fixed the problem.


    Thanks for your help.


    Wish I could give you a green checkmark for solving my problem but I think only the OP gets to do that.




    Message was edited by: DavidinTexas

  • 4. Re: Java Not Working
    nmarkellos Level 1 Level 1 (0 points)

    I will give the green check mark because I can acutally use java now ... it is just my gradebook that won't launch, but I think it is actually an issue with Pearson, which I am hoping I can get to the bottom of tomorrow when I call them. Ugh ... why do they keep changing everything?

  • 5. Re: Java Not Working
    Yogi.B Level 1 Level 1 (0 points)

    Thanks CT !

    That solved my issue. It took me few hours to reach you comment



  • 6. Re: Java Not Working
    Shemker Level 1 Level 1 (0 points)

    Pearson has put out an update for PowerSchool Gradebook.  I called our district tech department and they simply installed the update district wide.  It works just fine. 

  • 7. Re: Java Not Working
    mattybritton Level 1 Level 1 (0 points)

    Did you ever find a solution for PowerTeacher?  I need to get this on my home computer.  When you called the tech dept was the update on the school's end to where they updated PowerTeacher and voila it worked at home? 

  • 8. Re: Java Not Working
    Shemker Level 1 Level 1 (0 points)

    Yup.  It doesn't matter where you access it from.  Once the district upgraded PowerSchool/PowerTeacher, Gradebook once again worked with java. 


    Good luck!


  • 9. Re: Java Not Working
    fkinnett Level 1 Level 1 (0 points)



    Can you give me more information about the PowerSchool / PowerTeacher upgrade... version number? something I can tell our tech department?



  • 10. Re: Java Not Working
    Shemker Level 1 Level 1 (0 points)

    This should help.


    Screen Shot 2012-11-16 at 8.29.44 AM.png

  • 11. Re: Java Not Working
    Hudson13hawk Level 1 Level 1 (0 points)

    Worked for me too. Which is very useful as the previous workarounds have meant deleting installations completely and then re-installing an earlier Java!  I keep forgetting to click the checkmark when Apple sends out an update! I wish they would fix this bug for older mac users.