1 2 Previous Next 18 Replies Latest reply: Apr 12, 2014 6:03 AM by JimJohnMarks
Wilbur Pan Level 1 Level 1 (10 points)

Because of the security issues with Java, I uninstalled Java 6 (using various terminal commands) and installed Java 7 from Oracle's website. Looking at /Library/Internet Plug-Ins, I can see that JavaAppletPlugin.plugin is there, and Get Info tells me that it is part of Java 7 Update 09.

 

However, when I use Safari to try out a Java test page, or use one of the Java-based programs that I need to run for work, I get a message that says, "To open “PluginProcess,” you need a Java SE 6 runtime. Would you like to install one now?"  (PluginProcess is replaced by the program name if I am running a Java program.) If I click "Install", the Apple version of Java 6 gets installed.

 

This doesn't make sense to me. Why would Java 7 need the Apple Java 6 environment? And why doesn't Safari or other Java based programs recognize that the Java 7 JavaAppletPlugin.plugin is on my computer already?

 

Although I'm not really an IT person, I am pretty handy with the Terminal and command line operations, so if fixing this means using the command line, I'm good with that.

 

Thanks!

1 2 Previous Next