Skip navigation

startup troubles iMac G5

613 Views 3 Replies Latest reply: Oct 27, 2012 1:39 PM by -Rotten Apple- RSS
lapresle Calculating status...
Currently Being Moderated
Oct 23, 2012 1:46 PM

I have an old iMac G5 that was working fine when I put it in storage. This was a few years ago and I tried to start it up and I can't get past the gray screen with the dark gray apple. I have a wireless keyboard and held down the shift key to start it in safe mode, but that didn't work. I'm able to view it as a fire-wire drive by connecting it to my MB Pro and holding down the T key when I start it. Anysuggestions?

  • Klaus1 Level 8 Level 8 (43,415 points)
    Currently Being Moderated
    Oct 23, 2012 3:13 PM (in response to lapresle)

    Start by replacing the PRAM battery.

  • steve626 Level 4 Level 4 (1,395 points)
    Currently Being Moderated
    Oct 27, 2012 12:19 PM (in response to lapresle)

    In addition to replacing the PRAM battery as was suggested, you may need to use a wired keyboard (USB) to be able to use some of the special startup options (such as safe mode with shift key held down, which is a good thing to try).

     

    Also, try resetting the SMC, which can be done as follows: shut down the computer, remove ALL connections to the computer, including the power cord, all usb and firewire peripherals, etc. Wait 60 seconds. Then, while holding in the power on button, plug in the power cord to the back of the computer. The release the power button and push it one more time to start up.

  • -Rotten Apple- Level 1 Level 1 (45 points)
    Currently Being Moderated
    Oct 27, 2012 1:39 PM (in response to lapresle)

    If you power up the machine and press Apple key + V you should get text lines instead of that Apple logo, last line usually tells why/where the booting hangs. iMac G5 machines had lots of troubles with graphics card, I know for a fact that sometimes when graphics card is failing it might work just fine under very light load (eq. booting screen) but will hang when its acceleration features are enabled. Hopefully it is not hardware problem. One option would also be to try to boot from disc and use Disk Utility to repair the disk, you might also click repair permissions just to be sure.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.