4 Replies Latest reply: Dec 5, 2012 8:13 PM by willhaus
willhaus Level 1 Level 1 (105 points)

[Sorry to repost, but the time limit cut me off before...]

 

Hi everybody,

 

After my recent upgrade to Mountain Lion Server from Lion Server, I was surprised that most services (DNS, calendar, file sharing, messeges, contacts, OD, Time Machine) came online with little trouble. The only exception was the wiki service, which I have not been able to get running after a few weeks of trying everything I can think of. An additional detail is that while normal personal calendars wrk fine, group calendars (i.e. those tied to group wikis) do not. I've scoured these discussions and have seen a number of issues that seem like mine, but no solutions. So I'm hoping maybe somebody can help me out.

 

If I click on the Wiki option in the sidebar of Server.app, I get a "Error Reading Settings". I often get an error "An error occurred on the server while reading settings. The error occurred while reading settings for the Wiki service." upon launching Server.app, even if I have not clicked on anything.

 

After I try to start the wiki service, "sudo serveradmin fullstatus wiki" in the terminal gives me the result

 

serveradmin[34803:707] outstanding requests are: (

        {

        Command = getState;

        Module = "servermgr_wiki";

        Timestamp = "2012-10-24 05:06:40 +0000";

    }

)

 

Oddly "sudo serveradmin stop wiki" downs;t seem to be able to stop the service, and give the same "outstanding requests" result.

 

I do not know if it's related or not, but if I click Logs in the Server.app sidebar, nothing shows up anymore. But if anyone asks me to retrieve something from a log, I can dig it out with root access.

 

Thank you for any help you can give me.

 

Sincerely,

Willhaus

  • 1. Re: Wiki doesn't work after upgrade to Mountain Lion Server
    willhaus Level 1 Level 1 (105 points)

    Okay, so a little more detail for you…

     

    If I can manage to restart the server without the wiki service on, everything else seems to work fine (including the web service running the default home page) and "serveradmin fullstatus wiki" will report that the service is stopped.

     

    But as soon as I try to start the wiki service, it never finishes, and it prevents the web service from working properly anymore. i.e. I get a 502 Proxy Error instead of the OS X Server default home page. It's after the attempted wiki start that "serveradmin fullstatus wiki" starts to give the

     

    serveradmin[2373:707] outstanding requests are: (

            {

            Command = getState;

            Module = "servermgr_wiki";

            Timestamp = "2012-10-25 16:22:15 +0000";

        }

    )

     

    error. And then I can't stop the wiki service - even "serveradmin stop wiki" gives the same "outstanding requests" message.

     

    This time I tried to stop the wiki from Server app and I got this error:

     

    An error occurred on the server while processing a command.

    The error occurred while processing a command of type 'getState' in plug-in 'servermgr_wiki'.

     

    If it's helpful at all, I've notice the following in my log files that seem related, but I have no idea how to fix - it almost seems lie the migration of the wiki failed from 10.7 to 10.8:

     

    collabd[767]: [CSConnectionPool:141 6a92000 +14027ms] Schema is STILL out of date (14 < 69) after launching wikiadmin, update failed! collabd will refuse to run until this is fixed.

     

    I'm really pulling my hair out over here, and have no idea what to try next?

     

    Anyone have any suggestions?

     

    Thank you!

  • 2. Re: Wiki doesn't work after upgrade to Mountain Lion Server
    willhaus Level 1 Level 1 (105 points)

    Well, okay, poking around a little more, I tried the instructions for migrating/copying wikis at this link-

    http://support.apple.com/kb/HT5082?viewlocale=en_US&locale=en_US

     

    When I follow them to the letter, the result is no different than what's been happening.

     

    BUT, if instead I run

    "sudo dropdb -U collab collab" and then go straight to "sudo serveradmin start wiki" the wiki starts perfectly!

     

    Of course since that skips the restore/import step, I don't have any of my old wiki data.

     

    It seems like something in that collab.pgdump file prevents the wiki service from working right. Maybe a migration doesn't work right or something? I don't know anything at that level of detail.

     

    Does that info give anyone an idea about what might be happening? Anything that might help me get it running?

     

    Thanks again,

    Willhaus

  • 3. Re: Wiki doesn't work after upgrade to Mountain Lion Server
    Ashdonian Level 1 Level 1 (0 points)

    I've got the same problem with my wiki OS10.8.2 + server 2.2. Did you get a solution that preserved the wiki data? My system reports it cant get a connection to the server even though it is running filesharing. I get identical results as you web page works if wiki is off when I open Server.app. Neither can I start wiki from Terminal it just reports "starting".

  • 4. Re: Wiki doesn't work after upgrade to Mountain Lion Server
    willhaus Level 1 Level 1 (105 points)

    Argh, no.

     

    In the end, I ended up destroying all wiki information on the new server, running a dupe of the old server on another computer, and slowly copying all wiki entries frpm the old server to the new through the web interface. A serious drag, but since we have < 100 entries, it's not exactly the end of the world. One good thing to note is that as soon as I created the new wikis on the new server, all of the old calendar data associated with those wikis became available too - ie I didn't loose it.

     

    For what it's worth, I did have a ticket in with Apple and they agreed to escalate the issue to Engineering since we have mission criticla data in the wiki, but I haven't persued that since this fix.