10 Replies Latest reply: Oct 24, 2012 12:54 PM by likepic
likepic Level 1 Level 1 (0 points)

I am missing master files from Aperture 3. I rebuilt the library with no success.

 

Oddly, I can't even find them in Time Machine even though I know I exported versions of them. The entire month of imports doesn't ever appear in Time Machine even though I have proof that I used the master files to export in July. I haven't used Time Machine a lot so maybe I'm missing something.

 

What else can I try.


Aperture 3, Mac OS X (10.7.5)
  • 1. Re: Missing master files in Aperture
    Tony Gay Level 4 Level 4 (1,625 points)

    A little more info please.

     

    1. Are you working with

    a. a Managed library workflow, or

    b. a Referenced file workflow?

     

    2. Are you working with multiple hard drives & is it possible that the images are on an external drive?

     

    3. Have you tried searching for another library on your system that may have been accidnetally created and contain the missing images? Search for either

    Aperture Library.aplibrary

    or just

    aplibrary

     

    Let us know how you go.

     

    Tony

  • 2. Re: Missing master files in Aperture
    likepic Level 1 Level 1 (0 points)

    It's a managed library all on my hard drive. I don't use external drives.

     

    I have over 11,000 images in that library. I have been intending to start another library but haven't done it yet.

     

    I searched for another library and found nothing.

  • 3. Re: Missing master files in Aperture
    Tony Gay Level 4 Level 4 (1,625 points)

    Any external drives that you ever connect, however unlikely it may seem?

     

    Are the projects that you imported the files into appearing?

     

    Tony

  • 4. Re: Missing master files in Aperture
    likepic Level 1 Level 1 (0 points)

    The external drives makes sense but I don't use any other than 2 USB drives and a portable drive - I just checked them (and of course Time Machine).

     

    There are three projects from 2010 (taken around the same time) that appear in Aperture, I can view the images but when I go to adjustments, it says "image not found" for all the photos inside these two projects. Each one of these images has the yellow triangle with the exclamation mark in the corner.

     

    I accessed one image from one of the projects in July (adjusted and exported an image) but I don't recall doing anything with the other projects.

     

    When I check on Time Machine before and after July there are no masters imported in the corresponding month before or after July.

     

    I really appreciate you taking the time on this frustrating problem.

  • 5. Re: Missing master files in Aperture
    léonie Level 9 Level 9 (51,640 points)

    Have you checked, if the missing masters are inside the Aperture Library package?

    Sometimes Aperture looses the connection to managed masters.

     

    You need to find out the exact date that you imported your images - you can find that information in the "Import Session" metadata tag - ad this tag to one of the metadata preset that you use to display the metadata in the info panel - set themetadata preset in the  info panel to "edit".

     

    Then open the Aperture Library package (ctrl-click the Aperture Library in the Finder window) and select "Show package Contents". Inside the window that opens go to the "Masters" folder, then inside to the year , month, day you imported the images. Are the original master image files still there?

     

    If yes, then make a backup copy of these images, to have a copy just in case, and try to repair the permissions in your library with the library first aid tools:

    Aperture 3 User Manual: Repairing and Rebuilding Your Aperture Library

     

    If you cannot reconnect the missing originals/masters this way, reimport the masters you found inside the library.

     

    Please post back, once you looked inside the library, if the masters/originals are still there.

     

    Regards

    Léonie

  • 6. Re: Missing master files in Aperture
    likepic Level 1 Level 1 (0 points)

    Thanks for the note.

     

    I had checked inside the Aperture library and didn't find them. I double checked again now to make sure - still no luck.

     

    I previously tried repairing and rebuilding the Aperture library.

     

    I would have thot it possible that I accidently deleted the masters but I have evidence on my computer that I accessed one of the images in July and exported it. Yet Time Machine doesn't show the missing masters either before or after that date. How is that possible?

     

    Is there something else I can check?

  • 7. Re: Missing master files in Aperture
    léonie Level 9 Level 9 (51,640 points)

    When did you export the image? Directly after importing?

     

    A common reason for missing masters/originals after import is to import them referenced, with the "Store files" pop up menu set to "In their current location". In that case your images will be left sitting on the card, and when you eject and erase the card, the images will be gone. Or import referenced to a different location than you wanted, for example the Desktop or another folder that you frequently erase.

     

    As for TM not showing them -you may have deleted them shortly after import.

     

    What also may have happened - if you tried to import referenced to an external drive and the drive has been dismounted during import - you may accidentally have moved and disconnected the cable - then Aperture may continue to import and write to its temporary directory instead /tmp. After some time this directory will be automatically erased, and it will not appear in the backup.

  • 8. Re: Missing master files in Aperture
    likepic Level 1 Level 1 (0 points)

    All great possibilities but not quite my situation.

     

    I exported one image in July 2012 but the masters in that folder were imported in April 2010. In 2010 I used them for a number of things so they imported properly initially.

     

    I have never imported files referenced - always to the same library.

     

    On the TM - I used the image in July so if I erased it afterwards, it should have shown up prior to that.

     

    This is frustrating.

  • 9. Re: Missing master files in Aperture
    léonie Level 9 Level 9 (51,640 points)

    Did you really export - using the export menu and not the media browser or dragging from the Aperture library window. The reason I am asking: You can happily be using your images and never notice that the original masters are missing, if you have high quality previews. Aperture will only use the previews and nor complain, unless you try to use "File > Export" or to edit the images. Do you recall clearly, if you edited the images during that critical period?

  • 10. Re: Missing master files in Aperture
    likepic Level 1 Level 1 (0 points)

    I am certainly learning a lot of things from this exercise by your good questions.

     

    I clearly remember using file>export to transfer the image since it is the same process I use for preparing all the images that I post on my blog. The exported image also has my wordmark on it which I don't think is possible without exporting.

     

    I also recall doing some edits to the image before exporting it.