Skip navigation

Safari slow and freezes when loading pages

86474 Views 88 Replies Latest reply: Nov 22, 2013 9:40 AM by G.Madigan RSS
  • Volantiad Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 9, 2012 1:50 PM (in response to Hoose0)

    I'm dismayed to see that the original post for this problem ~ which exactly describes my problem ~ was made in late April of this year... about 6 months ago.  I didn't start suffering from safari atrophitis (made that up) until about maybe 6 weeks ago.  Kinda crept up on me till I really noticed it about 3 weeks ago.  I guess I just hoped it'd go away on it's own (i.e. Apple might fix the problem) but it hasn't.  Sadly, it seems like the 'cure' is to stop using Safari and switch to something like Chrome or FireFox.  Well, if I have to, I will.  I can't take waiting 10, 20, 30 seconds for a webpage to open... if it does at all.  Yahoo, particularly, seems to suffer from this ailment although no webpage seems imune.  Bye, bye safari: it's been nice knowin' ya.   

  • fruzzl Calculating status...
    Currently Being Moderated
    Oct 14, 2012 8:56 PM (in response to Volantiad)

    I agree. I just upgraded to mountain lion and noticed a degredation in performance with safari. Not sure if the reason is related to mountain lion or not but it appears to be an unisolated issue.

     

    For me, when I search, or type in an address in the url line of Safari, it will freeze after I hit enter for roughly 10-30 seconds. It then loads fast...but it's quite frustrating. I hope this isnt a sign of things to come with Apple in general now that their fearless leader has passed.

     

    If Apple techs are reviewing these forums please read through this thread thoroughly as this is a very frustrating issue.

  • Bucky Turgidson Calculating status...
    Currently Being Moderated
    Oct 16, 2012 3:44 AM (in response to fruzzl)

    I have the same problem.

     

    It is definately Safari related as using any other browser removes the delay.

     

    This is a shame as I like Safari but i cant pu up with such slow page loading.

     

    I may have to look at option 5!

  • G.Madigan Calculating status...
    Currently Being Moderated
    Oct 22, 2012 7:04 AM (in response to excelcius)

    I tried the suggestion by "Hal in Maine":

     

    I have been having the same problem, but may have at last found a fix. I am running Mountain Lion and an Apple Airport Extreme Basestation router along with a recent iMac. What I did was go into Network settings through System Preferences, click on Advanced, click on the DNS tab, and then the + sign under DNS servers. Then I added the Google DNS address, which is 2001:4860:4860::8888. I then dragged this address to the top of the list of DNS servers and clicked Apply. Restarted Safari and Chrome and both are now much faster on loading web pages. Hope this may help.

     

    • Making sure 2001:4860:4860::8888 (EXACTLY as shown with the double colons :: ), and it was first in the • DNS list by adding it (copy/paste works) then dragging it to the top of the list.

    • Be sure to click the "Apply" button before leaving Network Preferences. (BTW – I never used WiFi, it's not on, but to suggest turning it off and using an ethernet cord as a solution is insane in 2012. That is NOT a solution.)

    • Quit Safari and re-opened it.

    • I haven't tested it long term.

     

    Although Safari's blue progress bar is still acting very oddly (pausing about 80% of the way across then vanishing for a several seconds), the reliability of it loading a page has been perfect so far.

    A quick side-by-side comparison with Firefox showed no significant difference when going to a few not-previously-visited sites.

     

     

    WARNING: Rant Ahead!

     

    I am getting very tired of bumping into more and more half-baked Windows-like problems with an Apple logo on it. The worst of it is Apple now gives Microsoft-like (read as useless and fonger-pointing) solutions that are often taking months, if they ever reply. I can see why Woz left to go to Australia; MUCH faster internet and to get away from this Microsoft-like morphing of Apple, a producer of cheap and poorly tested hardware and software, and big $$ for minor (if any) improvements.

     

    Do you remember when the Apple stores had chilled bottles of water?

    Do you remember when the Apple stores had people demoing the hardware that knew how to format a drive?

    Do you remember when the Apple stores had people demoing the hardware that knew what a Level 2 Cache was and what it did?

    Do you remember when the Apple stores had people that didn't make you feel like you were an idiot for spending so much on so little?

     

    OK: Done ranting.

  • fruzzl Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 24, 2012 1:15 PM (in response to G.Madigan)

    I too tried the suggestion by Hal in Maine and my problem persisted. Now i'm starting to think it doesnt have much to do with Safari though. Everytime I wake my macbook from sleep mode it drags when trying to load a page. I have to reset the wifi in order to continue.

     

    Before it appeared it had only to do with Safari, then I thought it hd something to do with flash player, but I'm not sure anymore. Hal in maine seems to have issues with google pages only which isnt my problem and most others on here. This happens on every page.

  • Gontran Bolduc Calculating status...
    Currently Being Moderated
    Nov 21, 2012 2:07 PM (in response to excelcius)

    I may have found a solution for the problem of speed interruption.

     

    The logic I followed is this one.

     

    There is no pattern for the anomaly to occur. I presumed the IMAC is working properly because the same event happened to different computers at home. I suspected the problem was in communication with the service provider because I have a server on my intranet and the problem was not present.  Then I assumed 2 automatic communications programs were fighting for control.

     

    Here is what I did and this worked for me 95% of the time.

     

    Go to system preference

     

    Click on

    • network
    • advance
    • Hardware
    • MTU - Change Automatic to Custom and in the window change 1500 to 1300.
    • Click on OK
  • Thomas Harnish Level 1 Level 1 (20 points)
    Currently Being Moderated
    Nov 23, 2012 6:06 PM (in response to Gontran Bolduc)

    Solved the problem. Curious, worked fine for, well, since forever. Then suddenly every pageload studdered or failed. Your solution fixed it for me.

  • Hal in Maine Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 24, 2012 6:48 AM (in response to Gontran Bolduc)

    I did what Gontran suggested and, miraculously, both Safari and Chrome have improved their response times. Just like the good old days. Both are now much speedier in their retrieval of web pages, both on my iMac running Mountain Lion and on my iPad running IOS 6.0.1

    Now, if Apple would just publicize this fix!

  • Gontran Bolduc Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 26, 2012 3:06 AM (in response to Hal in Maine)

    I did report to apple the problem and the temporary fix. 

  • A.Gardoh Calculating status...
    Currently Being Moderated
    Nov 28, 2012 11:29 PM (in response to Gontran Bolduc)

    This worked for me

  • pato_londres Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 1, 2012 9:24 AM (in response to Gontran Bolduc)

    Hi Gontran Bolduc tried to use your solution, but I use WiFi to connect to the Internet and therefore my setting are different.

     

    Do you have a solution for WiFi users?

  • Gontran Bolduc Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 3, 2012 8:23 AM (in response to pato_londres)

    I hope I am giving you the answer you are looking for:

    in the preference you click on

    network

    • wi-fi
    • advance
    • Hardware
    • MTU - Change Automatic to Custom and in the window change from 1500 to 1200 or 1300 or 1400. (The site Thomas Harnish found is really good.)
    • Click on OK and apply

     

    If use a IPAD after sync. with your computer, (I suspect) it will modify itself for the size of the packet.

  • pato_londres Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 3, 2012 9:13 AM (in response to Gontran Bolduc)

    Hi Gontran Bolduc I don't appear to have these setting. I trying to attach a screen grab so you can see my menu settings. Thank you very much for helping me

     

    ScreenSnapz.jpg

  • Gontran Bolduc Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 3, 2012 9:18 AM (in response to pato_londres)

    Are you talking about a computer, an Ipad or Iphone?

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.