Skip navigation

Logic 9's UI extremely laggy - any fixes?

53479 Views 516 Replies Latest reply: Aug 21, 2013 3:10 PM by nicowieditz RSS Branched to a new discussion.
  • albertneve Calculating status...
    Currently Being Moderated
    Oct 15, 2012 3:24 PM (in response to Fredo Viola)

    I will appreciate if someone could say which file is the right one inside Lion Installer. I went file by file and didn't find nothing similar to "iLife" or similar...

  • Fredo Viola Level 1 Level 1 (30 points)
    Currently Being Moderated
    Oct 15, 2012 3:27 PM (in response to albertneve)

    Luis from Logic Pro support today told me that since Lion iLife is separate purchase, so in my case this is probably not the problem. In fact, when looking at my computer I expected that iMovie etc had been automatically installed but it isn't even there.  I would suggest you make sure it's installed in the first place.  If it is, find the iLife installer from around the time of the Lion release and install that. 

  • Junior.se Calculating status...
    Currently Being Moderated
    Oct 19, 2012 2:30 AM (in response to fluffy)

    If they don't fix this soon it's the end of Logic!! I guees i aint the first to post this kind of comment but allot of Logic work is making you wish you wher in a mexican jail for drug trafficing.. Me and my boys found a way to get away from the hang (sort of).. Assinging a stop key on your midi keyboard and you can atleast stop the thing from playing and get out of the hang. Let's hope they fix it soon!!!!

  • seantyas Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 19, 2012 4:01 AM (in response to Junior.se)

    This whole situation is, for lack of a stronger and potentially censorable word or phrase, RIDICULOUSLY ABSURD.

     

     

    "Install a clean iLife"!?! Ha!

     

    Apple techs, seriously now, really? What else can we all say here?

     

     

    Great job wrecking an institution of a program. Clear as day to see that this greedy iDevice focus is the new driving force.

  • joseek Calculating status...
    Currently Being Moderated
    Oct 20, 2012 2:32 AM (in response to fluffy)

    Confirm that downgrading to Logic 9.1.5 helps much in comparisson to what's by default. Three hours of just work with music without uncontrollable GUI. Thanks for a temporary solution!

  • Nick 235 Calculating status...
    Currently Being Moderated
    Oct 22, 2012 9:23 AM (in response to fluffy)

    WOW! ok I only upgraded to ML the other day, went straight from SL to ML for this very reason! should check the fourms first! DOHHHH! One way I am releved it's not just me and then in another rather annoyed! I mean this thread is amost 3 months old!!! It's quite a major issue...not a bah I'll put up for it one...it's proper anoying!!!

     

    Anyways...if there is a solution, apart from downgreaging logic or running my BKup SL from my other divre (which I don't want to as apart from this issue I realy like the OS!) PLEASE POST IT! ..... I have a feeling Logic X is going to be announced soon...there has not been a logic update for quite a while now!

     

    XX

  • Preen Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 23, 2012 7:52 AM (in response to fluffy)

    I hate this... the creativity is blown away when you have to wait 10-40 seconds for Logic to response...

  • Jane Snijders Level 1 Level 1 (40 points)
    Currently Being Moderated
    Oct 23, 2012 12:36 PM (in response to fluffy)

    I can confirm that downgrading to logic 9.1.5 solved the issue for me on 10.8.2 as well.

    I did the supplemental update of ML before downgrading to 9.1.5.

     

    After hours of working on a project no lag anymore. Start /Stop responds like it should . mouse is back.

    9.1.6 has been almost unusable here as well.

     

    apple has the previous 9.1 versions hidden here:

    Logic Pro 9.1.1 through 9.1.6 updates

     

    copy Logic 9.1.6 ( using right click ) then right click and press option to move it out of your application folder.

    Then install logic 9 from dvd and update using the above 9.1.5.

     

    apple is too busy with other things as we could see this keynote......

  • Nick 235 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 23, 2012 2:03 PM (in response to Jane Snijders)

    I think I've worked out where the issue lies.... I could be well off but what seems to happen is the mouse is losing focus......and I think it's to do with short cuts/gestures on ML... please don't crucify me I am nice person! I think somewhere in something between the versions of logic and ML there is some conflicting things around gersurs and shortcuts...one short cut that I've notice which messed my old SC settings is CTLR and the arrow keys...I've gone from SL to ML so donno if this was something in L. I personally keep pulling out of logic cause my old short cut for zooming in logic was CTLR and the arrow keys. Now I have to use Option and CTLR.

     

    Soooooo........the mouse loses focus and thus giving the illusion of a UI lag.... although it appears to be running normal. Please test this. I'm wondering if this has been a main problem for logic users cause of the way shortcuts are used? Either the drugs are kicking in but I done this (which I can't find the post!! baa!) but System prefeancys>trackpad>zoom and scroll (tab) -> and uncheck Scroll Direction and i can't say I've had this UI issue again....worth a go? Actauly who here is using a track pad? and not...cuase if it's just track pad users then this may be the fix?!?!!?!??!

     

    ^^it's just a theory and at this moment in time....anything kind of theory must be of some use to someone somewhere anywhere...hello is there anybody out there....space is lonely...good bye

  • ZXC Level 2 Level 2 (180 points)
    Currently Being Moderated
    Oct 24, 2012 1:57 PM (in response to Nick 235)

    About the Logic Pro 9.1.8 Update

    General

    • Additional content downloads now behave correctly when installing on OS X Lion and OS X Mountain Lion.
    • Resolves an issue in which the Save As command sometimes resulted in an alert dialog in Logic 9.1.7.

    Audio

    • Fixes an issue that caused an Airplay dialog to repeatedly appear.
    • Relaunching the audio driver now reliably applies changes made to the buffer size.

    Performance and Stability

    • Resolves performance issues when using plug-ins that provide frequent graphic feedback.
    • Resolves an issue that could cause an abnormally large monitoring delay after a computer wakes from sleep.

    Plug-ins and Instruments

    • Fixes an issue with ES2 that could create distortion when a sidechain was used as the modulation source.
    • Tuner now responds consistently when used in a channel strip that also contains plug-ins which introduce latency.
    • The MIDI channel for a multi output software instrument is no longer changed when adding Aux outputs when there are regions on the track.

    Compatibility

    • Logic now properly maintains Aux assignments for multi-output instances of Kontakt that are migrated from earlier versions to Kontakt 5.
    • Resolves an issue in which deleting tracks took longer than expected if Melodyne Editor was inserted on a track
  • Preen Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 24, 2012 2:31 PM (in response to ZXC)

    I installed the update but the problem still exists for me

  • SmokenSound Level 1 Level 1 (20 points)
    Currently Being Moderated
    Oct 24, 2012 2:34 PM (in response to Preen)

    Please more feedbacks on update , need to be sure )

  • Preen Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 24, 2012 2:40 PM (in response to SmokenSound)

    Well Its much better than it used to be though, but I had the same unresponsiveness when I had 2 (1 eq with analyze on and one softube plugin with some graphical content) plugins open and playing the song...

     

    But can't recreate the problem so don't know if it was just some glitch...

1 ... 23 24 25 26 27 ... 35 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (6)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.