Skip navigation

Crashes & corrupted imports in Aperture; reinstall?

795 Views 16 Replies Latest reply: Dec 5, 2012 6:26 PM by Frank Caggiano RSS
1 2 Previous Next
Sue C Calculating status...
Currently Being Moderated
Oct 23, 2012 12:21 PM

I have a MacBook Pro that had Aperture preinstalled when I bought it 2 years ago. I recently upgraded to Lion 10.7.5 and Aperture version 3.4.1 after having multiple crashes, but the crashes continued to happen. They happened usually (but not always) when I was using the loupe to inspect images for focus quality. I have repaired the library (after each crash) and also rebuilt the library. I was advised by a tech at the local Apple Store to create a brand new library with all new images and work with it for a while. If it did not crash, that might suggest my old library (or files within the library) was damaged or corrupted in some way. So I created a new library with 4 new projects. Aperture has not yet crashed, but now I am seeing lots of errors on imports from my SD cards. Some files cannot be imported and are put directly into Aperture trash. Others are marked with a badge that indicates the "referenced" originals are missing, but I don't use referenced files, only managed ones. The badges seem to be appearing on different photos each time I launch Aperture. So now I am thinking I should reinstall the software -- but since it came preinstalled, I don't have a CD or App Store purchase. How do I reinstall it?

  • Tony Gay Level 4 Level 4 (1,625 points)
    Currently Being Moderated
    Oct 23, 2012 11:58 PM (in response to Sue C)

    Have you tried deleting the preferences file?

     

    This page details how to do it.

     

    http://support.apple.com/kb/HT3805

     

    let us know how you go.

     

    Tony

  • Tony Gay Level 4 Level 4 (1,625 points)
    Currently Being Moderated
    Oct 24, 2012 8:18 PM (in response to Sue C)

    Disk Utilities is a great place to go, I would also delete the application preference though, this will not hurt in any way and given that this is happening when you are using Aperture and not other applications(?) to me it sounds more application related.

     

    Definately do this prior to re-installing the OS.

     

    Tony

  • Frank Caggiano Level 7 Level 7 (22,760 points)
    Currently Being Moderated
    Oct 25, 2012 7:41 AM (in response to Sue C)

    What OS was on the system when you first bought it? If it was Lion then you should be able to go to the App Store and associate this system and your Apple ID and have access to any of the SW that came installed on the machine.

     

    Second when you have these crashes does the whole system stop working necessitating a reboot of the machine or is it only Aperture that stops working but everything else is OK? If it is the former then yes this is a kernel crash but if it i the later then the tech misspoke and this is an Aperture crash.

     

    The import problems you are now having, are they happening with the new library you made or with you original library?

     

    I would suggest you create a new user on your system, log in as that user and run Aperture on a new library. Try all the functions you are having problems with currently and see what happens. This will help us determine if the problem is with something in your environment or something that is system wide.

     

    regards

  • Frank Caggiano Level 7 Level 7 (22,760 points)
    Currently Being Moderated
    Oct 25, 2012 8:09 AM (in response to Sue C)

    If it had SL installed when you bought it its a bit more complicated then.  Are you sure you did not get a DVD of Aperture? You should have. Did you at least get a serial number for the application? If you have a serial number you can download the application and use your serial number to unlock it. If you did not get either of those you will have to contact Apple to try and get the application.

     

    What you describe is a kernel panic. Very rare for a single application to cause this. Did the crashes only start happening since you installed Lion? If so did they start right away or after some time?

     

    Creating a new user as I wrote will possibly indicate where the problem lies. If the new user account runs OK then the problem is in something in your current user environment and would lead us in one direction. If the problem continues to occur with the new user then it would lead us in another direction. Again this is just a troubleshooting step I'm not suggesting you permanently run as the new user.

     

    Looking back at your first post I see you've had the machine in to an Apple Store already. The best thing for you right now might be to continue working with them. I'd also bring up the fact that Aperture came installed on your system when you bought it and you didn't receive a DVD or serial number (assuming those are both true) and that you were entitled to them and you want them for backup purposes.

     

    good luck

     

    regards

  • léonie Level 8 Level 8 (46,430 points)
    Currently Being Moderated
    Oct 25, 2012 8:30 AM (in response to Sue C)

    Aperture has not yet crashed, but now I am seeing lots of errors on imports from my SD cards.

    Sue, to exclude that the problem come from your cards, cardreader, or camera, I'd suggest you perform the checks that Frank Caggiano recommended also with images that you have checked in other applications, and that you know are o.k. Have you a folder with Desktop pictures, or other images that could be used for a test library?

  • Frank Caggiano Level 7 Level 7 (22,760 points)
    Currently Being Moderated
    Oct 25, 2012 10:24 AM (in response to Sue C)

    Well as I wrote above as you have had Apple Support inc=volved in this it is probabply best to continue with them. At least you should push to get the DVD and or Serial number for Aperture. Whithout at least a valid serial number you're in trouble,

     

    In addition I've laid out a number of steps you could follow. If you try any of those post back the results and we'll see if there is anything else we can do here.

     

    regards

  • léonie Level 8 Level 8 (46,430 points)
    Currently Being Moderated
    Oct 25, 2012 10:49 AM (in response to Sue C)

    So...if I understand you and Frank correctly, you're suggesting creating a new user and new library with some test images, and use this test library on Aperture to see whether a kernel panic occurs?

    Yes, the steps Frank recommended will help to narrow down the problem. Kernel panics are rare, but hard to track down. They may be caused by incompatible software, mostly caused by installing third-party software kernel extensions (do you have any "helper" apps installed, non Apple software or plug-ins?),  hardware trouble (defective RAM, disks, or graphic cards), incompatible firmware, or occasionally buggy software.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.