1 Reply Latest reply: Oct 25, 2012 6:52 PM by John Galt
Robert R. P Level 1 Level 1 (0 points)

What are the known incompatible applications with previously supplied Apple Applications starting with OSX?, and now using Snow Leopard, but wanting to know whether or not to switch to Mountain Lion. My iMac is Mac OS X Version 10.6.8 with 2.8 GHz Intel Core 2 Duo with 4 GB 800 MHz DDR2 SDRAM. Will I have trouble with Photo Shop CS.15, MS Office 2008, iPhoto 11, Keynote 09 v5.0.4, Disk Warrior 4.4,

TechTool Pro 6 v 6.0.6, Reunion 10-0-4, Preview version 5.0.3 (504.1), and can I continue to take screen shots?


iMac, Mac OS X (10.6.8), Tech Tool Pro 6.0.4 Identified Defe