5 Replies Latest reply: Oct 26, 2012 2:38 PM by Mark23
upctry2 Level 1 Level 1 (0 points)

Hi ,

 

 

I have a 2.8 quad core xserve running 10.6.8. Can I upgrade this to 10.8?  I was told by

someone that it is to old.

 

My reason is I want to repace my G5  workstations, which work fine but need to upgrade PS

for other software that is intel based. The server function is to store working client image files

projects.  That's it.

 

I was thinking of getting a new macmini to replace the G5 and use my 30" monitor so was concerned

with combatibilty issues.

 

Thanks

Martin

  • 1. Re: Can I upgrade my xserve
    John Lockwood Level 5 Level 5 (5,370 points)

    If your XServe predates 2009 then it is too old to run Mountain Lion. See http://www.apple.com/osx/specs/

     

    I would think from what you wrote that yours is indeed too old. Therefore you will need to get either a Mac Pro or a Mac mini and use that instead. My personal preference is to use a Mac mini and depending on your storage needs add to that an external Thunderbolt RAID5 system.

  • 2. Re: Can I upgrade my xserve
    upctry2 Level 1 Level 1 (0 points)

    ok so can I upgrade to Lion and be happy for now? The server does all I need of it right now.

     

    Thanks

    Martin

  • 3. Re: Can I upgrade my xserve
    Mark23 Level 3 Level 3 (975 points)

    Over the years the ability to customize OS X Server has almost disappeared. I would like to have the Xserve 2013 (if it would've existed), pure for the 1U form factor.

     

    But even then Apple has taken out much Server functionality like failover, not to mention the Server Admin GUI and it looks like Workgroup manager is to be deprecated in favor of Profile Manager, which essentially is not a stable product if you ask me. The only reliable services that people notice are Mail and Messages (the new iChat).

     

    I think there will come a time in the not so distant future that Apple will only make desktop products and will leave the server marker to Linux, another Unix flavor than OS X or - given Apple's effort to integrate OS X into Windows environments - deny IT staff the luxury of working with OS X.

     

    Upgrading to Lion is pretty safe if you still want to, just make sure you update 10.7 to the lates revision, which is 5 I believe.

  • 4. Re: Can I upgrade my xserve
    upctry2 Level 1 Level 1 (0 points)

    Thanks for the note , I agree with what yur saying. Not everybody needs the latest and greatest. It still works. Thanks for the tip on Linux.

    I'll do the upgrade for sure.

     

    Thanks again. Have a great day.

     

    Martin

  • 5. Re: Can I upgrade my xserve
    Mark23 Level 3 Level 3 (975 points)

    You're welcome, have a great day.