Skip navigation

Ethernet won't setup/work WIFI works fine...

3948 Views 13 Replies Latest reply: Nov 3, 2012 3:51 PM by Neville Hillyer RSS
Markie76 Calculating status...
Currently Being Moderated
Oct 13, 2012 12:06 PM

Hi Guys,


I wonder if you can help.


I have recently bought a G5 Imac (ppc) with10.5.8 on it which I have reinstalled with a single user setup as an admin.


At home I have DSL broadband with a Belkin F5D8636-4 N wireless router. My windows laptop and Android phone connect to it fine and internet works fine with the current settings.


On the Imac Airport connects absolutely fine to the router and the internet works as expected.

On the ethernet connection in the NETWORK screen in settings, I get a green circle by Ethernet but status within the 'Automatic' location states 'Not Connected'.


I have tried various variations of the setup; Using DHCP/DHCP with manual address/Manually - by typing in an IP address within the address range set in my router, typing in the router address, changing the subnet mask to match the router, nothing seems to work.


What I have tried;


If I set "configure" to 'Using DHCP' and click APPLY - the circle turns yellow then green after 5 seconds and it shows IP: SubnetMask BUT the status says "Connected. Ethernet has a self-assigned IP address and may not be able to connect."


If I set "configure" to 'Manually', then for IP I enter subnetmask I leave as (I changed the LAN setting in my router to match this) router I enter and click apply - the circle turns yellow then green and the status says "Connected. Ethernet is currently active and has the IP address". But when I launch Safari it says 'You are not connected to the internet'. When I log into my router and check the DHCP client list there is no entry for IP


I then click on 'Network Diagnostics' button in Safari, in the Network Diagnostics window on the left;

Ethernet has a red circle and under it states 'Failed' &

Network Settings has a green circle with nothing beneath it &

ISP has a red circle and under it states 'Failed' &

Internet has a red circle and under it states 'Failed' &

Server has a red circle and under it states 'Failed.


I then select Ethernet in the main window and click CONTINUE - The title says 'Not connected to Ethernet' and under it tells me 'This computer does not seem to be connected to a DSL or cable modem, or to an Ethernet network' - I click CONTINUE  - title changes to 'Unable to connect to the internet' and under it tells me 'Network Diagnostics cannot fix the current networking problems' - I click on QUIT.


I have tried both a 'straight through' and 'crossover' network cable and same behaviour with both.


Please help as my initial Imac satisfaction is diminishing quickly.





iMac, Mac OS X (10.5.8)
  • BDAqua Level 10 Level 10 (114,805 points)
    Currently Being Moderated
    Oct 13, 2012 1:03 PM (in response to Markie76)

    Hello Mark,


    Sadly it sounds like defective Ethernet Port, both are dead on my G5 Quad.


    One possibility that can cause Ethernet problems, possibly this also...


    Might be time to replace the PRAM Battery, 4 years is close to their lifespan, far less if ever without AC power, & can cause strange startup problems...


    See which one your G5 has...



  • BDAqua Level 10 Level 10 (114,805 points)
    Currently Being Moderated
    Oct 19, 2012 4:49 PM (in response to Markie76)

    Ah, that's pretty good news!


    I guess I'd try a 10.5 re-install.

  • BDAqua Level 10 Level 10 (114,805 points)
    Currently Being Moderated
    Oct 20, 2012 1:44 PM (in response to Markie76)

    I wonder if the Ethernet Kext from 10.4 would work in 10.5, mine is...?


    /System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns/AppleBCM5701 Ethernet.kext

  • BDAqua Level 10 Level 10 (114,805 points)
    Currently Being Moderated
    Oct 21, 2012 10:51 AM (in response to Markie76)

    Well, since Apple is not going to fix it, I'm just trying to suggest a possible workaround, no idea if it'll work since my 10.5 setup was stolen a few months back.

  • Neville Hillyer Level 4 Level 4 (1,845 points)
    Currently Being Moderated
    Oct 27, 2012 7:11 AM (in response to Markie76)

    Well done with your testing and disk swap.


    In my experience there is nothing about the Leopard install which makes wired ethernet unreliable.


    There is a kext problem caused by one of the upgrades which was never fixed by Apple but that does no more than put regular messages in the log - it does not affect reliability - for cleaner logs replace it with the earlier kext.


    Here are my network settings:


    Picture 1.png


    Try yours with the same. If your router fails to provide a DNS Server set it to


    Hit Advanced and turn off IPv6 - it is not going to work properly for most people for several years.


    Set your router to DHCP with as few limitations as possible. If practical change its DNS server to


    Turn off all wireless (at router and the problem Mac) until wired ethernet is working.


    Remove all ethernet connections to Mac and router except those being tested.


    Turn off all firewall restrictions and virus software.


    Try all ethernet cable and socket combinations. No need to play with cross-over cables as all Macs have auto-detected for many years.


    Reset router - see instructions - some just need power removing for 10 minutes. Shutdown and restart Mac a few times. If necessary repair Mac disk and permissions - I use AppleJack with the following instruction:


    applejack AUTO shutdown


    Good luck.

  • Neville Hillyer Level 4 Level 4 (1,845 points)
    Currently Being Moderated
    Nov 3, 2012 12:46 PM (in response to Markie76)

    When you installed Leopard did you import anything or was it a clean install with all preferences etc entered from the keyboard? If not perhaps you could try this. Backup everything to an external disk. Erase internal disk. Install Leopard without importing anything. Update via Software Update.

  • Neville Hillyer Level 4 Level 4 (1,845 points)
    Currently Being Moderated
    Nov 3, 2012 3:51 PM (in response to Markie76)

    Sorry - unable to think of anything else except to try another install.


    I will  recap for others who may wish to help:


    1. G5 / Leopard wired ethernet not working on either socket - wireless works OK.
    2. Wired ethernet works with Tiger on alternative hard disk.


More Like This

  • Retrieving data ...

Bookmarked By (1)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.