1 2 3 4 Previous Next 45 Replies Latest reply: Sep 20, 2013 2:41 PM by emilybk Go to original post
  • 30. Re: Google Talk and OSX Mountain Lion
    Ralph Johns (UK) Level 9 Level 9 (67,515 points)

    HI,

     

    I also have another thread now where someone is having issues logging in the GoogleTalk

    https://discussions.apple.com/message/20115305#20115305

     

    In the Messages Preferences have you tried deleting the account then re-adding it ?

     

     


    7:02 PM      Friday; October 26, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • 31. Re: Google Talk and OSX Mountain Lion
    matthewDG Level 1 Level 1 (0 points)

    I have tried that multiple times, unfortunately. I've tried re-adding the account in system preferences as well as messages' preferences.

  • 32. Re: Google Talk and OSX Mountain Lion
    Ralph Johns (UK) Level 9 Level 9 (67,515 points)

    HI,

     

    I believe Google have some sort of dual password process that can be applied.

    Are you using this as I have seen similar issues reported in the Mail app ?

     


    8:38 PM      Saturday; October 27, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • 33. Re: Google Talk and OSX Mountain Lion
    matthewDG Level 1 Level 1 (0 points)

    I was, actually, it's called two-step verification, many months ago, but I disabled it because that was around the time I first noticed connectivity issues with google talk, if I remember correctly.

  • 34. Re: Google Talk and OSX Mountain Lion
    Ralph Johns (UK) Level 9 Level 9 (67,515 points)

    Hi,

     

    Yep.  I have only seen it in posts regarding the Mail app and getting Google Mail (or at least logging in).

     

    However I am now seeing more GoogleTalk issues that don't seem to respond to any other  attempt to get them working.

     

    In the thread I saw about the mail app there seemed to be some suggestion that undoing the two step verification was not that simple a process.

     

     

     

     


    9:15 PM      Saturday; October 27, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • 35. Re: Google Talk and OSX Mountain Lion
    matthewDG Level 1 Level 1 (0 points)

    well changing back to one-step (password only) verification was easy enough, but I've tried using other IM applications with every IM service under the sun since switching back, and they all work fine. Messages is the only one I have issues with.

  • 36. Re: Google Talk and OSX Mountain Lion
    Ralph Johns (UK) Level 9 Level 9 (67,515 points)

    Hi,

     

    Can you go to the Keychain Access app in Applications/Utilities

    Find any and all items regarding the Google ID

    Double click them to open the info panel

    Check the access tab allows Messages and iMAgent to access the info.

     

    Back on the info tab tick the Show Password box and enter the Mac User Password in the dialogue box and Allow once to view the password.

     

    Do they match ?

    Are any to do with the two Step verification ?

     

     


    6:40 PM      Sunday; October 28, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • 37. Re: Google Talk and OSX Mountain Lion
    matthewDG Level 1 Level 1 (0 points)

    I allowed access to messages, but when allowing access to more applications it pops up with a finder window, and I'm not sure where the actual IMAgent process can be found. The password was not the same as my current password when I clicked "show password," it may have been the 2-step verification password, but I changed it and yet when I started messages, it still fails to connect.

  • 38. Re: Google Talk and OSX Mountain Lion
    Ralph Johns (UK) Level 9 Level 9 (67,515 points)

    Hi,

     

    IMAgent is a support app in System/Library/PrivateFrameworks/IMCore.framework

     

    I would also check the Keychain Access again for any second entry.

    It tends to add extra  entries when a password is changed  (it partly allows the same email to be used with different passwords on other sites).

     

     


    8:29 PM      Monday; October 29, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • 39. Re: Google Talk and OSX Mountain Lion
    inTOWN Level 1 Level 1 (0 points)

    +1 as I am having the same problem. Just upgraded to Mountain Lion on a new Macbook Pro, but whatever I do, the Google Talk won't work (same issues, tried all of the above suggestions)

  • 40. Re: Google Talk and OSX Mountain Lion
    pineappleitaly Level 1 Level 1 (0 points)

    Hi to all, i've finally found a way!

    i've problem with gtalk messages account , its not possible to login if i use my gtalk account directly in message preferencese .. no way to do this .. i get the message "this user are not using imessage" if try to send message to gmail account , and i can not see the "green" online light on my account.

     

    1) Open messages preferences and remove gtalk account.

    2) close messages

    3) open system preferences -> email account -> open the gmail account tab and check the "imessage icon" !

    Now my message work fine and the account was automaticaly add and connected to the program from the system preferences !

     

    i does not know how the manual message account add not work ...

  • 41. Re: Google Talk and OSX Mountain Lion
    akmalfikri Level 1 Level 1 (0 points)

    I can't find the said file

  • 42. Re: Google Talk and OSX Mountain Lion
    Ralph Johns (UK) Level 9 Level 9 (67,515 points)

    Hi,

     

    You need to be in the User's Home Folder (Little House iCon) and the Library in there.

    However in Lion an Mountain Lion this Folder is hidden.

     

    You can access it two ways, both from within the Finder.

     

    So with the Finder listed as the App that is "Front" (Listed in the menu bar next to the Apple icon) go to the Go Menu.

    Whilst holding down the ALT key, select the Library that then appears in the list.

     

    OR.

    In the Go Menu choose Go to Folder and type ~/Library in to the dialogue box that appears.

     

    From there you need to go to the Preferences  (At the method above you can type in~/Library/Preferences)

    Once in the Preferences you should be able to find the file I listed.

     

    There are two other folders called "Library" on your Mac.  (which you do not need to look inside)

    They are at the top level of the Hard Drive.

    One is visible in the window that shows Applications, System, Library and Users

    The other is inside the System Folder.

     

    (your Home Folder/Library is in fact in Users/(your account)/Library...)

     

     

     

     

    3Sigcopy2.png
    7:31 PM      Wednesday; April 17, 2013

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.3)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • 43. Re: Google Talk and OSX Mountain Lion
    Kanad Level 1 Level 1 (5 points)

    I too had the the same problem, but i solved it by the followin method.

     

    Step 1 : Enable 2 setp verification from gmail.com (https://www.google.com/settings/security)

     

    Step 2 : Go to Manage in Connected applications and sites tab

     

    Step 3 : Generate application specific password.

     

    Step 4 : Now go to system preferences > Mail, Contacts & Calenders > Google tab (If already) > details> enter your username and then the application specific password

     

    Step 5 : In iChat preferences , you'll now see the google acc with greyed out username and password and a single option of Enable this account.

     

    Step 6 : Now it should work

  • 44. Re: Google Talk and OSX Mountain Lion
    jinx.pt Level 1 Level 1 (40 points)

    To anyone still experiencing these issues, I have figured out a working solution.

    First let me present the problem more specifically:

    - I want to have both Gmail and Gchat on the native Mail and iMessages Apps on OSX.

    - I am using Google's Two Factor Authentication -> this is the important part, and where the problems arise

     

    Kanad, on the post previous to mine, states quite clearly how to generate codes for an application. The problem is that OSX tries to use the same code for both Mail and Messages, and Google doesn't like that. Sometimes keychain will accept a different password, but sometimes this won't work.

     

    So, the solution goes by using a 'feature' from google: your e-mail address on Google is exactly the same regardless of the amount of 'dots' it has in it. E.g.: If your e-mail address is my.name@google.com, if someone sends an e-mail to myname@google.com or my.na.me@google.com (etc), they will all end up on your account.

     

    So what I did, is setup two sepparate Google accounts on OSX's accounts setup:

    - I created one with myname@google.com for e-mail, using one generated password. During setup, I only activated the e-mail.

    - Then, I created a second account, using my.name@google.com (if you try to add a second account with the same address, OSX won't let you, thus why you need to create it by inserting (or removing) a dot. During this second account's creation, I only activated the Messages part, disabling the rest.

     

    I now have both e-mail and messages running fairly well, with two-factor authentication still enabled, on my OSX installation. Rejoice!