Skip navigation

file sharing 10.8.2 not working

6537 Views 20 Replies Latest reply: Oct 24, 2013 2:04 AM by APe Maia RSS
1 2 Previous Next
Ronohki Calculating status...
Currently Being Moderated
Oct 1, 2012 8:21 PM

I have two macbook pros and a mac pro connected on a lan. two computers are running osx 10.6.8 (mac pro and mac book pro) and the third is running 10.8.2. (new macbook pro). The one running 10.8.2 can see the other two in the finder but will not connect to them after typing in password through "connact as" button. The two running 10.6.8 can file share between them no problem but get a connection failed message in finder when trying to connect to the 10.8.2 machine with the "connect as" button. Is anyone else having this issue?

MacBook Pro, OS X Mountain Lion (10.8.2), finder file sharing
  • Larry Jorgenson Level 1 Level 1 (30 points)
    Currently Being Moderated
    Oct 1, 2012 9:06 PM (in response to Ronohki)

    I have a similar problem although my 10.6.8 machine can connect to the 10.8.2 machine.  Like you though, the 10.8.2 machine cannot connect to the shares on the 10.6.8 machine.  I can share the screen though.

  • Dennis Shedd Calculating status...
    Currently Being Moderated
    Oct 11, 2012 5:29 PM (in response to Ronohki)

    Same thing - 10.8.2 machine won't connect.

  • Daytripp Calculating status...
    Currently Being Moderated
    Oct 11, 2012 7:46 PM (in response to Ronohki)

    Same here, very fustrating

  • chestnutcow Calculating status...
    Currently Being Moderated
    Oct 16, 2012 12:50 AM (in response to Ronohki)

    Same problem but the 10.8.2 can connect to the 10.6.8 and not the other way around.  Come on Apple get it sorted please, a bug this basic should not be occurring.

  • Brenda Anderson1 Calculating status...
    Currently Being Moderated
    Oct 25, 2012 3:30 AM (in response to Ronohki)

    Yes, same problem for me too.  Can see my 10.7 machine from my 10.8.2, but cannot establish a connection.

  • satcomer Level 4 Level 4 (1,105 points)
    Currently Being Moderated
    Oct 28, 2012 4:09 AM (in response to Brenda Anderson1)

    Maybe the Apple document Connecting to legacy AFP services might help.

  • popeyesfx Calculating status...
    Currently Being Moderated
    Oct 28, 2012 4:27 AM (in response to Ronohki)

    I had a similar issue after installing a new macmini running mountain lion to my network. Mt does not connect to less secure service.s like those of snow leopard. I activated the legacy afp on the new mini as per the link posted by satcomer and it woked. Have to admit have only tried accessing from new mini to old one and not the other way.

    Hope this helps

  • PauloBoy Calculating status...
    Currently Being Moderated
    Jan 23, 2013 6:28 PM (in response to Ronohki)

    Oh yeah!!! Finally found some guys with the same problem than i have!!!! My 10.8.2 MBP see my imac (10.6.8) but that's all! I've been try connecting wireless direct or by firewire network mode between two mac, AND NOTHING! Just ping replys...

  • zzlaptop Calculating status...
    Currently Being Moderated
    Feb 20, 2013 9:42 AM (in response to Ronohki)

    ONE SOLUTION: USE IP ADDRESSES

     

    My Lion machine can see (ping) the Mountain Lion machine, but not other way round. And the Lion box can't connect to the Mountain Lion box as a server when connecting as afp://machinename.local wouldn't work.

     

    However, connecting to afp://IPaddress DID work. Example: afp://10.0.1.6.

     

    You can use the ifconfig command in the terminal to get your IP address. There are probably other ways, but that's how I habitually do it. It may be something like 192.168.x.y or 10.0.x.y.

     

    Worked for me - can't guarantee others. And still can't see the Lion box from Mountain Lion although when I'm on another network, my Finder window fills up with lots of other Macs. Weird.

  • Larsborg Calculating status...
    Currently Being Moderated
    Feb 22, 2013 2:38 PM (in response to chestnutcow)

    I have the same problem - cannot connect from 10.6.8 to 10.8.2.

    Every time I try to connect, netauthagent on 10.6.8 crashes.

    Do you see this?

    Check your ~/Library/Logs/DiagnosticReports

     

    I have found a weird workaround:

    The server's full user name must contain a space (chestnut cow).

    On the client side, in the connect dialog enter the name with the space.

     

    Please let us know if this works for you.

  • Daniel Filler Level 1 Level 1 (40 points)
    Currently Being Moderated
    Mar 3, 2013 6:49 PM (in response to Ronohki)

    Same here – both computers on 10.8.2 – neither connects but both see one another in the sidebar. Really getting annoyed with this one. Same wireless network, both with internet connectivity. Oddly enough, when I send out a broadcast in terminal I get responses from most of my iDevices, but not from the other mac which has the same netmask and same broadcast ip. This is a head scratcher.

  • lestudio Level 1 Level 1 (30 points)
    Currently Being Moderated
    Mar 13, 2013 12:51 PM (in response to Ronohki)

    I have the opposite problem. I have a mchimne running 10.8.2 that can connect to my other computers but  from any of the others I can't connectto the 10.8.2.

  • lestudio Level 1 Level 1 (30 points)
    Currently Being Moderated
    Mar 13, 2013 1:44 PM (in response to lestudio)

    after a lenthy session with apple care I have my problem fixed. after being told there was no fix , unfortunately filesharing either worked or it didn't, I got to a senior senior adviser. We eventually tried screen sharing and that worked. I was able to connect to my 10.8.2 machine and share it's screen. That drove apple care tech to check the firewall. That was under system prefs  Secuity and privacy/firewall then options. applefileserver was blocking connections as was networkbrowseragent. After changing to allow, I am not running correctly again.

     

    I realise that this was not the post for this but it was the closest. I have added this as maybe this may help somebody.

     

    I just remembered we also deleted the keychain password for the 10.8.2 machine on the other machine trying to connect to it, which forced it to ask for the password again.

  • Eric Root Level 6 Level 6 (14,000 points)
    Currently Being Moderated
    Mar 13, 2013 2:50 PM (in response to Ronohki)
    Try setting up another admin user account to see if the same problem continues. If Back-to-My Mac is selected in System Preferences, the Guest account will not work.

     

    Isolating an issue by using another user account

     

    If the problem is still there, try booting into the Safe Mode.  Shut down the computer and then power it back up. Immediately after hearing the startup chime, hold down the shift key and continue to hold it until the gray Apple icon and a progress bar appear. The boot up is significantly slower than normal.

                   

    Safe Mode

     

    Safe Mode - About

    General information.

     

    Troubleshooting Permission Issues

     

    Step by Step to Fix Your Mac

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.