Skip navigation

Pictures inserted into iMovie wrong or blank

591 Views 3 Replies Latest reply: Oct 29, 2012 9:02 AM by Markcw98a RSS
Markcw98a Level 1 Level 1 (5 points)
Currently Being Moderated
Oct 24, 2012 2:47 PM

My apologies up front as I know this has been flagged by others.   But, no one seems to have found a solution for this yet and my situation may be a little different.  I have a 2009 imac running Lion (10.7.5).   I did install the iPhoto and  iMovie '11 updates.    I was editing a project in iMovie- adding pictures from iPhoto from within the iMovie application.   Then I got an error message saying I had to restart my Mac.   That happened and then iPhoto would not open.   I had to rebuild the database for iPhoto (using opt+cmd) per another thread.   That worked and then I went back to iMovie and noticed that all the pictures that I had added to the project I was working on were playing as a black screen.   The thumbnails were there- just no picture played.   I also noticed that iMovie was less responsive, getting the spinning pinwheel a lot.   I tried deleting all the pictures I had inserted (all the video segments played fine) thinking that somehow the pictures were corrupted after the database rebuild.   When I tried adding pictures back in, a picture different from the thumbnail played- or it was black screen again. 

 

I also tried opening a new project and inserting still pictures- they played as they should.   I am guessing that my original project file is corrupted.   Is there a way to recover it so I can add still pictures?   Again- the video segments play fine.   

 

I did see a suggestion to delete some cache files- but I could not find them.   I also read that others tried this and still had the issue.   I would appreciate directions on how to find the files I need to delete- if that is a solution.   Or- any other ideas.    Thanks. 

 

Mark

iMac, Mac OS X (10.7.4), Also iPad2 and legacy iPhone.
  • John Cogdell Level 5 Level 5 (4,595 points)
    Currently Being Moderated
    Oct 28, 2012 5:20 AM (in response to Markcw98a)

    Hi Mark,

     

    Trashing iMovie's preference file will often fix problems, but may not help with your situation (but worth trying).

     

    Go to your User (Home) folder Library/Preferences (not the Library folder at the top level in Macintosh HD). Similar to Mountain Lion, on Lion the User Library folder will be hidden (unlike pre-Lion OS X versions). To access it, click on Go in the Finder menu bar, then press and hold down the Option key - the Library folder will appear in the drop down list, enabling access to it.

     

    In the Preferences folder, locate a file named "com.apple.iMovieApp.plist". With iMovie closed, drag this file to the Desktop. When next opened, iMovie will create a fresh preference file with the default settings (you can change these settings in the menu item "IMovie>Preferences" if desired). If iMovie is now running smoothly, it's OK to drag the old preference file to the Trash. Trashing the file will not harm your existing Events or Projects.

     

    John

    MacBook Pro (15-inch Late 2008), OS X Mountain Lion (10.8.2), Sony HDR-SR7 & DCR-TRV20E

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.