Skip navigation

iPhone 5 can't send SMS - gets an error when sending SMS

216753 Views 655 Replies Latest reply: Jan 8, 2014 5:20 PM by carlo martin RSS Branched to a new discussion.
  • roman.dor Level 1 Level 1 (5 points)

    Hey Fabio,

     

    Here are my settings after unlock

    MessageSettings1.PNG

     

    MessageSettings2.PNG

  • Fabio_Locha Level 1 Level 1 (0 points)

    Hi roman.dor,

     

    Thanks a lot!

  • roman.dor Level 1 Level 1 (5 points)

    BTW Fabio,

     

    you don't have the option "send as sms" because your iMessage is not activated, thus if it's not activated you don't have the option "Send as SMS when iMessage is unavailable", meaning if iMessage is not activated it will always be unavailable, so there is no point to have the option "Send as SMS", it's hidden and shows only when iMessage is activated.

    Here is the screen on my unlocked iPhone when iMessage is deactivated:

    MessageSettings3.PNG

     

    Regards.

  • shay1234 Level 1 Level 1 (0 points)

    having the same problem here in Israel. I've been trying to get a hold of apple support for the last three or four days with no success by far doing all the steps you guys suggested..

  • omer78 Level 1 Level 1 (0 points)

    Hi shay, im also in the same boat, using cellcom, no texting option available.

    i'll keep you updated if anything new comes to light.

    btw tell us about your iphone, where, how, when did you get it ?

     

    תחזיק מעמד אחי, נעבור את זה

  • npagazani Level 1 Level 1 (0 points)

    I have sent two emails now to support@apple.com and both times I got the standard Autoreply message saying:

     

    "Dear Apple Customer,

    Thank you for contacting Apple. This automated response provides links that address
    the most frequently asked questions about Apple's products and services. We hope this
    response helps resolve your question. Thank you for choosing Apple.

    The Apple Team"

     

    Does this stop here or will it eventually get looked at by a real person? The message implies it stops here!

    Can someone send me some real email addresses to send my complaint to?

    Thanks

  • roman.dor Level 1 Level 1 (5 points)

    Hey npagazani,

     

    Try to contact the big guys with emails from here and you should get a better treatment I think

     

    This is the way I got my iPhone unlocked.

     

    <Link Edited By Host>

  • hterrones Level 1 Level 1 (0 points)

    Hi guys!!!!, I have good news and bad news,

     

    Let's start with the good ones, I finally solved my problem, like some happy people who can finally send SMS, activate Facetime and iMessage, I put my Iphone to factory state with iTunes and the expected message finally appeared: Congratulations, your Iphone is unlocked.Then, imessage and facetime was activated without problems and SMS started to work. I was told that the solution is very simple, Apple has to unlock the SIM, which is associated with phone data, in their servers, because the Apple lock policy is not resident in the device but in the main servers. That confirms what I thought, is just a flag in their database.

     

    The bad news are that my problem was not solved by Apple Support people, as a matter of fact I am still waiting for an Apple Senior Advisor who promised to call me back and help me. My problem was solved with my brother´s help, who works in one of the mobile network operator in my country, he has technical contacts in Apple and with the Max Case ID <edited by host>, they figured out quickly the solution of the problem, thanks Max for your information, it  was very helpful.

     

    My suggestion is put pressure on them, send emails, make phone calls until you contact a person interested in your problem, then give them the Max case number to help them, because I think most of them don't know the root of the problem.

     

    Good luck to all of you, and thanks again for the information received through this forum!!!

  • Bratzi Level 1 Level 1 (0 points)

    Hey all,

    Still no answer after 5 emails, one of them to the "big guys" (thanks again to Roman).

    I wonder how many of us still have the problem...

     

    and to OMER : the details of the phone are not important.

    The common thing that we all share is a SPRINT IPHONE5 that is used outside US with a SIM of a local carrier.

    We just had a bad luck choosing Sprint.

    The seller asked which carrier we preffer. We really didn't know which is better, so we chose one of them...

    as I said : "BAD LUCK" !!!

     

    I hope we all "נעבור את זה בשלום"

  • Bratzi Level 1 Level 1 (0 points)

    I've just read hterrones news, and for us it's bad news (happy for you hterrones).

    Only connections can solve our problem????

  • Fabio_Locha Level 1 Level 1 (0 points)

    Hi hterrones,

     

    Sorry for asking, but where are you from?

     

    Thanks...

  • Fabio_Locha Level 1 Level 1 (0 points)

    Well, I was looking here and found that following people already fixed the problem:

     

    APPLE.HN

    PRASADR.87

    ROMAN.DOR

     

    Hey friends, do you think possible to share your Case ID's, like our friend Max Bianchi has done?

     

    Please, this will be very helpfully for other users try to fix same problem.

     

    Thanks in advance to Apple.HN, Prasadr.87 and Roman.Dor!!!

  • aaquiquem Calculating status...

    I USED THIS SOLUTION AT MEXICO WITH AND IPHONE 5 FROM SPRINT BUYED AT APPLE STORE AND IT WORKED, SO IT IS A SOFTWARE BUG FROM APPLE:

     

    1. Go to Settings / Messages

     

    2. Make sure "Show Subject Field" is on

     

    3. Try sending a message but type your message in the subject heading instead of the main box. The key is that the subject line has to have something in it, even a " " blank space will do

     

    I tried sending it this way to other iphones and smart phones and both the subject and body of the SMS would go through, but to older cell phones only the subject heading goes through, and only the first 39 characters.

     

    Hopefully Apple/Sprint will come up with an actual fix, but I'm hoping this is of help to some people out there...

  • aaquiquem Level 1 Level 1 (0 points)

    I USED THIS SOLUTION AT MEXICO WITH AND IPHONE 5 FROM SPRINT BUYED AT APPLE STORE AND IT WORKED, SO IT IS A SOFTWARE BUG FROM APPLE:

     

    1. Go to Settings / Messages

     

    2. Make sure "Show Subject Field" is on

     

    3. Try sending a message but type your message in the subject heading instead of the main box. The key is that the subject line has to have something in it, even a " " blank space will do

     

    I tried sending it this way to other iphones and smart phones and both the subject and body of the SMS would go through, but to older cell phones only the subject heading goes through, and only the first 39 characters.

     

    Hopefully Apple/Sprint will come up with an actual fix, but I'm hoping this is of help to some people out there...

  • HellocK Level 1 Level 1 (0 points)

    @aaquiquem

     

    Thanks for sharing your experiance yet sadly ...

     

    Thats not a fix that simply sends a MMS not a SMS .. so you'll be charged differently according to your priceplan and it doesnt fix the issue which is you cant send SMS messages

     

    to proof my point after swtiching on subject try to switch MMS off and u'll notice that subject will go off automatically and if it doesnt when u try to send it will advise you that u need to have MMS on

1 ... 19 20 21 22 23 ... 44 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (6)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.