Skip navigation

Pdp authentication failure

40949 Views 30 Replies Latest reply: Apr 10, 2014 11:51 PM by jgebhar RSS
1 2 3 Previous Next
Ashtown Level 1 Level 1 (0 points)
Currently Being Moderated
Sep 30, 2012 11:31 PM

Unable to access the Internet from my iPhone. Message being generated: PDP authentication failure

iPhone 4S
  • paulinpaloalto Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 29, 2012 7:46 PM (in response to Ashtown)

    I recently had this problem on my iPhone5.  At first I thought it was just the cell towers where I was, but it kept happening in a different part of town.  I was able to clear the condition simply by doing a hard reset (hold "home" and "power" together until you see the Apple Logo on the screen).

     

    So this sounds to me like a software bug in IOS.  Some state is getting corrupted in the cell driver.

  • ChrisJ4203 Level 7 Level 7 (26,375 points)
    Currently Being Moderated
    Oct 29, 2012 8:02 PM (in response to Ashtown)

    The only reference I can find in the Apple support documents regarding pdp authentication has to do with lower versions of iOS and custom APNs. I've provided a link to that http://support.apple.com/kb/TS2422. Are you trying to set your own APN rather than use the one from the carrier?

  • paulinpaloalto Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 29, 2012 9:39 PM (in response to ChrisJ4203)

    No, I was innocently using my iPhone5.  It worked one day and then ceased to work without my having changed anything.  I was able to make phone calls and do SMS, but not connect to the internet.  Doing the hard reset, as I described, cured the problem.

     

    This is pretty clearly a bug in the cell phone driver of IOS.

  • ChrisJ4203 Level 7 Level 7 (26,375 points)
    Currently Being Moderated
    Oct 30, 2012 12:32 PM (in response to paulinpaloalto)

    I wouldn 't say that it is a bug in the cell driver, it is more a possibility of an error in the carrier file. Which carrier are you with? The carriers here in the US use a carrier file to set a number of parameters and the APNs are one of them.

     

    Glad you got it straightened out. If it had been a bug or some type of error, you would have seen the behavior either continue or other people would be experiencing it. Glad you got it working.

  • paulinpaloalto Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 30, 2012 1:10 PM (in response to ChrisJ4203)

    Well, if you do a search on this forum, you will see that a number of other people are experiencing this problem.  My carrier is ATT.

     

    My phone was working fine and was able to access the internet.  Without changing any configuration parameters or doing anything other than running apps, the phone ceased to be able to access the Internet.  Every time I tried to access a website with Safari, I got the notifier saying "Unable to access the Internet.  PDP Authentication Failure".  I tried a normal powercycle reboot and that did not fix the problem.  I then did a "hard reset", which fixed the problem.  So it sounds to me like some software state in NAND flash or some other nonvolatile RAM was changed by the difference between a normal powercycle and a hard reset. 

     

    That doesn't prove that it's a software bug, but in my professional opinion as an OS developer (Unix, linux and various RTOS) I'd say it's highly suggestive.

  • ChrisJ4203 Level 7 Level 7 (26,375 points)
    Currently Being Moderated
    Oct 30, 2012 2:30 PM (in response to paulinpaloalto)

    Well, if you look at it that way, I have 4 phones here in the house, all AT&T, all on iOS 6. I have 4S times 2, and iPhone 4 times 2. If none of them have displayed this behavior is this a bug that only affects selective devices? My view of a bug is something that can be replicated on all devices that meet specific parameters, such as all AT&T phones, or all iPhone 4S devices on iOS 6. Of course, my definition of a bug may be flawed, so I could be wrong. It is possible that something corrupted your carrier file, which is separate from iOS and the reset corrected it. What Carrier file do you have on the device? I have AT&T 13.0.

  • paulinpaloalto Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 30, 2012 4:48 PM (in response to ChrisJ4203)

    Ok, Chris.  This will be my last post on this subject.  I'm guessing that you are not a software developer.  Just because most people don't see a bug, doesn't mean it's not a bug.  It just means that it's a bug that's hard to reproduce.  So your theory is that something corrupted my carrier file.  What exactly might do that?  Gremlins?  Cosmic rays?  An Act of God?  I think the most likely answer would be "a somewhat difficult to reproduce software bug".  In operating systems, the hardest kinds of bugs to reproduce (and therefore fix) are the ones that only happen when two very particular asynchronous events happen at just the wrong time relationship to one another.

     

    I'm done now.  Thanks for your help.

  • ChrisJ4203 Level 7 Level 7 (26,375 points)
    Currently Being Moderated
    Oct 31, 2012 5:29 AM (in response to paulinpaloalto)

    No I am not a developer. However, I told you what my view of a bug was. You have explained it and that satisfies me, however you did not need to be condesending. I tried to provide my understanding of the subject and what has been written on the error as well as what controls your APN, which is the carrier file on an AT&T phone. Sorry you're having a problem and a simpleton like myself cannot rise to your level of understanding.

  • paulinpaloalto Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 31, 2012 11:10 AM (in response to ChrisJ4203)

    Hi, Chris.

     

    You're right and I'm sorry.  I could have made my point without being offensive about it.  Believe it or not, I'm not (normally) a troll.  I just was having a rough day yesterday and took my frustration out on you.  That was wrong and I apologize.  It's obvious from your strength points that you spend a lot of time helping people on this forum.  I don't know whether you do it as a job or just as a Good Samaritan in your spare time, but I thank you for your help and apologize again for the offense I gave.

     

    Regards,

    Paul

  • ChrisJ4203 Level 7 Level 7 (26,375 points)
    Currently Being Moderated
    Oct 31, 2012 11:44 AM (in response to paulinpaloalto)

    No, this is not a job, it is a hobby. I'm retired, and spend my time teaching Business Technology at the local community college, mostly in PC applications such as Windows, and I specialize in Microsoft Office applications. I spend time here when I can and am always open to learning, especially when it comes to Mac products. Apology accepted, and maybe you can teach me a thing or two. I leave the teaching of our programming to people a lot more educated than I am, I just use the computer! Have a good day.

  • paulinpaloalto Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 31, 2012 1:56 PM (in response to ChrisJ4203)

    Hi, Chris.

     

    Great!  Sounds like a useful and productive way to be retired.  If you understand Microsoft Office, then I'm sure you can teach me a thing or two as well.  I'll come looking for you next time I get stuck in MS Word.

     

    Regards,

    Paul

  • ChrisJ4203 Level 7 Level 7 (26,375 points)
    Currently Being Moderated
    Oct 31, 2012 2:40 PM (in response to paulinpaloalto)

    Agreed! Have a good day.

  • puff_pear Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 24, 2012 9:28 PM (in response to Ashtown)

    I have this problem too!! I've try all method but it doesn't  work. I use iPhone 4s, my carrier is China Unicom and I use firmwere version 6.0.1 Please help me.

  • japakio Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 16, 2013 6:02 PM (in response to Ashtown)

    Hi guys, i have the same problem here in Brazil, but in my case i bought the iphone 5 and never worked the internet, from the first day appears:  PDP authentication failure,Can anyone help me? I've done  everything you all said and still not working.

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.