Skip navigation

Does 10.8 server have vacation messages

28064 Views 178 Replies Latest reply: Oct 29, 2013 8:07 PM by davidh RSS
  • redshift82r Level 2 Level 2 (325 points)
    Currently Being Moderated
    Oct 10, 2012 9:48 PM (in response to pilbaraecho)

    I assume you're in WA, shoot me an email with contact details (land line preferably) to this address which will be deleted today!

     

    qprvikings at icloud dot com

  • angryiphoneuser Calculating status...
    Currently Being Moderated
    Oct 12, 2012 2:42 AM (in response to pilbaraecho)

    Gerry,

     

    I enabled the logs to write to a file - there was an Apache permissioning problem.

     

    All I can find is an entry in the error log:

     

    [11-Oct-2012 08:34:53 +0100]: PHP Error: Unable to connect to managesieve on miniserver.<mydomain>.org:4190 in /opt/webapps/webmail/plugins/managesieve/managesieve.php on line 294 (GET /webmail/?_task=settings&_action=plugin.managesieve)=

     

    I will start sanitising the config files you requested.

     

    Many, many thanks for your help by the way.  I have tried to click 'solve problem' on the other issue but since the forums were down I cannot edit my posts or apply the "This solved my problem" tab.

     

    Nick

  • angryiphoneuser Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 12, 2012 2:51 AM (in response to pilbaraecho)

    Gerry,

     

    These files are massive to post - is there any extract you need or can I email them?  Alternatively I will remove all the commentary and post the sanitised settings?

  • angryiphoneuser Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 12, 2012 2:59 AM (in response to pilbaraecho)

    Gerry,

     

    I will start with the small files:

     

    90.sieve.conf

     

    plugin {
     
      sieve = /Library/Server/Mail/Data/rules/%u/dovecot.sieve

     

    #sieve_global_path = /var/lib/dovecot/sieve/default.sieve

     

     
      sieve_dir = /Library/Server/Mail/Data/rules/%u

     

        #sieve_global_dir =

     


      #sieve_before =

     

    #sieve_after =
      

     

      #sieve_extensions = +notify +imapflags

     

     
      #sieve_plugins =

     

    #recipient_delimiter = +

     

     
      #sieve_max_script_size = 1M

     

    #sieve_max_actions = 32

     

     
      #sieve_max_redirects = 4

     

    #sieve_quota_max_scripts = 0

     

    #sieve_quota_max_storage = 0

     

    20-managesieve.conf

     

    ##
    ## ManageSieve specific settings
    ##

     

    # Service definitions

     

    service managesieve-login {
      inet_listener sieve {
        port = 4190
      }

     


    }

     

    service managesieve {
    #process_count = 1024
    }

     

    # Service configuration

     

    protocol sieve {
    #managesieve_max_line_length = 65536

     

    #mail_max_userip_connections = 10

     

    #mail_plugins =

     

    #managesieve_logout_format = bytes=%i/%o

     


      #managesieve_implementation_string = Dovecot Pigeonhole

     

     
      #managesieve_sieve_capability =
      #managesieve_notify_capability =

     

    #managesieve_max_compile_errors = 5

     

      # Refer to 90-sieve.conf for script quota configuration and configuration of
      # Sieve execution limits.
    }

     

     

    Rest to follow....

  • redshift82r Level 2 Level 2 (325 points)
    Currently Being Moderated
    Oct 12, 2012 3:17 AM (in response to angryiphoneuser)

    Why not sanitise and post them to a public share in Dropbox and post the link?

  • redshift82r Level 2 Level 2 (325 points)
    Currently Being Moderated
    Oct 12, 2012 3:34 AM (in response to angryiphoneuser)

    Nick, signing off for the night - post a link and I'll have a look tomorrow.

     

    You should be able to telnet to 4190 and see a response from sieve.

     

    $ telnet server.ip 4190

     

    Talk tomorrow!

  • angryiphoneuser Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 12, 2012 9:43 AM (in response to pilbaraecho)

    Gerry,

     

    See:

     

    https://dl.dropbox.com/u/38984346/main.inc.txt

     

    https://dl.dropbox.com/u/38984346/managesieve.txt

     

    https://dl.dropbox.com/u/38984346/config.inc.php.txt

     

    I cannot seem to telnet on 4190 - I think there may be a permissioning problem but i don't know where to start.

     

    Nick

  • redshift82r Level 2 Level 2 (325 points)
    Currently Being Moderated
    Oct 12, 2012 5:40 PM (in response to angryiphoneuser)

    Nick, the problem doesn't appear to be Roundcube. You need to check the files in L/S/Mail/config/Dovecot/conf.d and make sure that

     

    A. Sieve is listening on tcp 4190

    B. that sieve is listed as a plugin mentioned in the sieve config file - see the Part II at the beginning of this thread.

     

    For a better understanding , you can check the Dovecot 2 wiki which goues through troubleshooting and additional tools like Doveconf.

     

    Let us know what you find.

    Cheers

    Gerry

  • Matt Domenici Level 1 Level 1 (110 points)
    Currently Being Moderated
    Oct 28, 2012 5:36 PM (in response to angryiphoneuser)

    If you can get the plug-in to appear in Roundcube, then your problem will most likely appear in mailaccess.log on your server.  Look for references to managesieve-login.

     

    Most folks these days configure the Mountain Lion Server to only connect over a TLS connection and using CRAM-MD5.  I'd suggest you update the config.inc.php.dist file as follows:

     

    - Change the managesieve_auth_type to CRAM-MD5

    - Change the managesieve_usetls to true

     

    Save, logout if webmail, and log back in again, and you should be able to see your filters.  You should see the managesieve-login appear as a successful auth when you click on filters if all is working.

  • kunikatsu Calculating status...
    Currently Being Moderated
    Oct 30, 2012 10:54 PM (in response to redshift82r)

    Hi Redshift,

     

    after I enter:-

    sudo createdb -O roundcube -E UNICODE roundcubemail

     

    I got this reply from the system:-

    createdb: could not connect to database postgres: FATAL:  role "root" does not exist

     

    Any idea what the problem is?

     

    Justin

  • redshift82r Level 2 Level 2 (325 points)
    Currently Being Moderated
    Oct 30, 2012 11:07 PM (in response to kunikatsu)

    sudo implies "root" user, so .... try connecting as user _postgres

     

     

    sudo createdb -u _postgres -O roundcube -E UNICODE roundcubemail

     

    HTH

  • kunikatsu Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 31, 2012 3:00 AM (in response to redshift82r)

    Hi redshift,

     

    Thanks. I am really new to all this. Need more help from u.

     

    I am trying setup roundcube like my wiki which is having the url www.mydomain.com/wiki

     

    I like to setup roundcube as www.mydomain.com/webmail. what should I do? where should roundcube folder be on my server hd and how to tell my web server that this folder is www.mydomain.com/webmail?

     

    Thanks in advance.

     

    Justin

  • redshift82r Level 2 Level 2 (325 points)
    Currently Being Moderated
    Oct 31, 2012 5:53 PM (in response to kunikatsu)

    Hi Justin - see http://gerrydeakin.clarify-it.com/d/3dcye7 for explanation of how to set up Roundcube as a Webapp

     

    I think that answers your question

    cheers

    Gerry

  • kunikatsu Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 4, 2012 6:47 AM (in response to redshift82r)

    Hi Gerry,

     

    I was successful following the steps up to step 7 but can't see roundcube in server app.

     

    Justin

  • redshift82r Level 2 Level 2 (325 points)
    Currently Being Moderated
    Nov 4, 2012 4:40 PM (in response to kunikatsu)

    1.Try turning web services off then on

     

    2. Check Webconfig.log for malformed plIst - check the webmail.plist XML versus the com.example.webapp XML

1 ... 5 6 7 8 9 ... 12 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (9)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.