Skip navigation

HT1338: OS X: Updating OS X and Mac App Store apps

Learn about OS X: Updating OS X and Mac App Store apps

HT1338 Software update not working with snow leopard 10.6.8

8045 Views 6 Replies Latest reply: Mar 25, 2014 10:06 PM by SGcls RSS
meloamaury Level 1 Level 1 (0 points)
Currently Being Moderated
May 11, 2012 4:43 PM

When I try to update snow leopard 10.8.6 through the Software update, it launches but crashes with the message Software Update can't check for updates because of a network problem. Software Update can’t connect to the update server. But I do have internet connection. If I try to update from the terminal with the command " sudo softwareupdate -i -r, it tries to connect but end up with connection timed out. I have never able to update my system with software update utility. Does anybody have any suggestion?

MacBook Pro (13-inch Early 2011), Mac OS X (10.6.8)
  • Kappy Level 10 Level 10 (220,980 points)

    Consider trying to download the Mac OS X 10.6.8 Update Combo v1.1 instead of using Software Update. You can also give this a try to fix SU:

     

    Fix for Software Update

     

    See Troubleshooting Automatic Software Update in Mac OS X.

     

    Delete the following files:

     

    • /Library/Preferences/com.apple.SoftwareUpdate.plist
    • /Home/Library/Preferences/com.apple.SoftwareUpdate.plist
    • /Home/Library/Preferences/ByHost/com.apple.SoftwareUpdate.xxx.plist where "xxx" is a number.
    • /Home/Library/Caches/com.apple.SoftwareUpdate/ (delete entire folder)

     

    Software Update Fix 1.1 - MacUpdate

  • SeanTheTechGuy Level 1 Level 1 (0 points)

    I was successfully able to delete the files, and now my updates are working again...

  • Michael Paine Level 2 Level 2 (315 points)

    Kappy's tips worked for me. But only after I restarted the computer when I had deleted the files.

  • RodWall5 Level 1 Level 1 (5 points)

    Kappy's tip worked for me aswell. Didn't need to restart after deleting files. Thanks!

  • SGcls Level 1 Level 1 (0 points)

    Hi,

     

    This reply may seem late but might as well share my findings.

     

    I have the same problems with the software updater for 10.6.8 as well after trying to move on to Mavericks from

    OS X Leopard 10.6.8.

     

    Tried the patch as well the listed files to delete and etc but all failed.

     

    Then I noticed the problem was with the software updater complaining that there was a network problem and even though the dignostics was run the results were no network connection exists but Air Port is connected and there is no issue browsing the web.

     

    I took a look at the Wi-Fi settings and noticed that the default locations were going back to an old Wi-Fi network location I had latched on to 4 years ago! I assumed some screw up with the Wi-Fi network software and thus removed all Wi-Fi network associations and locations and reconfigured the Wi-Fi from scratch for my local home Wi-Fi network. After this the software update worked fine and can now download updates. Note that I did install the update patch by Apple though in my first attempt to resolve the problem.

     

    I would consider the possibility of the Wi-Fi software services within OS X Snow Leopard being a bit "buggy".

    Deleting all the non used Wi-Fi network associations and clearing or resetting the default location settings helped revive/resolve the no network connection problem with the software updater.     

     

    Now can move on to Mavericks...

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.