9 Replies Latest reply: Dec 26, 2012 10:30 PM by BrianJZ
Jonas Gabrielson Level 1 Level 1 (0 points)

Hello! I have run into a major problem with my iMac and I have no idea what is going on. Help would be greatly appreciated!

 

The inital problem: I was using my iMac last night, mainly surfing with Safari but with several other applications open in the background (Photoshop, at least ten Safari tabs, Mail, Evernote, iTunes, Spotify, possibly a few others). Suddenly, while reading on a forum, I could no longer scroll the page with my Magic Mouse. In fact, nothing responded at all, no clicks, no keyboard presses (wired, Apple Extended keyboard), no nothing. A minute later, the pointer froze too. I shut down with the power button and restarted.

 

The first time, the Mac booted into my BootCamp partition. Possibly, I had made that change myself earlier and forgotten about it. Windows 7 started without a fuss, and I then rebooted into OS X.

 

However, OS X would not load. For over half an hour, only the grey apple and the spinning wheel. Finally, I gave up and tried to boot into the Recovery drive. After a long, long period of waiting, I finally got to the "Welcome" screen where you choose your language. However, neither keyboard nor mouse responded to input. I restarted again, this time trying Safe boot. I got past the grey progress bar, but then it halted again. Tried again, booting into the original System disk (10.5.6), which worked after a long, long time. When at the Welcome screen, the mouse did not work, but I could choose with the keyboard. After choosing, the mouse came alive. I ran Disk Utility, which reported no errors. Set Startup disk to my main partition and restarted. This time (after a long, long time of waiting), I actually came to the login screen on my boot volume. Mouse and keyboard did not respond initially, but came alive after 5-10 minutes. I could then log in. I actually managed to work for a few minutes, saving two recovered PS documents and starting Activity Monitor, before everything beachballed and I had to power down again.

 

I have now tried this several times. I can only get in to my OS X partition by booting to my DVD, and then choosing the 10.8.2 partition as the Startup drive. I see the same unresponsive mouse/keyboard every time at login or welcome screens. When I get into my 10.8.2 system, I can see in Activity monitor that kernel_task uses 100-110% of processor time, and often another process takes all the rest (mds, CrashReport). Once, I actually managed to quit all my running applications and do a restart from the menu, but it then hanged up on me on the grey "shut-down" screen.

 

Meanwhile, my Win 7 partition still works like a charm.

 

Any ideas about what I should do? Should I just give up and restore from Time Machine already? What could be causing the problems with the mouse and keyboard? Why is kernel_task using so much processor time?


iMac (24-inch Early 2009), OS X Mountain Lion (10.8.2), 8GB RAM, ATI Radeon HD 4850