Skip navigation

Macbook pro early 2011 battery not found after HDD replacement

619 Views 8 Replies Latest reply: Dec 14, 2012 11:43 PM by clintonfrombirmingham RSS
pointblaster Calculating status...
Currently Being Moderated
Nov 1, 2012 6:14 AM

I recently replaced my HDD to an SSD and when i started the computer again the battery symbol showed an "X".
I tried reseting the smc and removing/inserting the battery several times.

Today i tried inserting my friends macbook pro battery in mine, and no luck there....
So it is problaly a logic board problem, or maybe something wrong with the OS...
Does somebody have any solution to this? or maybe have the same problem?
Any advice would be helpful!



MacBook Pro (13-inch Early 2011), OS X Mountain Lion (10.8.2), Samsung SSD


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.