Skip navigation

Printer job "On hold (authentication required)"

100854 Views 72 Replies Latest reply: Apr 6, 2014 2:53 PM by Ber121b RSS
  • silverbirch07 Calculating status...



    This is the first time I've been able to print to a Windows 7 printer from my MacBook


    Very grateful for your tip, thanks again



  • marconelli Calculating status...

    After trying so many other suggestions to no avail, this one worked for me. Just to be clear: use "guest" as the login name and "guest" as the password. Thank you so much for posting this solution. (It still amazes me that nothing else seems to work, even the actual and correct login names and passwords for my Windows workgroup!)



  • lyfan Calculating status...

    Thank you so much!!! I spent so long on it! Your advice totally worked, I can't believe it was that simple!!! THANK YOU!

  • D.O Calculating status...
    Currently Being Moderated
    Dec 12, 2012 11:32 PM (in response to caw35slr)

    IT WORKSS !!!!!!!!!! thank you so much to whoever give this solution..


    username : guest

    password : guest


    so simple but it 100% effective.

  • Stasia W. Calculating status...
    Currently Being Moderated
    Jan 4, 2013 9:26 AM (in response to Hen3ry)

    Henry, this solved it for me - THANK YOU.

  • antst Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 26, 2013 6:17 AM (in response to tageek)

    In my case it doesn't show popup authorization dialog, even if I resume job. (refresh icon).

    It does with different account, but with my normal one - not anymore (it used to work as it should).

    It just freezes print queue window.


    all I have in logs is:


    2/26/13 3:14:01.321 PM PrinterProxy[596]: *** WARNING: -[NSImage compositeToPoint:operation:] is deprecated in MacOSX 10.8 and later. Please use -[NSImage drawAtPoint:fromRect:operation:fraction:] instead.

    2/26/13 3:14:01.321 PM PrinterProxy[596]: *** WARNING: -[NSImage compositeToPoint:fromRect:operation:] is deprecated in MacOSX 10.8 and later. Please use -[NSImage drawAtPoint:fromRect:operation:fraction:] instead.

    2/26/13 3:14:03.703 PM NetAuthSysAgent[588]: Property list invalid for format: 200 (property lists cannot contain objects of type 'SecCertificate')


    So, I guess problem is with NetAuthSysAgent or NetAuthAgent. But I spent already 10 hours trying to get a bit more information with no luck

  • EsTaF Level 1 Level 1 (0 points)

    Didn't help all it.

  • KREVwon Calculating status...
    Currently Being Moderated
    Mar 26, 2013 10:47 AM (in response to tageek)

    This was the ticket. Super simple. THANKS!!!

  • VirtualJ Calculating status...
    Currently Being Moderated
    Mar 28, 2013 4:07 AM (in response to caw35slr)

    Big thank you!  Resolved my printing issue.


    So chuffed!


  • PNDH Level 1 Level 1 (5 points)

    May God bless you Thank you so very much, it solved my problem for me!

  • Adumisu Calculating status...

    thank you so much! bravo!bravo!

  • ryden74 Calculating status...
    Currently Being Moderated
    Jul 4, 2013 11:00 PM (in response to caw35slr)

    My situation is pretty standard: a Mac user in a Windows-based network. The solution uses CUPS.


    I originally set my Mac up in Snow Leopard in 2012, and got it working with the windows network printer. But then it stopped working after a few weeks, continually getting the "On hold (authentication required)" message.Despite authenticating and re-authenticating, and deleting the network passwords many times, I couldn't get it to work.


    This message is INCREDIBLY frustrating, since I could see that my computer was communicating successfully with the printer; getting the levels of toner in the printer, for example.


    The original thing that I had done was to set up the printer with the following connection string, using Mac OSX's Settings application:


    smb:\\<printer's IP address>\<printer's Windows network name>


    (I had tripped up for a long time here on the fact that the Windows printer network name had spaces in it. Scotched that one by replacing the "space" character with the "%20".)


    However, as mentioned already, this only worked for a while. Then there ensued much head-bashing against-wall (given that the network IT people are soooo anti-Mac that it is simply a waste of time talking to them, which, again, I think is pretty common in the world.... all those "IT professionals" are in the job-protection scheme, and don't want people to move to Mac).


    The solution was to use OSX's CUPS printing management, via http://localhost:631 on the Mac. This brings up the "Common Unified Printing Solution", which is OSX's printer management. Then I added the printer from the "admin" part of the CUPS web-based interface, using the connection string


    socket:\\<printer's IP address>


    (discovered from http://localhost:631/help/network.html)


    and told CUPS the printer's name (going with the %20 thing for all spaces in the name again) and my network username and password, and then told it the printer type... and it proceeded to print.




    So I can yet again keep working in an anti-Mac environment, without anyone forcing a crappy Windows 7 or 8 PC onto me.

  • camap97 Calculating status...

    Thank you very much. It's a miracle.


    I did it.

  • bumpwhite Calculating status...

    Tried your approach and deleted related keychain access items. Did not resolve issue. Old user id still shows up. This has always been the biggest piece of crap mac has. It really ****** me off Apple has no interest in fixing the problem. These arrogent ******** need to understand MS will be around for the forseeable future.

  • Kevin Neal Level 2 Level 2 (475 points)
    Currently Being Moderated
    Oct 4, 2013 1:14 AM (in response to bumpwhite)



    dseditgroup -o edit -a everyone -t group _lpadmin


    it works for me


More Like This

  • Retrieving data ...

Bookmarked By (2)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.