Skip navigation

iCal not connecting to Google Calendar - HTTP 404 error

68380 Views 120 Replies Latest reply: Apr 16, 2014 12:32 PM by CussinSailor RSS
1 2 3 ... 9 Previous Next
richwilliamson Calculating status...
Currently Being Moderated
Sep 7, 2012 9:48 AM

Hi there


I've just bought my first Mac, and I'm running Mountain Lion, just updated to 10.8.1. When I set the system up, I fed in the details of my Google account, and it merrily put my Gmail into the Mail app, and Notes also syncs. But, the Calendar app is giving me continual problems, with this same error message:


"Your calendar couldn't be refreshed.


The URL encountered HTTP error 404. Make sure the URL is correct."


I've tried deleting and re-adding the Google calendar; the whole Google account; the iCloud account (because various fourms seem to think this is an issue) and none of it has helped. Any suggestions?



MacBook Air, OS X Mountain Lion (10.8.1)
  • sinoue Level 2 Level 2 (175 points)

    Just ran into this trying to import an Edline school calendar exported .ics file into my Apple iCal set to sync with my Google Calendar.


    If you open your web broswer and goto do you get any error messages?


    You may need to stop using Apple's iCal - Calendar 6.0 until we figure out where the preference setting for checking the calendar is at.


    Are you using more than one calendar to sync with?


    I might try the calendar app Fantistical in the Mac App Store to see if this works better than Apple's built in calendar.

  • mhoerler Calculating status...

    I have a similar problem. I noticed that iCal didn't show any updates to my Google calendar since 10/28/2012. I tried refreshing the calendar, but that didn't help. Then I removed the calendar from iCal and added it back as a subscription under "On My Mac": still no events. Then I refreshed the newly added calendar and noticed that the Title of the iCal window showed "Calendar - Updating..." and it seems to be hanging on that update operation. There is no error message, though.

  • mhoerler Level 1 Level 1 (0 points)

    A reboot seems to have fixed it for me.

  • ECSinPA Calculating status...

    I've been running Mountain Lion since it first came out (on a new MBP Retina), and I've just started having these problems in the past couple of weeks.  It's with a Google calendar that my spouse keeps that I subscribe to:



    username@gmail is spouse's gmail account.  I've tried refreshes, reboots, remove-and-reinstall etc. ad nauseum, but nothing helps.  Any suggestions, please?

  • Munas Level 4 Level 4 (1,255 points)

    I have exactly the same problem. Reopening my Calendar app sometimes helps and sometimes - not...

  • Kjell-o Calculating status...

    I'm having the same issues here. Big time nusiance. Is this a bug with Apple or Google? My gut tells me it's Apple and their animosity towards google.


    Please anyone have a solution? I have 25 users plagued with this problem. Restart failed, removed account and readded the account, failed. Not sure what else to do.

  • jerrodt Calculating status...

    I don't think it's Apple as I started having this problem recently as well and there have been no OS or Calendar application patches that I have installed. My guess is that Google changed something on there end.


    This is a pretty annoying problem as it refreshes and starts working for a while, then throws the error, the comes back.


    Each time it comes back, all of my delegated calendars (which is many), re-enable and I get flooded with OMG YOUR MISSING 12 MEETINGS!


    I'm about to stop using Calendar but I like it's notifications better than the Google ones.

  • Munas Level 4 Level 4 (1,255 points)

    In my case it affects some delegated calendars. It gets annoying... I would blame Google too.

  • ECSinPA Level 1 Level 1 (0 points)

    I've posted this in a Google forum, so let's see if I get any replies there.  If I get anything helpful, I'll re-post it here.



  • Ziru Calculating status...

    I began to experience this issue since yesterday.  Fortunately, I found a workaround which at least work for me.  Go to Preferences -> Account tab, uncheck the "Enable this account" option and then re-check it.  Now, the iCal alert dialog no longer pops up.  No clue of what caused this though.

  • Kjell-o Level 1 Level 1 (0 points)

    From an email from Google Enterprise support. This is encouraging. The fix I found (clear Calendar caches) was temporary. It lasted about an hour before I started getting the oddities again. Problem is definitely with Google Apps. Who really knows though . . . could be something in Apple's programming too.



    Screen Shot 2012-11-27 at 1.06.46 PM.png

    "Thank you for your patience while we work with your issue.


    "At this time I’m in close consultation with a higher level support department. We are currently working on this issue. I’ll be updating you as soon as I hear back from them. I wish you have a great day."

  • ECSinPA Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 27, 2012 1:44 PM (in response to Ziru)



    Go to Preferences -> Account tab, uncheck the "Enable this account" option and then re-check it.



    Fingers crossed, that worked for me and for dear spouse!  At least it has for the last hour - will post back later with updates.

  • TBgulli Calculating status...

    I got the same problem and it is freakingly annoying!!! I get the message every 20 to 30 minutes and every second time iCal is listing the events of (luckily) only one calendar twice only to remove the duplicated once later on.


    I'm on OSX 10.8.2 and run iCal 6.0 and am syncing multiple calendars with google. Deleting and readding didn't solve the problem for me either. I woulnd't want to change to another calendar app but if this can't be solved...

  • supraru Calculating status...

    Wow, I am so glad I am not crazy and found this thread.  I have sufered this problem sice July and have not been able to rectify it in anyway. Yes, I have done everything mentioend here, the best it ever got was 3 full days without the errors after I deleted the account for 24 hours and re-added it.  But as others have reported, probelm reappears between 1 hour and 1 day later after most "fixes." 

1 2 3 ... 9 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (10)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.