Skip navigation

referenced files show up as managed

1217 Views 13 Replies Latest reply: Jan 3, 2013 12:34 PM by Jan Wessel RSS
Jan Wessel Calculating status...
Currently Being Moderated
Oct 8, 2012 6:18 AM

Using Aperture 3.4.1


I have about 10.000 images (each is a 125MB TIFF file) in Aperture.

As the AP library became very large (about 1,3 TB), I decided to go from Managed to Referenced.

So I used the "Relocate Original for Project" from the File Menu.

This worked fine, but..., unforunately Aperture crashed a couple of times.

So now I have  about 200 images of which Aperture thinks they are Managed, although they have been moved to where I told Aperture to Relocate them as Referenced.


What I suspect that happened is:

- Aperture relocated the Original file to outside Aperture, then crashed before it had time to store the new File Status and the link to the Referenced file in thedatabase.


I have tried to Repair and Rebuild the database but to no avail.


If I try to Relocate Original -> Unavailable original files cannot be relocated.

I I try to Locate Referenced Files -> No Referenced Files

I cannot use Show in Finder, as Aperture thinks the image is Managed.


Anyone an idea how to solve this?


Would be greatly appriciated.



iMac, Mac OS X (10.7.5)
  • léonie Level 8 Level 8 (46,465 points)
    Currently Being Moderated
    Oct 13, 2012 3:59 AM (in response to Jan Wessel)


    I really think, before you invest more time into fixing the library, you need to find the reason for the crashes and get to run reliably.


    What is the error message that you get when Aperture is crashing? Is it always the same message? Do you have a crashlog? Then you could post the first 60 lines, so we can get an idea what might be going on.


    What kind of images do you have in your library? Raw, jpeg? And where is your library? On an external volume? Directly connected or network volume?




  • léonie Level 8 Level 8 (46,465 points)
    Currently Being Moderated
    Oct 13, 2012 1:51 PM (in response to Jan Wessel)


    as far as I can see you have a crash because of an incompatible or missing virtual machine plug-in. Are you using a virtual machine - Parallels, VMware? Then you might check, if an upgrade is available. This looks like a conflict with the new sandboxing in MacOS X 10.7.5 and Mountain Lion. Your current version might be incompatible.


    I have not used a virtual machine for a long time, so I cannot help with that problem. Hopefully other frequent posters drop in, or you could search the Lion forum for similar posts.


    Once your system is stable again, post back to tackle your library.




  • stuartfromtwickenham Calculating status...
    Currently Being Moderated
    Nov 1, 2012 5:08 PM (in response to Jan Wessel)

    I have the same problem. Unfortunately I did not keep the crash information. I will next time. Is it stored anywhere?


    As the files in error exist in the relocated location, and are not in the managed files location, do you think it would be safe to just copy them back?

  • stuartfromtwickenham Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 2, 2012 2:12 AM (in response to Jan Wessel)

    Jan, Thanks for the help.


    I'll try turning TM off when I relocate the rest of the files. Thanks for the tip.

  • prepare4landing Calculating status...
    Currently Being Moderated
    Dec 5, 2012 10:13 PM (in response to Jan Wessel)

    Jan Jan Jan!!!!


    Thank you so much for posting this.  I was having the EXACT same issues while attempting to relocate my files to a hard disk.  Apeture would crash and the last 4-5 photo's it was working on relocating would come up as the file was "offline" but was unable to reconnect.  Exact same issues you were having and I searched and searched and couldn't find a solution.  Then I finally came across this thread and I turned off "Time Machine" and now everything works as it should with no crashes from Aperture.  For some reason there is a bug in Aperture that causes it to crash when time machine does it's automatic back ups and causes the files that it was working on relocating at the time to be corrupted.  I'm also running 10.7.5 and Aperture 3.4.3.  Is there a good way to report this to apple so they can work on a solution??  Thanks again for your post!




More Like This

  • Retrieving data ...

Bookmarked By (1)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.