Skip navigation

Mail bug in Mountain Lion

95801 Views 432 Replies Latest reply: Feb 7, 2014 10:16 AM by Big Rock RSS Branched to a new discussion.
  • Kawanaut Calculating status...
    Currently Being Moderated
    Nov 1, 2012 5:06 AM (in response to markmal)

    If 10.8.3 doesn't fix it, then I don't think we are ever going to see a fix

    http://appleinsider.com/articles/12/10/31/apple-preparing-first-beta-of-os-x-108 3

     

    Let's hope for the best!!

  • DWFaust Level 1 Level 1 (25 points)
    Currently Being Moderated
    Nov 2, 2012 9:03 AM (in response to markmal)

    I did email Craig Federighi about this issue and got a response that in part said:

     

    "It's not too much to ask.  We understand the issue and intend to address it."

     

    Hopefully that’s good news

  • iacas Calculating status...
    Currently Being Moderated
    Nov 2, 2012 12:11 PM (in response to DWFaust)

    As good as that news may be, I don't particularly like that you didn't feel the need to honor his request. Sharing that will make it less likely that he'll respond or be honest with others in the future.

  • ross70s Calculating status...
    Currently Being Moderated
    Nov 2, 2012 2:28 PM (in response to DWFaust)

    Excellent news indeed.

  • Brassive Calculating status...
    Currently Being Moderated
    Nov 8, 2012 12:54 PM (in response to markmal)

    FWIW, The "work-around" (feature, really) of dragging the account in the left column that you want to be default to the top of the list worked for me. Granted, this doesn't help with aliased addresses (the University that employs me  aliased our old email addresses when we moved to MS Exchange) but it solved 90% of the problem for me.

     

    I would like to see a feature added that would allow me to set the reply address for any email by its "to" field. I have three well-used aliases that I would love to assign specific accounts with which to reply. But that is a feature request, not a bug fix.

     

    My opinion is that this isn't a bug, just a not-very-well-thought-out decision by Apple engineers. Bugs are behaviors that are unintentional. Unfortunately Apple is as arrogant as any behemoth so they'll never address a problem they won't admit is a problem. Hopefully this will be set back on track (quietly, no doubt) in a future update.

  • macvancouver Calculating status...
    Currently Being Moderated
    Nov 8, 2012 3:06 PM (in response to Jerome Krinock)

    Whew, I thought I was doing something wrong. It's a serious problem for me.

     

    I have four accounts

     

    One iCloud account

    One Gmail personal account

    One Gmail Triathlon Club Account

    One Gmail work account. (forward from work domain)

     

    I am finding that often when I reply to an email intending it to be from my personal account or my work account, when they reply, it comes to my Triathlon Club or Work account, and clearly, the reply to was from the Triathlon Club Account. I am not the only one reading the Triathlon Club account, so either work or personal email is being seen there, Not good at all!!!

  • Paul Mycroft Calculating status...
    Currently Being Moderated
    Nov 18, 2012 11:22 AM (in response to markmal)

    I have 8 POP addresses in my Mail.

     

    This issue ONLY happens to me when a rule moves an email message out of the main inbox into a sub-inbox.

     

    Would this not be considered a bug?

     

    In any case, I have submitted it as feedback so hopefully, someone is listening.

  • ajlajluk Calculating status...
    Currently Being Moderated
    Nov 19, 2012 3:05 PM (in response to markmal)

    I have several email addresses but only use 2 gmail addresses regularly so these are the ones that I have noticed this problem with.

     

    When I reply to an email which was sent to my primary gmail email address it shows it as being sent (and puts the reply address) as the secondary gmail address.

     

    Both gmail accounts are set up for POP/SMTP rather than IMAP for reasons I will not bother with here as it is not relevant.

     

    I seem to have cured this problem by changing the settings in the account settings: Go to

    Preferences > Accounts

    then for each gmail account set up a new Outgoing Mail SMTP server from the pop down list: Edit Servers.

    Set up SSL for each account with Password authentication using the Username and Password for each account.

     

    This seems to have solved the problem and I now seem to be getting the correct reply address for each separate account.

     

    Hope that helps others with this problem.

  • phineas8 Calculating status...
    Currently Being Moderated
    Nov 19, 2012 4:45 PM (in response to ajlajluk)

    It's true that if you move messages to a gmail or other webmail account, this problem occurs. I think, though, that the many messages emphasizing that usage may have confused the issue for some posters to this thread. It's only one of several use cases where this problem manifests.

     

    I agree with Paul Mycroft two posts up. Messages that are moved out of their original inbox -- either manually or by email rules, for whatever reason -- lose their account identity when you reply to them. Instead of replying from the account to which they were sent, they identify themselves as being from the topmost account entry under the "Mailboxes" header on the gray "Mailbox list" (there may be some variations in different use cases). Messages that are not moved reply just fine. It would seem that Apple has removed the element that identifies the receiving account out of the message and given that job to the default account, which isn't established by the Preferences setting (Preferences ... Composing) that's supposed to handle that job, but is instead controlled by the order of the account inboxes in the folder tree.

     

    Even an iOS 6 Mail message remembers its received account when you move it and reply from the new location.

     

    It's a bug, not a feature. Really, two bugs.

     

    FWIW, my use case: My company archives all Exchange-based email after 30 days. By setting up an email rule to move all my Exchange mail to a folder "On My Mac," I'm able to search and review email months later. As a result, I have the problem. I've also encountered a related problem I haven't seen noted elsewhere: In some instances Apple Mail CCs my default account on some of my outgoing messages (and no, I don't have Automatically CC myself Preference setting checked).

     

    The problem has been so productivity-robbing for me that I was compelled to switch to Outlook. But I'll switch back to Apple Mail when (if?) Apple fixes this.

  • Ernie Stamper Level 8 Level 8 (37,455 points)
    Currently Being Moderated
    Nov 19, 2012 4:46 PM (in response to ajlajluk)

    What you cite for Gmail From address behavior is standard for Gmail, and nothing to do with Mail.  When the Gmail SMTP is authenticated with the email address of each account, it is in fact a separate SMTP in each case.  This SMTP will change the From address to be that used to Authenticate the server.

     

    This is a different thing from the behavior that is the subject of this topic.

     

    Ernie

  • Ce1tarion Calculating status...
    Currently Being Moderated
    Nov 23, 2012 1:39 PM (in response to markmal)

    Hello Everyone,

     

    Indeed, when sending an email from a@hotmail.com and selecting the correct email address, then Mail sends an email from b@hotmail.com... and is always using b@hotmail.com for some reason. As I wanted to delete this email address because I don't use it at all, now my contacts have this email address that I didn't want to use anymore, sounds great...

     

    I used this email address only for spams, etc... after placing an order, so then my email address for friends and family is always clean with no ad to manage.

     

    I think that I have resolved this matter very simply and yes it works - Hope this was not discussed previously, otherwise I do apologize in advance.

     

    Let's try this and please let me know if it has worked for you guys as I know how it is a pain.

     

    I have deleted the email address account in question in Mail before starting below process.

     

    1. Open Mail
    2. Select Mail and then Preferences
    3. Unselect "Enable this account" and do it for ALL your accounts
    4. Quit Mail
    5. Open Mail again
    6. Select Mail and then Preferences
    7. Select "Enable this account" and do it for ALL your accounts
    8. Quit Mail
    9. Open Mail again
    10. It works :-)

     

    After sending 5 emails, it appears that it seems working well... Hope this helps!

     

    Joss.

  • nautilus2104 Calculating status...
    Currently Being Moderated
    Nov 23, 2012 1:49 PM (in response to Ce1tarion)

    No this won't work for the original problem described here. Once an email has been moved from in the inbox to another folder in Mail, either manually or by an automatic filter, Mail will not allow the user to reply to the sender using the email of the orginial message sent to the sender. I've given up and use Postbox. http://www.postbox-inc.com/ I like Sparrow too, buy I can't turn off threaded emails which I hate.

  • Kawanaut Level 1 Level 1 (50 points)
    Currently Being Moderated
    Nov 23, 2012 3:37 PM (in response to nautilus2104)

    Gotta say, that Postbox-Inc app looks really neat, and the pricing ($10) is really attractive as well.

     

    If Apple doesn't fix their Mail bug in 10.8.3 then I'll have to seriously consider Postbox instead. Heck, they might even be able to innovate their mail app more than Apple does with their Mail app, and as long as they stay out of Mac App Store they are not bound by the weird Apple guidelines.

  • wagaya Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 23, 2012 6:09 PM (in response to Ce1tarion)

    Re fixing the problem by disabling then re-enabling Mail accounts:

     

    I wish I could say that that helps. but it did nothing for me. After following the procedures, when I reply to a message that has been moved to a non-Inbox folder, I still have the sender set to my default email address, not the email address that received the message.

     

    The bug remains big, annoying, bizarre, and in full force, with not a word from Apple on the matter.

  • phineas8 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 23, 2012 10:21 PM (in response to Kawanaut)

    Too bad PostBox doesn't support Exchange as an Exchange client. I've been aware of this product but it has *really* come a long way. Does look cool; just doesn't help me.

1 ... 14 15 16 17 18 ... 29 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (22)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.