Skip navigation

HT1338: OS X: Updating OS X and Mac App Store apps

Learn about OS X: Updating OS X and Mac App Store apps

HT1338 upgraded to mountain lion and wifi keeps dropping

54750 Views 235 Replies Latest reply: Jul 25, 2013 1:42 AM by stevefromorpington RSS
  • Cameron546 Calculating status...

    1.Go to mac hd/library --> locate Prefences folder then locate the SystemConfiguration folder and place this on desktop.

    2.Shut down mac and do a SMC RESET  ( http://support.apple.com/kb/HT3964?viewlocale=en_US )

     

    3. start mac up , go to your desktop and click on the apple on the top of your screen go to system prefences and go to network

     

    4.underneath the white field on the left you select wifi and underneath you see a + a - and a little flower thingie, click on the flower thingie and select set order device.  Drag wi-fi to the top and press ok .

     

    5. Click on advanced now and delete all preferred networks then go to the next tab which is called TCP/IP, click this and renew dhcp-lease then click apply and ok.

     

    6.Go to the spotlight and type in keychain passwords , open it and select password on the left side of your screen , delete all airportnetwork passwords.

     

    7. go back to system prefences network and go to assist me , then diagnostics , setup network enter password and save password in keychain

     

    8.test it put it to sleep , restart --> see if works , otherwise call AppleCare.

     

     

    Cameron.

  • Matt NewBones Calculating status...

    I get this too, totally annoying

     

    https://discussions.apple.com/thread/4231009

  • Matt NewBones Level 1 Level 1 (20 points)

    I actually just made some progress...

     

    I had previously added a syslog server on my network in an attempt to capture what might be happening when my network was dropping.

     

    I hadnt had much luck pin-pointing anything of interest until today. I found this happening right when all my devices were losing connecting to my network -

     

    2012-10-3115:45:52noticeairport-extremelocal080211Switching to channel 60
    2012-10-3115:45:52noticeairport-extremelocal080211Radar detected on channel 132
    2012-10-3115:45:52notice-airport-extremelocal080211Switching to channel 60
    2012-10-3115:45:52noticeairport-extremelocal080211Radar detected on channel 132

     

    It appears that the required DFS controls for these upper channels (in UK at least) are controlling things on their own (as designed to).

     

    I have turned my 5Ghz network to a fixed lower channel so I shouldn't get these network drops.

     

    If you don't hear from me, all went well!

  • aboutface Level 1 Level 1 (0 points)

    Spoke with Apple Care who fixed my intermittent network connection issues after having upgraded to Mountain Lion:

    This is what he asked me to do:

    1. Go to your Macintosh HD drive in Finder (system drive)

    2. Go to Library

    3. Drag the 'SystemConfiguration' Folder onto the Desktop (creates a BU copy - just in case)

    4. Delete the 'System Configuration' Folder within the 'Library Folder' (empty the Trash Bin - just in case)

    5. Reboot - This recreates the network files (automatically)

    6. That's it!

    Works now like a charm

    P.S.: Just in case if you have done custom network configurations, write them down first.

    PPS: I did the above and it works, but please don't hold me liable for anything you do on your own machine : )

  • aboutface Level 1 Level 1 (0 points)

    Spoke with Apple Care who fixed my intermittent network connection issues after having upgraded to Mountain Lion:

    This is what he asked me to do:

    1. Go to your Macintosh HD drive in Finder (system drive)

    2. Go to Library

    3. Drag the 'SystemConfiguration' Folder onto the Desktop (creates a BU copy - just in case)

    4. Delete the 'System Configuration' Folder within the 'Library Folder' (empty the Trash Bin - just in case)

    5. Reboot - This recreates the network files (automatically)

    6. That's it!

    Works now like a charm

    P.S.: Just in case if you have done custom network configurations, write them down first.

    PPS: I did the above and it works, but please don't hold me liable for anything you do on your own machine : )

  • jackflint Calculating status...

    I'm fairly sure you will find that the problem returns after a few days. This is definitely a router/hub security issue. The only way to get rid of this problem for good is to change your router/hub settings to WPA or WPA2. That's what myself and many others eventually had to do and my machine has been perfect ever since.

     

    Unfortunately, if you have older devices in your home that are not WPA compatible they will no longer be able to connect wirelessly to the internet. This is a huge drawback and is a shambles. Apple need a good kicking for this.

  • stevefromorpington Level 1 Level 1 (0 points)

    OK how about this, I think it ties in with some of the other comments above.  I started having this problem the day after Virgin Media installed my new router to take me from 20 to 60mb. My old router was set to WEP encryption and the new router is WPA2.  The problem manifests itself by dropping off the Mac version of MSN Messenger Version 8.  I have also tried it with Trillian and the same happens. While testing Trillian I had my Lenovo Win 7 machine running Windows Live Messenger and that stayed connected. The disconnect happens randomly but usually goes for a couple of hours before dropping out.   I am wondering if it is a problem associated with WPA2 and am thinking of taking the new router back to WEP to see what happens. Anyone got any ideas about this before I go ahead with the change? (I have 7 devises attached to the router unfortunately)

  • stevefromorpington Level 1 Level 1 (0 points)

    I have also tried the System Configuration file tip from aboutface above.  It didn't work.  I just got a message saying "Wifi: No Hardware Installed" and it did not regenerate the System Configuration so not sure what happened there.

    I am really hacked off with Apple. Had nothing but trouble with this machine since I bought it 6 weeks ago.... not impressed at all....

  • jackflint Level 1 Level 1 (0 points)

    I honestly think the only sure way of curing this problem is to completely remove all internet settings, change router to WPA or WPA2 and then start again from scratch. That is the only way my system could be cured.

  • RoxyAngel7 Calculating status...

    You are absolutely right!  My old router would not convert to WPA, it only did WEP. So I bought a new router lastnight and it automatically set to WPA2 Personal. I have not had a single problem since. No more disconnections. My iMac is working flawlessly.

     

    ***For everyone else reading this, I am not recommending that you go out and buy a new router, I am just saying it worked for me because my router was old. But check your routers to see if it can be set to WPA or WPA2. You will save yourself a lot of time and money. Otherwise you may have to go to your local Apple Store or Best Buy and purchase the Airport Express or something similar.***

  • Sea S Calculating status...

    I upgrated my MacBook Pro from 10.6.8 to Mountain Lion 3 days ago, and noticed this wifi dropping-reconnect issue right away, about every 30 minutes or so. I have a new router (Motorola brand) and setting is WPA2 Personal. I tried every thing mentioned all above, also tried every thing googled, but still have this issue. Finally yesterday night, I spent 2 hours to use my 10.6.x installation CD to bring my Mac back to 10.6.8 from timemachine back up which I made just before Mountain Lion upgrating... I'm back to old happy time now To me, Mountain Lion is nice except this wifi dropping thing, but not impressed...

  • RoxyAngel7 Level 1 Level 1 (10 points)

    How many devices can your router hold?

  • Sea S Level 1 Level 1 (0 points)

    The router is 'Motorola SBG6580 DOCSIS 3.0 Wireless Cable Modem'

    2 iphone, 2 MacBook Pro 17 (10.6.8), 2 Lenovo T410 (Win XP, Win 7), 1 Sony TV connect to the router through WiFi.

    2 Voice over IP phone connect to it through network cable directly.

     

    All devices are happy:-)

    When upgraded one MacBook Pro from 10.6.8 to Mountain Lion, it got WiFi dropping problem right away, but at meantime other MacBook Pro 10.6.8 has no problem. I'm waiting for Apple to fix that bug, I assume it is Mountain Lion bug as 10.6.x never has such problem, for Mountain Lion, after then I will try it again.

  • Sea S Level 1 Level 1 (0 points)

    BTW, one googled thing I didn't try: Force router to stay on Wireless-G only. Most new router will handle Wireless-A/B/G/N automatically (Manufacture's default setting). But someothers said they tested and found Mountain Lion WiFi driver is a little bit too sensitive to Wireless-N somehow. They set router to Wireless-G only, then the problem resolved... I don't know if that is true or not as I forgot to try that before rollbacked my Mac to 10.6.8. Right now I just don't want to spend another 3 hours, in case it is not true for my Mac, to test it out. But if someone has the issue now, then just give it a try and let me know the outcome...

  • Deal and Fix Calculating status...

    Yes, it does work - it has solved all my wifi issues.

     

    Selection on the router's WLAN page should be set to 802.11G ONLY and nothing else.

     

    My connection speed is strong and it feels like the internet again.....

1 ... 8 9 10 11 12 ... 16 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.