Skip navigation

Safari Hangs, then eventually loads page

2180 Views 5 Replies Latest reply: Nov 3, 2012 3:39 AM by hoppy2070 RSS
glgon Calculating status...
Currently Being Moderated
Oct 17, 2012 8:34 PM

I am having issues with Safari vers 6, running Mountain Lion.  When I go to a web page, the blue status bar displays approx 25% of the way, then hangs for a few minutes.  This happens to me several times a day.  I have Google Chrome on my MacBook Air as well.  If I open Chrome and type in the same web site URL, it comes up immediately, while Safari is still hanging.  After a few minutes, Safari will eventually load the page successfully.  Any ideas on what the issue is?

iMac, Mac OS X (10.6.7)
  • George Pinkham Calculating status...
    Currently Being Moderated
    Oct 18, 2012 5:08 PM (in response to glgon)

    Same issue here on an iMac running Mountain Lion.  Can take up to minutes to load a page... sometimes the page won't load at all.  Tried the DNS prefetching disabling -- no effect.  I highly doubt it has any router involvement, because as I waited for the page to load on my iMac, I found my phone (iOS6) and typed in the same web address and watched Safari on my phone load the page in about a third of a second.  I then grabbed my Macbook (running Lion) and did the same -- page loaded in about a half second.  Grabbed one of my kid's iPad (1) and watched the page load in a couple seconds.  And as I type, the page still hasn't loaded on the iMac...Suggestions?

     

    Also, when this happens (because sometimes Safari loads the page extremely fast), I notice that my mail will load slowly as well; if I'm listening to internet audio, it will frequently interrupt....

     

    Message was edited by: George Pinkham

  • Brenda Bell Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 29, 2012 3:31 PM (in response to glgon)

    Me too. It's not a router issue. All of my Windows, portable devices and pre-Mountain Lion Mac's do not have this issue. I've also launched the developer console and watched the requests -- the whole time I'm waiting, it really looks like Safari is doing absolutely nothing but spinning. Sometimes stopping the current request and refreshing will finish loading the page immediately, but not always.

     

    This has been happening for a few months now -- very annoying.

  • Muz Level 1 Level 1 (45 points)
    Currently Being Moderated
    Oct 30, 2012 3:07 PM (in response to glgon)

    I'll add to this. Safari loads between 25 to 50% of the page and then just sits there. On my iPhone or iPad there is no hang time. What gives?

  • hoppy2070 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 3, 2012 3:39 AM (in response to glgon)

    Mine did this a month ago after downloading  SW update. It did this for about a week then "bingo" it came good.  Could Apple have corrected a bug???

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.