4 Replies Latest reply: Apr 14, 2013 11:31 AM by SGMReno
HussainDawnman Level 1 Level 1 (0 points)

There is no power light no booting. the problem is no apple store or a known qualified apple technician around too. What shall I do.

Little back ground; I always keep the machine plugged in the power, could this be a good reason?


MacBook Pro, Windows 7
  • 1. Re: my Macbook pro is totally dead!
    clintonfrombirmingham Level 7 Level 7 (28,720 points)

    I always keep the machine plugged in the power, could this be a good reason?

     

    No - surely there is an Apple Authorized Service Provider around you somewhere?

     

    Sounds as if you have significant hardware failure - you'll need to take it to an AASP somewhere... no one here can fix it for you.

     

    Clinton

  • 2. Re: my Macbook pro is totally dead!
    wjosten Level 10 Level 10 (93,295 points)

    Read here:

     

    http://support.apple.com/kb/TS1365

     

    If no result, you can call AppleCare & they will arrange to have your computer shipped in for service. If your computer is no longer covered by AppleCare or you did not purchase such, you will have to pay for the call.

  • 3. Re: my Macbook pro is totally dead!
    HussainDawnman Level 1 Level 1 (0 points)

    Thank you gents for the suggestions. I took it to a store (i watch) that is the only one near me. I was promised to have it checked, but still in doubts they are qualified enough to deal with it.

    --------

    I think the problem happend when I did something silly by plugging a USB end and a connector at the other end wired to a digital receiver to flush that machine. I made that wire my self but had a problem figuring the colors of the 4 wire connections. It seems that the USB shorten something in the MacBook.

    Hope that is not bad.

     

    wires.jpg

  • 4. Re: my Macbook pro is totally dead!
    SGMReno Level 1 Level 1 (0 points)

    The System Management Controller reset fixed my totally dead MBP.  I had a similar problem as HussainDawnman with a USB spike and it bricked the machine...then the SMC reset brought it all back...good as before!