Skip navigation

iMovie project won't open

6661 Views 8 Replies Latest reply: Nov 4, 2012 5:46 AM by armyboy50 RSS
isign31 Calculating status...
Currently Being Moderated
Apr 17, 2011 8:03 AM

I made a movie project for my son last night (it's for his math class).  It was finally finished last night, but it was too late to share it to iDVD so I can burn it onto a disc that he can take to school tomorrow.  This morning, when I tried to open the project in iMovie so I can share it, iMovie doesn't recognize it.  When I double click on the movie, iMovie opens, but nothing is in the pane where I should see the project.  Why is it doing this, and how can I make it open?



PS - I'm using iMovie 11, 9.0. 

  • uncleho Calculating status...
    Currently Being Moderated
    Apr 17, 2011 8:11 AM (in response to isign31)

    Make sure that the project is located here: <user>/Movies/iMovie Projects/yourproject

    Also make sure that all the events you used in the video are here: <user>/Movies/iMovie Events/

    If the project is not there, that is the problem. iMovie only recognizes projects from there. Find the project you were working on via spotlight, and move it to the project folder. You should also look here:

    The person there had a similar problem, just with iMovie 08.

    Finally, make sure you have updated iMovie to the latest software. Check the software updates.

  • uncleho Level 2 Level 2 (180 points)
    Currently Being Moderated
    Apr 17, 2011 8:37 AM (in response to isign31)

    You are very welcome

  • lizsbs Calculating status...
    Currently Being Moderated
    Apr 18, 2011 4:38 PM (in response to uncleho)

    I am having the same issue but I'm using iMovie '08. I've already checked that the project file and events are in the specified folders but it's still not working. I've also checked for updates and the only one was to upgrade to iLife '11, which I don't want to do at this point.

  • uncleho Level 2 Level 2 (180 points)
    Currently Being Moderated
    Apr 19, 2011 5:44 AM (in response to lizsbs)

    Trash iMovie pref file - most often helps.


    *Not knowing the origin to Your problem - General approach when in trouble is as follows.*


    • Free space on internal (start-up) hard disk if it is less than 10Gb should rather have 25Gb


    • Delete iMovie pref file - or rather start a new user/account - log into this and re-try


    iMovie pref file resides.


    Mac Hard Disk (start-up HD)/Users/"Your account"/Library/Preferences


    and is named.


    While iMovie is NOT RUNNING - move this file out to desk-top.

    Now restart iMovie.


    • Hard disk is untidy. Repair Permissions, Repair Hard disk (Apple Disc Util tool)


    • Garageband-fix. Start it, Play a note and Close it. Re-try (Corrects an audio problem that hinders iMovie)


    • Screen must be set to Million-colors


    • Third party plug-ins that doesn't work OK (not relevant for iMovie’08 or 09)


    iMovie updated ?

    QuickTime updated ?

    Mac osx updated?


    You can also run "Cache Out X", clear out all caches and restarts the Mac

  • lizsbs Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 19, 2011 4:37 PM (in response to uncleho)

    There is no iMovie pref in my list of preferences. The free space on my internal hard disk is more than 25Gb. Everything is updated...


    I tried to create a new project and the same thing occurs. I can drag and drop media into the timeline but no preview shows in the preview pane and I can't export anything. I don't know if this information helps...but I just thought I'd explain more of what's going on.


    What should the project extension be in the iMovie projects file? The extension for the file that I'm having issues with is "(project title).rcproject"


    Please help! I've never had an issue like this before.

  • uncleho Level 2 Level 2 (180 points)
    Currently Being Moderated
    Apr 24, 2011 8:03 AM (in response to lizsbs)

    Yep. .rcoroject is right. Put in the Mac OS X programs disk you got with your mac (not the installation). Reinstall the iMovie program. That might fix it.

  • armyboy50 Calculating status...
    Currently Being Moderated
    Nov 4, 2012 5:46 AM (in response to isign31)

    He guyz i fixed this problem by going to the iMovie projects folder and double clicking it, i think it resets the file to allow editing/publishing, this is also why when you move the file back into it


    hope it helped!!


More Like This

  • Retrieving data ...

Bookmarked By (1)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.