Skip navigation

Choppy playback for iTunes movies

66053 Views 71 Replies Latest reply: Feb 26, 2014 8:15 PM by mstewie211 RSS Branched to a new discussion.
  • LSatch Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 7, 2012 2:07 AM (in response to facepalmmonkey)

    I have the same problem, I have tried all the suggestions and nothing. My computer is new and meets all the requirements for iTunes, it runs Win7 32 bits. Impossible to watch anything, all other players work well Windows Media Player, VLC Media Player, etc., but iTunes.

     

    I would appreciate some help, it is frustrating buying movies and not being able to watch after paying...

  • Chris_57 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 1, 2012 8:35 AM (in response to facepalmmonkey)

    Configurer le format audio de la carte son en Format cd ou dvd . J'avais aussi la lecture des vidéos saccadés avec iTunes 10 et 11sous windows 7, ma carte son était configurée en 24 Bits ,192000 Hz (Qualité Studio) ce qui a provoqué ce problème. Depuis la lecture est normale.

  • Chris_57 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 1, 2012 8:39 AM (in response to facepalmmonkey)

    Configure the audio format of the sound card CD or DVD format. I also had jerky video playback with iTunes 10 and 11For Windows 7, my sound card was configured with 24 bits, 192000 Hz (Studio Quality) causing this problem. Since reading is normal.

  • elizabeta82 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 21, 2012 5:06 PM (in response to facepalmmonkey)

    I've had this problem for a month. 

     

    I can't stay up late enough to watch The League, or It's Always Sunny, Justified, or The Walking Dead.  So I bought them from Itunes. 

     

    They're so choppy that they're unwatchable.  I know asking for a refund is laughable (even though I purchased a product and they did not fulfill their end of the bargain); so I'm not purchasing anything from Itunes anymore (unless i'm hammered).  I'll go to best buy for music, and put the songs into my library that way. 

     

    I'm sure Xbox Live has a way to buy these shows, so I'll give my cash to Microsoft; knowing that I'll be able to watch my shows.  And if I can't; I'm positive they'll have a fix for it quickly.  So, goodbye Apple, you've lost a customer.

     

    You've lost me over twenty some dollars; when if you'd had a competent support staff, who knows how much more money I'd have spent? 

  • foatbttpo1567 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 22, 2012 6:16 AM (in response to facepalmmonkey)

    I'm having this problem too. Using Windows 8 64-bit.

  • TyBod Calculating status...
    Currently Being Moderated
    Dec 24, 2012 8:26 AM (in response to facepalmmonkey)

    Ok guys...I think I may have something here. Make sure your computer's audio playback sound card is set to 16bit. Then make sure Quicktime's playback matches. Also, check the box labeled safemode(WaveOut only) under Play Audio Using/Audio/Quicktime settings.

     

    Now you may need to adjust between 44.1 kHz and 48khz in the advanced tabs for Audio to get it playing smooth. I'm thinking this just depends on the sound card you have. Just make sure the Quicktime Audio settings and your sound card Audio playback settings match!

     

    I have to run in compatibility mode windows Xp (service Pack 2) just to get a movie to play using iTunes. In Quicktime settings I have to run my video in Safe mode (GDI only) to get it to play, the audio and video still not staying synced. Then I had to do all the things mentioned above to get the Audio/Video to sync a stay synced.

     

    Running windows 7/ATI Radeon HD 4250 video card/running sound through basic hdmi/audio/vid cable.

     

    Hope this helps

  • TyBod Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 24, 2012 2:45 PM (in response to facepalmmonkey)

    I get the same thing when I play iTunes HD movies in Quicktime. Just a grey screen. No sound no picture. But, it begins the time count at the bottom when you press play as if it is playing. Also, quicktime is the only way you can adjust the playback options for video player in iTunes. Also, switching to the  iTunes mini player to play the movies seems to help too. I was having the same problems ever since iTunes 11 update. Just got it fixed today doing all the things mentioned in my first post. I used to watch all my movies with quicktime until it stopped playing the HD movies I bought from iTunes. SD movies purchased from iTunes play fine in quicktime.

  • TyBod Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 26, 2012 6:23 PM (in response to TyBod)

    Forget everything I posted above!!!! I fixed it and it has stayed fixed! The solution is 3 steps.

    1. Make sure everything involved (computer, cable, and monitor are all HDCP capable.

    2. Split the audio from the HDMI cable. So it is coming out of the speaker jack from the computer into external speakers ONLY. Do not send the audio through the HDMI cable.

    3. Disable wireless sync in iTunes for all devices. This will cause iTunes to pause the video while still playing sound. Then the video fast forwards to catch up with the audio.

  • TyBod Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 26, 2012 6:25 PM (in response to JAHStevenson)

    Disable wireless sync in iTunes for all devices. This will cause iTunes to pause the video while still playing sound. Then the video fast forwards to catch up with the audio.

  • TyBod Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 27, 2012 7:43 AM (in response to facepalmmonkey)

    It might not be possible to. Try updating the drivers for the laptop monitor display and video card. If playback is still choppy you need to figure out if your display/laptop/video-card can handle HDCP, HD vid, and HD audio all in one signal. My external monitor (Samsung tv) could not. So splitting the sound to a different audio device and hooking up external speakers worked for me.

  • Keifer.Street Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 31, 2012 2:04 PM (in response to Chris_57)

    This actually worked for me. Apparently, I had a separate audio manager other than the default Windows audio driver called Realtelk HD Audio Manager.

     

    I went into the 'Default Format' tab, changed the Default Format to 24Bits, 48000 Hz (Studio Quality), which is the 'DVD Format' preset.

     

    The instant I changed this setting the audio playback went to normal.

     

    Thanks a ton Chris, I've spent a lot of time trying to figure this out

     

    This has completely resolved this audio iTunes video playback issue for me 100%; FYI I have Windows 8 Pro 64bit and iTunes 11 installed.

    iTunes1.png

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.