Skip navigation

Thunderbolt display doesn't start after standby

9778 Views 43 Replies Latest reply: May 11, 2013 12:41 PM by aelogica.sts RSS
  • TheDanDev Calculating status...

    I thought the latest update fixed things.  And it did make it better.  I am still experiencing intermittend problems when waking up from sleep, even with 10.8.2.  The thunderbolt display doesn't come on  unless I unplug and plug in.


    Both my MacBook and Thunderbolt display are under a year old and therefore still under warranty.  I never considered this a hardware issue until now.  Maybe it is an issue and I need to go to the Apple Store and see what they can do.


    The problem is that I am not sure I could reproduce it at the Apple Store with my setup.  I have tried unsuccessfully to set the sleep time to 1 min and display timeout to 1 min and the display always comes on afterwards.  It only seems that this problem occurs when the display is sleeping for a very very long period of time - like overnight.


    Any advice?

  • Barry Breen Level 1 Level 1 (70 points)
    Currently Being Moderated
    Oct 13, 2012 4:13 PM (in response to TheDanDev)

    Have you commanded re-starts and sleep from the Thunderbolt Display with the clamshell closed and/or open? You might be able to successfully make the problem reocur. Then, if you have an extra Thunderbolt Cable try the workaround I mentioned to see if it is resolved. But, obviously, you need to make the problem repeat itself under some repeatable scenario. Also, try and re-start the computer with everything connected (you shouldn't have to monkey with connecting or disconnecting any cables). By the way, as easy way to know if you have replicated the problem is to click on the Menu Bar Speaker Icon to adjust volume. The resulting sound should come from the display. If it comes from the computer, you obviously have re-created the problem.


    Make sure that in your Energy Saver Prefs that after all the investigation you have done that the settings allow for sleep, etc.


    Also you might try shutdown from the display, and then startup from the computer with everything connected properly. That might successfully re-create the scenario repeatably.


    Sounds like you have a tough one to duplicate.


    Good luck!


    Message was edited by: Barry Breen to add an extra comment.

  • TheDanDev Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 13, 2012 4:17 PM (in response to Barry Breen)

    I actually just thought of something.  If I remember correctly, the last few times this happened was overnight when I woke up in the morning and turned on the MacBook.  I had to actually click the power button on the MBP to get everything to come on again.  To me this indicated the MBP was in DeepSleep or "hibernating". 


    To the life of me, I can't simulate a hibernation and I didn't think it would hibernate automatically when the power was connected.  Any ideas how I could simulate a hibernation (not a sleep) to test this theory?

  • Barry Breen Level 1 Level 1 (70 points)
    Currently Being Moderated
    Oct 13, 2012 4:26 PM (in response to TheDanDev)

    Dan, the only way I know to cause "hybernation" is when the battery runs down to about 7% or something like that. I have all the boxes checked under the "Power Adapter" tab of energy saver with a one hour computer sleep time.


    I do know what you are talking about because when I had the issue I recall the display difficult to wake up. I read somewhere that when you go to wake up the machine after overnight and you open the clamshell, if you start pressing buttons and get impatient the doggone machine can actually get confused as to what state it is in. I know that sounds ridiculous, but I've seen something like that happen.


    Sorry I can't be of more assistance.



  • TheDanDev Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 14, 2012 10:07 AM (in response to Barry Breen)

    Thanks for the help.


    I discovered today that it's not a hibernation issue.  It just happened again after the MP being a sleep for only a minute or two.  Very very intermittent.


    I found by unplugging the power to the TBD and plugging it back in also turns the TBD back on.


    Yuck....  tough to diagnose and reproduce.

  • Barry Breen Level 1 Level 1 (70 points)
    Currently Being Moderated
    Oct 14, 2012 1:14 PM (in response to TheDanDev)

    DanDev, that's exactly what mine was doing, including the intermittent thing with the power plug on the disiplay. I'd almost bet you have the same situation as me with the All-in-One cable. If you can get a regular Thunderbolt cable try doing what I did to plug in to the Thunderbolt port on the TD with the other end into the computer. If all works after that, I'd say your 99% sure of a TD issue with the All-in-One cable, etc. But, the only way you can narrow that down is with the cable.

  • Richatom Level 1 Level 1 (20 points)

    Add me to the list of sufferers.


    In my case there is no consistency. The problem seems to occur randomly. Sometimes TB wakes up after an overnight sleep, sometimes it wont wake up even after a few minutes nap.

  • betadecay Calculating status...

    I have also this annoying wake up problem. TB just remains black... Due to some other issues, the TB logic board was removed in my case, so i think we can exclude that the problem is connected to a LB defect in our case.

  • betadecay Level 1 Level 1 (0 points)

    So, you used the one TB ports(besides USB etc.) on the back of the Display? And did your replacement solved the problem? So you are sure that the All-in-one cable had a defect?

  • Barry Breen Level 1 Level 1 (70 points)
    Currently Being Moderated
    Nov 3, 2012 11:44 AM (in response to betadecay)

    Yes that is how I stumbled onto both a temporary workaround and the cause of the problem for my display. Yes, my replacement works absolutely perfect (no messing around with cables or any particular turn on procedure). It was either the all in one cable (most likelly) or the electronics in the display leading to the built in cable.


    By the way, I have two LaCie SSD Thunderbolt backup drives connected via Thunderbolt through the Thunderbolt port on the display now; so, my usual procedure when I remove the MBP-R is to eject the drives before unplugging the displaya from my computer (so that the drives are ejected properly). But, other than that I really have so specific procedure, and the new display that Apple sent me works every time.


    Thanks for asking.



  • Richatom Level 1 Level 1 (20 points)

    I think my problem may have been due to Parallels. With the latest Parallels update, it now seems to be working as expected.

  • Richatom Level 1 Level 1 (20 points)
    Currently Being Moderated
    Nov 8, 2012 10:35 AM (in response to Richatom)

    I spoke too soon. My thunderbolt has now started to get sleepy again.

  • Barry Breen Level 1 Level 1 (70 points)
    Currently Being Moderated
    Nov 8, 2012 10:53 AM (in response to Richatom)

    Richatom, that is the signature of this particular issue (its randomness that can make you think you resolved it). Hey, you plug the display in to the computer and it should work, period. Without having to do anything special (unless Apple had specific start-up or shut-down instructions, which they don't). Hope you get it resolved. You always have my workaround (that costs you a cable). I used the cable workaround to demonstrated to Apple that the display needed replacement or repair. The one thing I could do with the cable test was to demonstrate that the display would always work properly with it, always. And, without, it was random whether it worked properly, most times not.


    Best regards. Barry

  • Richatom Level 1 Level 1 (20 points)
    Currently Being Moderated
    Nov 13, 2012 8:09 AM (in response to Barry Breen)

    This seems to have been fixed by the patch released a few days ago.

  • Barry Breen Level 1 Level 1 (70 points)
    Currently Being Moderated
    Nov 13, 2012 10:47 AM (in response to Richatom)

    The problem I originally had was not a software issue. Apple verified it was a hardware issue. No software patch could resolve it. Glad your problem was resolved.


More Like This

  • Retrieving data ...

Bookmarked By (3)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.