Skip navigation

Netflix pausing/buffering issues

304278 Views 717 Replies Latest reply: Jan 8, 2014 10:44 AM by tommy2103.87 RSS
  • jimpal Level 1 Level 1 (35 points)
    Currently Being Moderated
    Nov 5, 2012 8:23 AM (in response to hairyfil)

    hairfill says;

     

    "Seems odd that they wouldn't code the app to buffer in this day and age."

     

    While this is only conjecture on my part, I think this relates to the business model each company has, and Netflix's arrangements with component suppliers (like Apple) who provide their service.

     

    Apple charges for rentals of movies, TV shows, etc., through iTunes when you watch them on an Apple TV. When you do pay your $1.99 - $5.99 (whatever) to rent, you have that show for 24 hours to watch again. It can just stay there in your ATV's memory.

     

    On the other hand, with Netflix, all of the money goes to Netflix, and they may not allow ATV's (or other devices) to hold a buffer on their memories (if any) either. They may just insist that straight non-buffered streaming is all they will allow with their business arrangements. That's all I can get with my Oppo BluRay player, for instance. Recently I was unable to get Netflix on my ATV3 for a few days unless I downgraded it to 720p from 1080p video. A call to Netflix service confirmed there was a problem with ATV3's "which will be fixed soon." A few days later it automatically fixed itself, with no need for a software update from Apple.

     

    I still think the main problem is your internet supply speed or wireless connection. Have you taken an iPad or iPhone to the site where your bad-performing sits in your house, and then run the free SpeedTest app to see how you do? If you dont have at least 6Mbps internet speed there you have found the problem. Although, you could also be receiving periodic interference from neighbors or your wireless phones, etc (iStumbler will help you find that).

     

    I'm not here to toot the horn for Apple, but just relating my experiences. Hope it helps, and you get this fixed soon.

  • hairyfil Calculating status...
    Currently Being Moderated
    Nov 5, 2012 10:10 AM (in response to jimpal)

    I think you could well be correct as there shouldn't be any technical limitations to the Netflix app buffering.

    I'll do what you suggest & check speedtest during a netflix slow down. However I've never seen my link from under 10mbps and usually I get 11-13mbps.

     

    No interference as I'm not using wifi.

  • darthstuey Calculating status...
    Currently Being Moderated
    Nov 7, 2012 11:53 AM (in response to hairyfil)

    I don't understand this at all. There must be hundreds of forum pages about this issue- it's not by any means an isolated incident.

     

    I have had to simply unplug Apple TV and put PS3 in its place. This, along with PC, laptop and iPad, streams Netflix with no issues at all. Up until a few weeks ago the Apple TV was also fine.

     

    There has to be something to this but I can't find any answers at all. The only thing I do know is, is that I'm not going to be buying my son the Apple TV he wanted for his room for Christmas. It's pointless if it won't stream Netflix.

     

    I'm now faced with the stupid situation where I have to swap an HDMI lead between PS 3 for Netflix and ATV for mirroring, music etc. I bought the ATV to do all these things in one beautiful little box. I'm gutted.

  • oeight74 Calculating status...
    Currently Being Moderated
    Nov 7, 2012 12:31 PM (in response to darthstuey)

    This is what worked for me. It was posted by BenFinklea so he deserves the credit. Since I've done these steps I've had no streaming issues. I agree that it's an Apple issue and not a Netfix one. All my other devices on and off the same network stream just fine. To test this I even bought a Roku LT which I love, especially for the money and it streamed flawlessly. I perfer the format of my Apple TV so I was glad to have it operational again! Good luck.

     

    Use Google’s Public DNS Server To Fix Apple TV Streaming Problems

     

    1. Navigate to Settings >> General >> Network and select Configure TCP/IP.

     

    2. Select “Manually” next to Configure IP.

     

    3. Dont change the IP address or the Subnet Mask and Router Address. Just click "Done".

     

    4. Set the DNS Address screen with the following: 008.008.008.008 and click “Done.”

     

    You should now be able to stream Netflix on your Apple TV.

  • icminc Calculating status...
    Currently Being Moderated
    Nov 7, 2012 12:31 PM (in response to RebeccaA)

    Darthstuey

    I'm with you on this. I have two 2nd Gen units. Since the latest software update, I've had nothing but Netflix issues. The one that I did not update still works great with no issues at all. This is 100% Apple issue. Its has nothing to do with the location of the units or download speed as previous people have mentioned. I swapped both units and my speed is fine. It used to work fine but what ever was included in this last update is causing the issue.

     

    There is a glitch somewhere in the latest update. Its the only thing that makes sense. Nothing has changed on my end except the one unit was updated. Go Figure.

     

    Did you update your ATV Recently?

     

    This is what I have found so far that makes the most sense

     

    It appears that Netflix have the ability to dynamically change the bandwidth used by each customer during peak times as well as the ability to set the bandwidth used by a customer based on the customers own available bandwidth. These mechanisms, working together, allow the largest number of customers access to Netflix videos and movies during peak times with only a slight degradation in video quality. Although I'm against throttling when used indiscriminately, this particular application makes sense, the alternative is that customers find themselves unable to watch movies during peak times or suffer timeouts or impossibly slow access. This arrangement works well on devices that use an up-to-date Netflix client or browser access, however the Apple TV is, at the moment, where is goes all pear shaped.

     

    I noticed that the AppleTV Netflix app would never dynamically alter the bandwidth used by a streaming video once it had started playing, in fact it seems as though it always plays the video at the highest quality possible even when it would involve a significant time spent buffering before playing. If Netflix does dynamically reduce bandwidth during peak times it would make sense that the AppleTV, unwilling or unable to downshift to a lower bitrate, would start to suffer stalls and constant buffering as it starved for data. Needless to say, this results in a horrible experience for the viewer.

     

     

     

    Watching a movie on Netflix is not supposed to involve ripping your system configuration apart. This should be a simple plug and play feature. If you can rent a movie using the ATV then Netflix should work. Its that simple or its supposed to be.

  • icminc Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 7, 2012 12:33 PM (in response to oeight74)

    oeight74,

    I tried this and it hasnt made any difference for me.

  • oeight74 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 7, 2012 12:40 PM (in response to icminc)

    ****, I'm sorry to hear that. Sell you Apple TV and get a Roku LT for $49.99 with free shipping on their website.

     

    I still use the one I purchased in my bedroom and as a back up if my Apple TV decides to crap out again.

  • darthstuey Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 7, 2012 1:16 PM (in response to oeight74)

    I use PlaymoTV and their DNS as UK Netflix is appalling. If I used Google I would go back to UK Netflix wouldn't I? I actually thought it was Playmo's DNS but I reset ATV and went back to normal DNS but the issue prevails.

  • roccoboy Calculating status...
    Currently Being Moderated
    Dec 3, 2012 8:06 PM (in response to rooseveltfromny)

    this seemed to work for me! changed to Standard Definition, played on Netflix...and then changed it back to 1080p and it is still working fine now.

  • icminc Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 3, 2013 11:13 AM (in response to RebeccaA)

    Finally got it figured out.

    I discovered that my Airport Express unit needed the latest firmware update in order for it to maintain a connection. For some reason, the latest update for the ATV threw them out of sinc and caused them to periodically stop communicating with each other. This is why Netflix would just stop while watching something.

    I updated the firmware and all has been perfect for the last week or so.

    I discoverd the problem while I was trying to stream music from my iPad and iPhone using Airplay to the ATVand it started cutting out after a few minutes. I then noticed that the Airplay icon actually was disappearing. After a little bit of digging online, I discovered that the problem was with the airport station and the fix was a firmware update.

    Not sure if anyone experiencing the  problems with Netflix on ATV are streaming thru an Apple Airport but if so, a firmware update worked for me and now Netflix and Airplay work seamlessly.

    Good luck everyone.

  • Casual Man Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 3, 2013 2:00 PM (in response to icminc)

    Thank you for posting this...I have been having the same problem just lately and with the holidays and the kids, etc. I haven't had time to research. I'm going to update my Airport firmware tonight and hope for the best.

  • hjno72 Calculating status...
    Currently Being Moderated
    Jan 8, 2013 8:14 AM (in response to RebeccaA)

    Apple TV is having issues with DHCP.

     

    Solution

    Configure Static ip for Apple TV on router

    Configure manual ip on Apple TV. This is necessary else the Apple TV will continue to make dhcp calls which is the cause of the buffering.

  • jimpal Level 1 Level 1 (35 points)
    Currently Being Moderated
    Jan 8, 2013 8:26 AM (in response to hjno72)

    To hjno72: It's good to see that this technique works for you, but honestly it isn't necessary.

     

    For both of my Apple TV's (one ATV2 and one ATV3) Netflix works perfectly without any buffering, ever. I use a new Time Capsule as my router, and all of the equipment's software is up to date. The Time Capsule is connected to a high-speed Comcast system (30 mbps) and I have excellent wireless connections to both ATV's. All settings are default (no special DHCP, etc.).

     

    I still say the answer to all ATV buffering issues is to have a strong and fast wireless internet connection, free from interference from neighbors, etc.

  • hjno72 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 8, 2013 8:35 AM (in response to jimpal)

    I have a netgear router. Setting static addresses were the only solution that worked. It's been working for over a week.

  • hjno72 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 8, 2013 8:41 AM (in response to hjno72)

    Ps. I have a 2mb line

Actions

More Like This

  • Retrieving data ...

Bookmarked By (13)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.