Skip navigation

Airplay icon missing from multiple devices; receiver missing from local network

26494 Views 39 Replies Latest reply: Nov 5, 2013 2:21 AM by IvanLaw RSS
  • FredRx Calculating status...

    Good call.  I'd be surprised if there aren't already some ongoing discussions related to these issues.

  • jgweiner Calculating status...

    In case you all didn't find the resolution to the wired/wireless issue here it is.  I too have Verizon FIOS and experienced the same exact symptoms as described above (except that I have a Pioneer VSX-1122 and not a Denon).  Simply disabling IGMP Proxy immediately fixed all of my problems.  Not sure why everything worked fine to begin with and then stopped but in any event, it's resolved.

     

    • If using a Verizon Actiontec router .... on the router, go to Advanced (accept the warning) and go to the IGMP Proxy menu and disable IGMP Proxy which should resolve the issue.  The issue here generally only presents when the AVR is wired directly to the Actiontec router and the iDevice is connected wirelessly.  Note however, that if streaming IPTV, disabling this proxy will also disable the IPTV connection, so in that case you'll need to leave IGMP enabled and place an ethernet switch between the Actiontec and the rest of the network.
  • Claibo Calculating status...

    Thank you very much for this....I have been struggling with this for a while and this worked!!

  • Johnkos Calculating status...

    My recent experience was I added an Linksys ip camera to the network. I lost all AirPlay but not Internet.  I removed the camera and all devices showed up with AirPlay again. So some device on the network may be the issue.

  • Aloke Level 1 Level 1 (0 points)

    Oddly enough, in my case with Windows PC's, Netgear WNDR3800 router and 2 Netgear switches, the Airplay icon is now reliably available by unchecking "Disable IGMP Proxying" (ie, enabling IGMP Proxy) setting on my router WAN setup page.

    Could be a coincidence ....

  • carlos179 Calculating status...
  • rogue03 Calculating status...

    After 12 hours of trying to figure this out I stummbled on to this post, Thanks much!! I upgraded Verizon routers yesterday and this morning I couldn't figure out why my airplay didn't work anymore, glad you posted this.

  • rgazzara Calculating status...

    OMG!!  IT WORKED!!

     

    I disabled the IGMP Proxy on my Verizon FiOS router and now I can connect to my stereo through my Airport Express AND the Remote App on my Apple iPod Touch works again.  I can play my iTunes library on my stereo again.

     

    I have been trying to solve this problem for MONTHS with no solution.  I tried everything.

     

    jgweiner, thanks a million, you are a genius.

  • ElanX Calculating status...

    Thanks for the IGMP Proxy tip. My AirPlay stopped working seemingly out-of-the-blue. I thought maybe the FiOS router auto-updated firmware. Someone mentioned an IP Camera being the issue, and I do have some, but didn't make any changes with them. Oh well, works now.

     

    What are the downsides to the disabled IGMP Proxy?

  • Jscharps Calculating status...

    Hello everyone,

     

    I had the same problem.  iTunes on Mac, iPhone, and iPad, wouldn't recognize pioneer vsx1021 receiver via airplay.  This all began when I purchased a new wireless router. (Cisco EA 2700).  Receiver was direct wired to wireless router.  Pioneer and Cisco techs were no help!   I decided to restore router to factory settings and start all over.  Once I did this, I noticed that all my apple products could recognize my pioneer receiver via airplay.  (Yeah).  However, after getting all of my components connected to the Internet, I did my final step of changing the SSID name to my 5.0 ghz band so i could view the two different wireless networks.  To my amazement I lost the airplay recognition to my receiver again!   It seems the problem is with routers with dual band capabilities.  After diagnosing this problem, I called cisco and spoke with a level 2 tech.  We did the following:

     

    1.  Opened the wireless setting on my router

    2.   Changed "channel width" from auto to 20 MHz only

    3.  Changed "channel" from auto to channel 9.

    4.  Applied settings

    5.  Unplugged power to router.

    6. Waited 30 seconds and reconnected power to router.

     

    Problem solved!   I can now do airplay from all my apple products to my pioneer receiver!

     

    Hope this helps everyone!  

  • Uldix Calculating status...

    Hello,

    We have few iPhones in our family, few days ago found that all have same problem - Airplay icon dissapeared.

    We have a Linksys router without function IGMP (at least I did not found it), tried to restart router but it did not help, some minutes later my son logged in router and refreshed settings and we found that this was helpfull.

    Anyway thanks to your discussion I started to looking for problem in router, not in iPhones.

    Thank you all.

  • jcairn Calculating status...

    Not exactly the same problem, but had a similar issue.

    I had to replace my integrated DSL modem/router/wireless, and bought the Actiontec GT784WN.  Its router software seems to be very similar to other Actiontec models.

    After putting in the router, I lost all my Airplay and home sharing on the network.  I read lots of posts, and tried the following, with device restarts in between each step:

     

    • Disable IGMP - Still no airplay/home sharing
    • Disable 802.11b on Wireless Radio settings - Still no airplay/home sharing
    • Disable WPS - Still no airplay/home sharing
    • Change wireless security setting to WPA Personal / AES (formerly WPA-WPA2 Personal / BOTH)

     

    The last change worked - all Airplay and home sharing is back online.

  • andiamo71 Calculating status...

    Wow...this has been driving me crazy.  I had the same Airplay issue with my new Harmon Kardon AVR 1700 receiver.  It was seeing my HTPC, which is wired, but not my iPhone or Macbook Pro on wifi.  I also have FIOS and disabled IGMP and voila! Instantly Airplay is showing up on my iPhone and Macbook Pro. Also, the Harmon Kardon app that I downloaded for my iPhone-which wasn't finding the receiver before-now is finding it.  This seems to have been the needle in the haystack that I couldn't find to fix the problem.  Thanks!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.